summaryrefslogtreecommitdiff
path: root/gnu/packages/messaging.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/messaging.scm')
-rw-r--r--gnu/packages/messaging.scm52
1 files changed, 38 insertions, 14 deletions
diff --git a/gnu/packages/messaging.scm b/gnu/packages/messaging.scm
index cbb4d4eaba..89df0970d6 100644
--- a/gnu/packages/messaging.scm
+++ b/gnu/packages/messaging.scm
@@ -1,6 +1,6 @@
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2014, 2015, 2016 Mark H Weaver <mhw@netris.org>
-;;; Copyright © 2014 Julien Lepiller <julien@lepiller.eu>
+;;; Copyright © 2014, 2017 Julien Lepiller <julien@lepiller.eu>
;;; Copyright © 2015 Taylan Ulrich Bayırlı/Kammer <taylanbayirli@gmail.com>
;;; Copyright © 2015 Andreas Enge <andreas@enge.fr>
;;; Copyright © 2015, 2016, 2017 Ricardo Wurmus <rekado@elephly.net>
@@ -166,17 +166,31 @@ identi.ca and status.net).")
(define-public hexchat
(package
(name "hexchat")
- (version "2.12.2")
+ (version "2.12.4")
(source (origin
(method url-fetch)
(uri (string-append "https://dl.hexchat.net/hexchat/hexchat-"
version ".tar.xz"))
(sha256
(base32
- "1xnclfbrgbkqndxygi5f27q00jd7yy54jbd1061jmhxa6wzpibbd"))))
+ "0ficrx56knz5y297qb0x5y02339yvyv734z7kpcx1ixvb0qr2dgs"))
+ (modules '((guix build utils)))
+ (snippet
+ '(begin
+ ;; Delete dangling symlinks to a non-existent ‘/usr’.
+ (with-directory-excursion "m4"
+ (for-each (lambda (f) (delete-file f))
+ '("intltool.m4" "libtool.m4" "lt~obsolete.m4"
+ "ltoptions.m4" "ltsugar.m4" "ltversion.m4")))
+ (delete-file-recursively "build-aux")
+ (delete-file "po/Makefile.in.in")))))
(build-system gnu-build-system)
- (native-inputs `(("pkg-config" ,pkg-config)
- ("intltool" ,intltool)))
+ (native-inputs `(("autoconf" ,autoconf)
+ ("autoconf-archive" ,autoconf-archive)
+ ("automake" ,automake)
+ ("intltool" ,intltool)
+ ("libtool" ,libtool)
+ ("pkg-config" ,pkg-config)))
(inputs `(("dbus-glib" ,dbus-glib)
("dbus" ,dbus)
("enchant" ,enchant)
@@ -190,6 +204,17 @@ identi.ca and status.net).")
("luajit" ,luajit)
("perl-xml-parser" ,perl-xml-parser)
("python-2" ,python-2)))
+ (arguments
+ `(#:phases
+ (modify-phases %standard-phases
+ ;; Release 2.12.4 wasn't properly bootstrapped. Later ones might be!
+ (add-after 'unpack 'bootstrap
+ (lambda* (#:key inputs #:allow-other-keys)
+ ;; This file is still required for autoreconf.
+ (copy-file (string-append (assoc-ref inputs "intltool")
+ "/share/intltool/Makefile.in.in")
+ "po/Makefile.in.in")
+ (zero? (system* "autoreconf" "-fiv")))))))
(synopsis "Graphical IRC Client")
(description
"HexChat lets you connect to multiple IRC networks at once. The main
@@ -434,24 +459,23 @@ simultaneously and therefore appear under the same nickname on IRC.")
(define-public python-nbxmpp
(package
(name "python-nbxmpp")
- (version "0.5.3")
+ (version "0.5.5")
(source
(origin
(method url-fetch)
- (uri (string-append "https://pypi.python.org/packages/source/n/nbxmpp/"
- "nbxmpp-" version ".tar.gz"))
+ (uri (pypi-uri "nbxmpp" version))
(sha256
(base32
- "0dcr786dyips1fdvgsn8yvpgcz5j7217fi05c29cfypdl8jnp6mp"))))
+ "1gnzrzrdl4nii1sc5x8p5iw2ya5sl70j3nn34abqsny51p2pzmv6"))))
(build-system python-build-system)
- ;; No tests included
- (arguments `(#:tests? #f))
- (home-page "http://python-nbxmpp.gajim.org")
+ (arguments
+ `(#:tests? #f)) ; no tests
+ (home-page "https://dev.gajim.org/gajim/python-nbxmpp")
(synopsis "Non-blocking Jabber/XMPP module")
(description
"The goal of this python library is to provide a way for Python
applications to use Jabber/XMPP networks in a non-blocking way. This library
-was initially a fork of xmpppy, but is using non-blocking sockets.")
+was initially a fork of xmpppy, but uses non-blocking sockets.")
(license license:gpl3+)))
(define-public python2-nbxmpp
@@ -1002,7 +1026,7 @@ for @uref{https://torproject.org,tor} router) and many more.")
(synopsis "Perl implementation of PSYC protocol")
(home-page "http://perlpsyc.psyc.eu/")
(license (list license:gpl2
- (package-license perl)
+ license:perl-license
;; contrib/irssi-psyc.pl:
license:public-domain
;; bin/psycplay states AGPL with no version: