summaryrefslogtreecommitdiff
path: root/gnu/packages/ncurses.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/ncurses.scm')
-rw-r--r--gnu/packages/ncurses.scm8
1 files changed, 4 insertions, 4 deletions
diff --git a/gnu/packages/ncurses.scm b/gnu/packages/ncurses.scm
index 3b2f9b15f9..c19fe6d990 100644
--- a/gnu/packages/ncurses.scm
+++ b/gnu/packages/ncurses.scm
@@ -330,8 +330,9 @@ of your system.")
"1460d5lc780p3q38l3wc9jfr2a7zlyrcra0li65aynj738cam9yl"))))
(build-system gnu-build-system)
(arguments
- '(#:tests? #f ; no test target
- #:make-flags (list (string-append "prefix=" (assoc-ref %outputs "out")))
+ `(#:tests? #f ; no test target
+ #:make-flags (list (string-append "prefix=" (assoc-ref %outputs "out"))
+ (string-append "CC=" ,(cc-for-target)))
#:phases
(modify-phases %standard-phases
(delete 'configure) ; there is no configure script
@@ -339,8 +340,7 @@ of your system.")
(add-before 'build 'patch-ncursesw
(lambda _
(substitute* "stfl_internals.h"
- (("ncursesw/") ""))
- #t))
+ (("ncursesw/") ""))))
(add-after 'install 'install-missing-symlink
(lambda* (#:key outputs #:allow-other-keys)
(let* ((out (assoc-ref outputs "out"))