summaryrefslogtreecommitdiff
path: root/gnu/packages/networking.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/networking.scm')
-rw-r--r--gnu/packages/networking.scm55
1 files changed, 48 insertions, 7 deletions
diff --git a/gnu/packages/networking.scm b/gnu/packages/networking.scm
index d4b9a3d129..2f4d3d233e 100644
--- a/gnu/packages/networking.scm
+++ b/gnu/packages/networking.scm
@@ -9,7 +9,7 @@
;;; Copyright © 2016 Nicolas Goaziou <mail@nicolasgoaziou.fr>
;;; Copyright © 2016 Eric Bavier <bavier@member.fsf.org>
;;; Copyright © 2016, 2017 ng0 <ng0@libertad.pw>
-;;; Copyright © 2016 Arun Isaac <arunisaac@systemreboot.net>
+;;; Copyright © 2016, 2017 Arun Isaac <arunisaac@systemreboot.net>
;;; Copyright © 2016 Benz Schenk <benz.schenk@uzh.ch>
;;; Copyright © 2016, 2017 Pjotr Prins <pjotr.guix@thebird.nl>
;;; Copyright © 2017 Mathieu Othacehe <m.othacehe@gmail.com>
@@ -70,6 +70,7 @@
#:use-module (gnu packages textutils)
#:use-module (gnu packages tls)
#:use-module (gnu packages valgrind)
+ #:use-module (gnu packages wm)
#:use-module (gnu packages xml)
#:use-module (ice-9 match))
@@ -1103,7 +1104,7 @@ gone wild and are suddenly taking up your bandwidth.")
(define-public nzbget
(package
(name "nzbget")
- (version "18.1")
+ (version "19.1")
(source
(origin
(method url-fetch)
@@ -1112,14 +1113,22 @@ gone wild and are suddenly taking up your bandwidth.")
(file-name (string-append name "-" version ".tar.gz"))
(sha256
(base32
- "1a8wmbhc1si1n8axzrr8ysmrd3gr643lbh6pvzmr0hnd65fixmx5"))))
+ "0y713g7gd4n5chbhr8lv7k50rxkmzysrg13sscxam3s386mmlb1r"))
+ (modules '((guix build utils)))
+ (snippet
+ ;; Reported upstream as <https://github.com/nzbget/nzbget/pull/414>.
+ '(begin
+ (substitute* "daemon/connect/TlsSocket.cpp"
+ (("gnutls_certificate-verification_status_print")
+ "gnutls_certificate_verification_status_print"))
+ #t))))
(arguments
`(#:configure-flags
(list
- (string-append "--with-libcurses-includes=" (assoc-ref
-%build-inputs "ncurses") "/include")
- (string-append "--with-libcurses-libraries=" (assoc-ref
-%build-inputs "ncurses") "/lib")
+ (string-append "--with-libcurses-includes="
+ (assoc-ref %build-inputs "ncurses") "/include")
+ (string-append "--with-libcurses-libraries="
+ (assoc-ref %build-inputs "ncurses") "/lib")
(string-append "--with-tlslib=GnuTLS"))))
(build-system gnu-build-system)
(inputs `(("gnutls", gnutls)
@@ -1387,3 +1396,35 @@ newer and only works on Ethernet network interfaces.")
;; AGPL 3 with exception for linking with OpenSSL. See the 'LICENSE' file in
;; the source distribution for more information.
(license license:agpl3)))
+
+(define-public bmon
+ (package
+ (name "bmon")
+ (version "4.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "https://github.com/tgraf/bmon/releases/download/v"
+ version "/bmon-" version ".tar.gz"))
+ (sha256
+ (base32
+ "0ylzriv4pwh76344abzl1w219x188gshbycbna35gsyfp09c7z82"))))
+ (build-system gnu-build-system)
+ (inputs
+ `(("libconfuse" ,libconfuse)
+ ("libnl" ,libnl)
+ ("ncurses" ,ncurses)))
+ (native-inputs
+ `(("pkg-config" ,pkg-config)))
+ (synopsis "Bandwidth monitor")
+ (description "bmon is a monitoring and debugging tool to capture
+networking-related statistics and prepare them visually in a human-friendly
+way. It features various output methods including an interactive curses user
+interface and a programmable text output for scripting.")
+ (home-page "https://github.com/tgraf/bmon")
+ ;; README.md mentions both the 2-clause BSD and expat licenses, but all
+ ;; the source files only have expat license headers. Upstream has been
+ ;; contacted for clarification: https://github.com/tgraf/bmon/issues/59
+ ;; Update the license field when upstream responds.
+ (license (list license:bsd-2
+ license:expat))))