summaryrefslogtreecommitdiff
path: root/gnu/packages/ocaml.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/ocaml.scm')
-rw-r--r--gnu/packages/ocaml.scm16
1 files changed, 8 insertions, 8 deletions
diff --git a/gnu/packages/ocaml.scm b/gnu/packages/ocaml.scm
index 96659632bf..e0bedf74f9 100644
--- a/gnu/packages/ocaml.scm
+++ b/gnu/packages/ocaml.scm
@@ -1718,7 +1718,7 @@ full_split, cut, rcut, etc..")
(define dune-bootstrap
(package
(name "dune")
- (version "3.5.0")
+ (version "3.6.1")
(source (origin
(method git-fetch)
(uri (git-reference
@@ -1727,7 +1727,7 @@ full_split, cut, rcut, etc..")
(file-name (git-file-name name version))
(sha256
(base32
- "10fpybiqqkmm7y9xmhy4qs451dydmffcjg13k7w8g2p9dd09jb6l"))))
+ "0gv851wxbv5ln20429nj7p92spzxgw8vngg9z94q39aawn6q8lx6"))))
(build-system ocaml-build-system)
(arguments
`(#:tests? #f; require odoc
@@ -2085,14 +2085,14 @@ defined in this library.")
(define-public ocaml-topkg
(package
(name "ocaml-topkg")
- (version "1.0.5")
+ (version "1.0.6")
(source (origin
(method url-fetch)
(uri (string-append "http://erratique.ch/software/topkg/releases/"
"topkg-" version ".tbz"))
(sha256
(base32
- "1iyinmcfqpprk7k4cc51nqgypayprbj4larwcfqw86k5dri84825"))))
+ "11ycfk0prqvifm9jca2308gw8a6cjb1hqlgfslbji2cqpan09kpq"))))
(build-system ocaml-build-system)
(native-inputs
(list opam ocamlbuild))
@@ -4310,7 +4310,7 @@ function that follows the prototype of POSIX's wcwidth.")
(define-public ocaml-zed
(package
(name "ocaml-zed")
- (version "3.2.0")
+ (version "3.2.1")
(home-page "https://github.com/ocaml-community/zed")
(source
(origin
@@ -4320,7 +4320,7 @@ function that follows the prototype of POSIX's wcwidth.")
(commit version)))
(file-name (git-file-name name version))
(sha256
- (base32 "1g171kk5wxnk66d4vwz2crh5i19vhqghp78iybl5am17gl9qf8pb"))))
+ (base32 "17zdbm422y0qznc659civ9bmahhrbffxa50f8dnykiaq8v2ci91l"))))
(build-system dune-build-system)
(propagated-inputs
(list ocaml-react
@@ -8456,7 +8456,7 @@ libraries.")
(define-public js-of-ocaml
(package
(name "js-of-ocaml")
- (version "4.0.0")
+ (version "4.1.0")
(source
(origin
(method git-fetch)
@@ -8465,7 +8465,7 @@ libraries.")
(commit version)))
(file-name (git-file-name name version))
(sha256
- (base32 "0iyhl9z57j53j2jvyqcwmxhbvy23l6g80aa0abmlgwam14yskspf"))))
+ (base32 "14ig69iyc9yzniclfsc6cz9g9zqp96bs66y6dy4rzrm78s81w6i1"))))
(build-system dune-build-system)
(arguments
`(#:tests? #f ;tests assume ocaml 4.13