summaryrefslogtreecommitdiff
path: root/gnu/packages/patches/bloomberg-bde-cmake-module-path.patch
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/patches/bloomberg-bde-cmake-module-path.patch')
-rw-r--r--gnu/packages/patches/bloomberg-bde-cmake-module-path.patch14
1 files changed, 6 insertions, 8 deletions
diff --git a/gnu/packages/patches/bloomberg-bde-cmake-module-path.patch b/gnu/packages/patches/bloomberg-bde-cmake-module-path.patch
index b08ca5eac0..7743863cf8 100644
--- a/gnu/packages/patches/bloomberg-bde-cmake-module-path.patch
+++ b/gnu/packages/patches/bloomberg-bde-cmake-module-path.patch
@@ -4,13 +4,11 @@ locating the bloomberg-bde-tools CMake modules.
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
-@@ -1,8 +1,6 @@
- cmake_minimum_required(VERSION 3.15)
+@@ -14,6 +14,7 @@ else()
+ if (NOT CMAKE_MODULE_PATH)
+ message(FATAL "Please specify path to BDE cmake modules.")
+ endif()
++ string(REPLACE ":" "cmake/;" CMAKE_MODULE_PATH "$ENV{CMAKE_PREFIX_PATH}cmake/")
--if (NOT CMAKE_MODULE_PATH)
-- message(FATAL "Please specify path to BDE cmake modules.")
--endif()
-+string(REPLACE ":" "cmake/;" CMAKE_MODULE_PATH "$ENV{CMAKE_PREFIX_PATH}cmake/")
-
- get_filename_component(repoName ${CMAKE_CURRENT_LIST_DIR} NAME)
+ include(bde_workspace)