summaryrefslogtreecommitdiff
path: root/gnu/packages/patches/ceph-disable-unittest-throttle.patch
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/patches/ceph-disable-unittest-throttle.patch')
-rw-r--r--gnu/packages/patches/ceph-disable-unittest-throttle.patch52
1 files changed, 0 insertions, 52 deletions
diff --git a/gnu/packages/patches/ceph-disable-unittest-throttle.patch b/gnu/packages/patches/ceph-disable-unittest-throttle.patch
deleted file mode 100644
index 08ae5f9e24..0000000000
--- a/gnu/packages/patches/ceph-disable-unittest-throttle.patch
+++ /dev/null
@@ -1,52 +0,0 @@
-FIXME: This test broke after the gcc-5/glibc-2.25 core-updates merge.
-Not sure what's going on here, it hangs after spawning the first thread.
-
-diff --git a/src/test/common/Throttle.cc b/src/test/common/Throttle.cc
-index 5b6d73217d..40a477b2a3 100644
---- a/src/test/common/Throttle.cc
-+++ b/src/test/common/Throttle.cc
-@@ -216,44 +216,6 @@ TEST_F(ThrottleTest, wait) {
- } while(!waited);
- }
-
--TEST_F(ThrottleTest, destructor) {
-- Thread_get *t;
-- {
-- int64_t throttle_max = 10;
-- Throttle *throttle = new Throttle(g_ceph_context, "throttle", throttle_max);
--
-- ASSERT_FALSE(throttle->get(5));
--
-- t = new Thread_get(*throttle, 7);
-- t->create("t_throttle");
-- bool blocked;
-- useconds_t delay = 1;
-- do {
-- usleep(delay);
-- if (throttle->get_or_fail(1)) {
-- throttle->put(1);
-- blocked = false;
-- } else {
-- blocked = true;
-- }
-- delay *= 2;
-- } while(!blocked);
-- delete throttle;
-- }
--
-- { //
-- // The thread is left hanging, otherwise it will abort().
-- // Deleting the Throttle on which it is waiting creates a
-- // inconsistency that will be detected: the Throttle object that
-- // it references no longer exists.
-- //
-- pthread_t id = t->get_thread_id();
-- ASSERT_EQ(pthread_kill(id, 0), 0);
-- delete t;
-- ASSERT_EQ(pthread_kill(id, 0), 0);
-- }
--}
--
- std::pair<double, std::chrono::duration<double> > test_backoff(
- double low_threshhold,
- double high_threshhold,