summaryrefslogtreecommitdiff
path: root/gnu/packages/patches/duplicity-test_selection-tmp.patch
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/patches/duplicity-test_selection-tmp.patch')
-rw-r--r--gnu/packages/patches/duplicity-test_selection-tmp.patch18
1 files changed, 18 insertions, 0 deletions
diff --git a/gnu/packages/patches/duplicity-test_selection-tmp.patch b/gnu/packages/patches/duplicity-test_selection-tmp.patch
new file mode 100644
index 0000000000..8f66be4dcc
--- /dev/null
+++ b/gnu/packages/patches/duplicity-test_selection-tmp.patch
@@ -0,0 +1,18 @@
+Reported upstream at https://bugs.launchpad.net/duplicity/+bug/1375019
+
+--- duplicity-0.6.24/testing/unit/test_selection.py 2014-05-09 08:27:40.000000000 -0500
++++ duplicity-0.6.24/testing/unit/test_selection.py 2014-09-28 12:28:53.932324380 -0500
+@@ -431,10 +431,10 @@
+ [(), ('1',), ('1', '1'), ('1', '2'), ('1', '3')])
+
+ self.root = Path("/")
+- self.ParseTest([("--exclude", "/home/*"),
+- ("--include", "/home"),
++ self.ParseTest([("--exclude", "/tmp/*"),
++ ("--include", "/tmp"),
+ ("--exclude", "/")],
+- [(), ("home",)])
++ [(), ("tmp",)])
+
+ if __name__ == "__main__":
+ unittest.main()