summaryrefslogtreecommitdiff
path: root/gnu/packages/patches/libaio-32bit-test.patch
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/patches/libaio-32bit-test.patch')
-rw-r--r--gnu/packages/patches/libaio-32bit-test.patch26
1 files changed, 26 insertions, 0 deletions
diff --git a/gnu/packages/patches/libaio-32bit-test.patch b/gnu/packages/patches/libaio-32bit-test.patch
new file mode 100644
index 0000000000..0da8e25c69
--- /dev/null
+++ b/gnu/packages/patches/libaio-32bit-test.patch
@@ -0,0 +1,26 @@
+This fix comes from an upstream pull request, see
+https://pagure.io/libaio/pull-request/22#commit_list
+
+diff --git a/harness/cases/23.t b/harness/cases/23.t
+index cc5a8a1..9bbb05c 100644
+--- a/harness/cases/23.t
++++ b/harness/cases/23.t
+@@ -72,7 +72,7 @@ static void fail_errno(const char *format, ...)
+ static void *thrproc2(void *arg)
+ {
+ for (;;) {
+- off_t offset = 0;
++ off64_t offset = 0;
+
+ pthread_barrier_wait(&barrier);
+ if (exiting)
+@@ -92,7 +92,7 @@ static void *thrproc3(void *arg)
+ {
+ for (;;) {
+ char c;
+- off_t offset = 0;
++ off64_t offset = 0;
+
+ pthread_barrier_wait(&barrier);
+ if (exiting)
+