summaryrefslogtreecommitdiff
path: root/gnu/packages/patches/perl-module-pluggable-search.patch
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/patches/perl-module-pluggable-search.patch')
-rw-r--r--gnu/packages/patches/perl-module-pluggable-search.patch25
1 files changed, 0 insertions, 25 deletions
diff --git a/gnu/packages/patches/perl-module-pluggable-search.patch b/gnu/packages/patches/perl-module-pluggable-search.patch
deleted file mode 100644
index bb2a57f7e5..0000000000
--- a/gnu/packages/patches/perl-module-pluggable-search.patch
+++ /dev/null
@@ -1,25 +0,0 @@
-Fix core Perl module Module::Pluggable such that it can find plugins that live
-in symlinked directories.
-
-Patch borrowed/adapted from Nixpkgs.
-
---- perl-5.16.1/cpan/Module-Pluggable/lib/Module/Pluggable/Object.pm 2015-04-08 23:28:48.120164135 -0500
-+++ perl-5.16.1/cpan/Module-Pluggable/lib/Module/Pluggable/Object.pm 2015-04-08 23:30:27.032166704 -0500
-@@ -164,7 +164,7 @@
- my $sp = catdir($dir, (split /::/, $searchpath));
-
- # if it doesn't exist or it's not a dir then skip it
-- next unless ( -e $sp && -d _ ); # Use the cached stat the second time
-+ next unless ( -e $sp );
-
- my @files = $self->find_files($sp);
-
-@@ -279,7 +279,7 @@
- (my $path = $File::Find::name) =~ s#^\\./##;
- push @files, $path;
- }
-- }, $search_path );
-+ }, "$search_path/." );
- }
- #chdir $cwd;
- return @files;