summaryrefslogtreecommitdiff
path: root/gnu/packages/patches/sbcl-fix-riscv-build.patch
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/patches/sbcl-fix-riscv-build.patch')
-rw-r--r--gnu/packages/patches/sbcl-fix-riscv-build.patch19
1 files changed, 0 insertions, 19 deletions
diff --git a/gnu/packages/patches/sbcl-fix-riscv-build.patch b/gnu/packages/patches/sbcl-fix-riscv-build.patch
deleted file mode 100644
index 3e01ee6579..0000000000
--- a/gnu/packages/patches/sbcl-fix-riscv-build.patch
+++ /dev/null
@@ -1,19 +0,0 @@
-commit b286d92af7468164c155c70d38213211b296fdfe
-Author: Douglas Katzman <dougk@google.com>
-Date: Wed Jan 10 11:46:55 2024 -0500
-
- Fix riscv build
-
-diff --git a/src/compiler/riscv/float.lisp b/src/compiler/riscv/float.lisp
-index ce46d24ac..a16380293 100644
---- a/src/compiler/riscv/float.lisp
-+++ b/src/compiler/riscv/float.lisp
-@@ -578,7 +578,7 @@
- (:results (res :scs (double-reg)))
- (:arg-types signed-num)
- (:result-types double-float)
-- (:translate make-double-float)
-+ (:translate %make-double-float)
- (:policy :fast-safe)
- (:generator 2
- (inst fmvx-> :double res bits)))