summaryrefslogtreecommitdiff
path: root/gnu/packages/patches/xpra-5.0-install_libs.patch
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/patches/xpra-5.0-install_libs.patch')
-rw-r--r--gnu/packages/patches/xpra-5.0-install_libs.patch42
1 files changed, 42 insertions, 0 deletions
diff --git a/gnu/packages/patches/xpra-5.0-install_libs.patch b/gnu/packages/patches/xpra-5.0-install_libs.patch
new file mode 100644
index 0000000000..4d40bf1f79
--- /dev/null
+++ b/gnu/packages/patches/xpra-5.0-install_libs.patch
@@ -0,0 +1,42 @@
+Distribution specific patch, not going upstream
+
+This workaround for Gentoo interferes with our use of --no-compile during
+the 'install stage.
+
+diff --git a/setup.py b/setup.py
+index e254bf99c..90db55c3f 100755
+--- a/setup.py
++++ b/setup.py
+@@ -663,8 +663,6 @@ if modules_ENABLED:
+ # Utility methods for building with Cython
+
+ def add_cython_ext(*args, **kwargs):
+- if "--no-compile" in sys.argv and not ("build" in sys.argv and "install" in sys.argv):
+- return
+ if not cython_ENABLED:
+ raise ValueError(f"cannot build {args}: cython compilation is disabled")
+ if cython_tracing_ENABLED:
+@@ -1809,9 +1807,6 @@ else:
+ if root_prefix.endswith("/usr"):
+ #ie: "/" or "/usr/src/rpmbuild/BUILDROOT/xpra-0.18.0-0.20160513r12573.fc23.x86_64/"
+ root_prefix = root_prefix[:-4]
+- for x in sys.argv:
+- if x.startswith("--root="):
+- root_prefix = x[len("--root="):]
+ print(f"install_data_override.run() root_prefix={root_prefix}")
+ build_xpra_conf(root_prefix)
+
+@@ -1955,13 +1950,6 @@ else:
+ if uinput_ENABLED:
+ add_data_files("lib/udev/rules.d/", ["fs/lib/udev/rules.d/71-xpra-virtual-pointer.rules"])
+
+- #gentoo does weird things, calls --no-compile with build *and* install
+- #then expects to find the cython modules!? ie:
+- #> python2.7 setup.py build -b build-2.7 install --no-compile \
+- # --root=/var/tmp/portage/x11-wm/xpra-0.7.0/temp/images/2.7
+- #otherwise we use the flags to skip pkgconfig
+- if ("--no-compile" in sys.argv or "--skip-build" in sys.argv) and not ("build" in sys.argv and "install" in sys.argv):
+- pkgconfig = no_pkgconfig
+
+ if OSX and "py2app" in sys.argv:
+ import py2app #@UnresolvedImport