summaryrefslogtreecommitdiff
path: root/gnu/packages/patches
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/patches')
-rw-r--r--gnu/packages/patches/flatpak-fix-fonts-icons.patch89
-rw-r--r--gnu/packages/patches/freecad-vtk-9.3.patch43
-rw-r--r--gnu/packages/patches/ghc-9.2-cabal-support-package-path.patch67
-rw-r--r--gnu/packages/patches/ghc-aeson-encodeDouble.patch25
-rw-r--r--gnu/packages/patches/ghc-clock-realfrag.patch22
-rw-r--r--gnu/packages/patches/libvpx-CVE-2023-44488.patch107
-rw-r--r--gnu/packages/patches/mes-0.26.1-fixups.patch126
-rw-r--r--gnu/packages/patches/mixxx-link-qtscriptbytearray-qtscript.patch25
-rw-r--r--gnu/packages/patches/mixxx-system-googletest-benchmark.patch43
-rw-r--r--gnu/packages/patches/python-scikit-optimize-1148.patch32
-rw-r--r--gnu/packages/patches/python-scikit-optimize-1150.patch275
11 files changed, 353 insertions, 501 deletions
diff --git a/gnu/packages/patches/flatpak-fix-fonts-icons.patch b/gnu/packages/patches/flatpak-fix-fonts-icons.patch
new file mode 100644
index 0000000000..5b9d855b2e
--- /dev/null
+++ b/gnu/packages/patches/flatpak-fix-fonts-icons.patch
@@ -0,0 +1,89 @@
+modify from https://github.com/NixOS/nixpkgs/pull/262462
+
+diff --git a/common/flatpak-run.c b/common/flatpak-run.c
+index 94ad013..5c9f55e 100644
+--- a/common/flatpak-run.c
++++ b/common/flatpak-run.c
+@@ -871,6 +871,49 @@ out:
+ return res;
+ }
+
++static void
++get_gnu_closure (GHashTable *closure, const gchar *source_path)
++{
++ if (g_file_test (source_path, G_FILE_TEST_IS_SYMLINK))
++ {
++ g_autofree gchar *path = g_malloc(PATH_MAX);
++ realpath(source_path, path);
++ if (g_str_has_prefix(path, "/gnu/store/"))
++ {
++ *strchr(path + strlen("/gnu/store/"), '/') = 0;
++ g_hash_table_add(closure, g_steal_pointer (&path));
++ }
++ }
++ else if (g_file_test (source_path, G_FILE_TEST_IS_DIR))
++ {
++ g_autoptr(GDir) dir = g_dir_open(source_path, 0, NULL);
++ const gchar *file_name;
++ while ((file_name = g_dir_read_name(dir)))
++ {
++ g_autofree gchar *path = g_build_filename (source_path, file_name, NULL);
++ get_gnu_closure (closure, path);
++ }
++ }
++}
++
++static void
++add_gnu_store_symlink_targets (FlatpakBwrap *bwrap, const gchar *source_path)
++{
++ GHashTable *closure = g_hash_table_new_full (g_str_hash, g_str_equal, g_free, NULL);
++
++ get_gnu_closure(closure, source_path);
++
++ GHashTableIter iter;
++ gpointer path;
++ g_hash_table_iter_init(&iter, closure);
++ while (g_hash_table_iter_next(&iter, &path, NULL))
++ {
++ flatpak_bwrap_add_args (bwrap, "--ro-bind", path, path, NULL);
++ }
++
++ g_hash_table_destroy(closure);
++}
++
+ static void
+ add_font_path_args (FlatpakBwrap *bwrap)
+ {
+@@ -898,6 +946,18 @@ add_font_path_args (FlatpakBwrap *bwrap)
+ "\t<remap-dir as-path=\"%s\">/run/host/fonts</remap-dir>\n",
+ SYSTEM_FONTS_DIR);
+ }
++ else if (g_file_test ("/run/current-system/profile/share/fonts", G_FILE_TEST_EXISTS))
++ {
++ add_gnu_store_symlink_targets (bwrap, "/run/current-system/profile/share/fonts");
++ flatpak_bwrap_add_args (bwrap,
++ "--ro-bind",
++ "/run/current-system/profile/share/fonts",
++ "/run/host/fonts",
++ NULL);
++ g_string_append_printf (xml_snippet,
++ "\t<remap-dir as-path=\"%s\">/run/host/fonts</remap-dir>\n",
++ "/run/current-system/profile/share/fonts");
++ }
+
+ if (g_file_test ("/usr/local/share/fonts", G_FILE_TEST_EXISTS))
+ {
+@@ -998,6 +1058,13 @@ add_icon_path_args (FlatpakBwrap *bwrap)
+ "--ro-bind", "/usr/share/icons", "/run/host/share/icons",
+ NULL);
+ }
++ else if (g_file_test ("/run/current-system/profile/share/icons", G_FILE_TEST_IS_DIR))
++ {
++ add_gnu_store_symlink_targets (bwrap, "/run/current-system/profile/share/icons");
++ flatpak_bwrap_add_args (bwrap,
++ "--ro-bind", "/run/current-system/profile/share/icons", "/run/host/share/icons",
++ NULL);
++ }
+
+ user_icons_path = g_build_filename (g_get_user_data_dir (), "icons", NULL);
+ user_icons = g_file_new_for_path (user_icons_path);
diff --git a/gnu/packages/patches/freecad-vtk-9.3.patch b/gnu/packages/patches/freecad-vtk-9.3.patch
new file mode 100644
index 0000000000..af9d654046
--- /dev/null
+++ b/gnu/packages/patches/freecad-vtk-9.3.patch
@@ -0,0 +1,43 @@
+From d0fb2b8b29fe0428d9dd8aa790b0d6e45c8a9516 Mon Sep 17 00:00:00 2001
+From: Adrian Insaurralde Avalos <adrianinsaval@gmail.com>
+Date: Wed, 22 Nov 2023 16:42:06 -0300
+Subject: [PATCH] 3rdPart/salomesmesh - fix for vtk 9.3 compatibility
+
+minimum required version is 7.1
+---
+ src/3rdParty/salomesmesh/inc/SMESH_SMDS.hxx | 4 ----
+ src/3rdParty/salomesmesh/src/SMDS/SMDS_UnstructuredGrid.cpp | 5 +++++
+ 2 files changed, 5 insertions(+), 4 deletions(-)
+
+diff --git a/src/3rdParty/salomesmesh/inc/SMESH_SMDS.hxx b/src/3rdParty/salomesmesh/inc/SMESH_SMDS.hxx
+index 7f89573efd0d..47a52fe585fe 100644
+--- a/src/3rdParty/salomesmesh/inc/SMESH_SMDS.hxx
++++ b/src/3rdParty/salomesmesh/inc/SMESH_SMDS.hxx
+@@ -39,10 +39,6 @@
+ #define SMDS_EXPORT
+ #endif
+
+-#ifdef VTK_HAS_MTIME_TYPE
+ #define VTK_MTIME_TYPE vtkMTimeType
+-#else
+-#define VTK_MTIME_TYPE unsigned long
+-#endif
+
+ #endif
+diff --git a/src/3rdParty/salomesmesh/src/SMDS/SMDS_UnstructuredGrid.cpp b/src/3rdParty/salomesmesh/src/SMDS/SMDS_UnstructuredGrid.cpp
+index 7e3de0070a02..e9895d615717 100644
+--- a/src/3rdParty/salomesmesh/src/SMDS/SMDS_UnstructuredGrid.cpp
++++ b/src/3rdParty/salomesmesh/src/SMDS/SMDS_UnstructuredGrid.cpp
+@@ -1026,7 +1026,12 @@ void SMDS_UnstructuredGrid::BuildLinks()
+ GetLinks()->Allocate(this->GetNumberOfPoints());
+ GetLinks()->Register(this);
+ //FIXME: vtk9
++ #if VTK_VERSION_NUMBER < VTK_VERSION_CHECK(9,3,0)
+ GetLinks()->BuildLinks(this);
++ #else
++ GetLinks()->SetDataSet(this);
++ GetLinks()->BuildLinks();
++ #endif
+ GetLinks()->Delete();
+ #else
+ this->Links = SMDS_CellLinks::New(); \ No newline at end of file
diff --git a/gnu/packages/patches/ghc-9.2-cabal-support-package-path.patch b/gnu/packages/patches/ghc-9.2-cabal-support-package-path.patch
new file mode 100644
index 0000000000..9e4c405c50
--- /dev/null
+++ b/gnu/packages/patches/ghc-9.2-cabal-support-package-path.patch
@@ -0,0 +1,67 @@
+Without this patch, Cabal terminates if GHC_PACKAGE_PATH is set. This is
+an annoyance with Guix as it makes heavy use of GHC_PACKAGE_PATH to have
+GHC pickup Haskell package installed via Guix. Therefore, Cabal does
+presently not work by default in environments created by Guix. This is
+a workaround which makes Cabal respect GHC_PACKAGE_PATH.
+
+Taken from https://github.com/haskell/cabal/issues/3728
+
+diff -upr a/libraries/Cabal/Cabal/src/Distribution/Simple/GHC.hs b/libraries/Cabal/Cabal/src/Distribution/Simple/GHC.hs
+--- a/libraries/Cabal/Cabal/src/Distribution/Simple/GHC.hs 2022-11-06 20:41:17.000000000 +0100
++++ b/libraries/Cabal/Cabal/src/Distribution/Simple/GHC.hs 2023-12-18 14:34:15.148911717 +0100
+@@ -71,6 +71,7 @@ module Distribution.Simple.GHC (
+ ) where
+
+ import Prelude ()
++import Distribution.Compat.Environment (lookupEnv)
+ import Distribution.Compat.Prelude
+
+ import qualified Distribution.Simple.GHC.Internal as Internal
+@@ -117,7 +118,7 @@ import System.Directory
+ , canonicalizePath, removeFile, renameFile, getDirectoryContents )
+ import System.FilePath ( (</>), (<.>), takeExtension
+ , takeDirectory, replaceExtension
+- ,isRelative )
++ , isRelative, searchPathSeparator )
+ import qualified System.Info
+ #ifndef mingw32_HOST_OS
+ import System.Posix (createSymbolicLink)
+@@ -333,9 +334,11 @@ getInstalledPackages :: Verbosity -> Com
+ -> ProgramDb
+ -> IO InstalledPackageIndex
+ getInstalledPackages verbosity comp packagedbs progdb = do
+- checkPackageDbEnvVar verbosity
+ checkPackageDbStack verbosity comp packagedbs
+- pkgss <- getInstalledPackages' verbosity packagedbs progdb
++ envPackageDBs <-
++ maybe [] (map SpecificPackageDB . unintersperse searchPathSeparator)
++ <$> lookupEnv "GHC_PACKAGE_PATH"
++ pkgss <- getInstalledPackages' verbosity (envPackageDBs ++ packagedbs) progdb
+ index <- toPackageIndex verbosity pkgss progdb
+ return $! hackRtsPackage index
+
+@@ -405,10 +408,6 @@ getUserPackageDB _verbosity ghcProg plat
+ packageConfFileName = "package.conf.d"
+ ghcVersion = fromMaybe (error "GHC.getUserPackageDB: no ghc version") $ programVersion ghcProg
+
+-checkPackageDbEnvVar :: Verbosity -> IO ()
+-checkPackageDbEnvVar verbosity =
+- Internal.checkPackageDbEnvVar verbosity "GHC" "GHC_PACKAGE_PATH"
+-
+ checkPackageDbStack :: Verbosity -> Compiler -> PackageDBStack -> IO ()
+ checkPackageDbStack verbosity comp =
+ if flagPackageConf implInfo
+@@ -461,8 +460,11 @@ getInstalledPackagesMonitorFiles :: Verb
+ -> ProgramDb
+ -> [PackageDB]
+ -> IO [FilePath]
+-getInstalledPackagesMonitorFiles verbosity platform progdb =
+- traverse getPackageDBPath
++getInstalledPackagesMonitorFiles verbosity platform progdb packageDBs = do
++ envPackageDBs <-
++ maybe [] (map SpecificPackageDB . unintersperse searchPathSeparator)
++ <$> lookupEnv "GHC_PACKAGE_PATH"
++ traverse getPackageDBPath (envPackageDBs ++ packageDBs)
+ where
+ getPackageDBPath :: PackageDB -> IO FilePath
+ getPackageDBPath GlobalPackageDB =
diff --git a/gnu/packages/patches/ghc-aeson-encodeDouble.patch b/gnu/packages/patches/ghc-aeson-encodeDouble.patch
new file mode 100644
index 0000000000..11ad425eae
--- /dev/null
+++ b/gnu/packages/patches/ghc-aeson-encodeDouble.patch
@@ -0,0 +1,25 @@
+From 58766a1916b4980792763bab74f0c86e2a7ebf20 Mon Sep 17 00:00:00 2001
+From: Oleg Grenrus <oleg.grenrus@iki.fi>
+Date: Thu, 1 Jun 2023 22:58:28 +0300
+Subject: [PATCH] QC-2.14.3 Double generators generates infinite number too
+
+---
+ tests/PropUtils.hs | 5 +++--
+ 1 file changed, 3 insertions(+), 2 deletions(-)
+
+diff --git a/tests/PropUtils.hs b/tests/PropUtils.hs
+index 3c449029a..43de85d7f 100644
+--- a/tests/PropUtils.hs
++++ b/tests/PropUtils.hs
+@@ -51,8 +51,9 @@ import qualified Data.Aeson.Decoding as Dec
+
+ encodeDouble :: Double -> Double -> Property
+ encodeDouble num denom
+- | isInfinite d || isNaN d = encode d === "null"
+- | otherwise = (read . L.unpack . encode) d === d
++ | isNaN d = encode d === "null"
++ | isInfinite d = if d > 0 then encode d === "\"+inf\"" else encode d === "\"-inf\""
++ | otherwise = (read . L.unpack . encode) d === d
+ where d = num / denom
+
+ encodeInteger :: Integer -> Property
diff --git a/gnu/packages/patches/ghc-clock-realfrag.patch b/gnu/packages/patches/ghc-clock-realfrag.patch
new file mode 100644
index 0000000000..0f7bb0542a
--- /dev/null
+++ b/gnu/packages/patches/ghc-clock-realfrag.patch
@@ -0,0 +1,22 @@
+From 8372e801ef062223756db69818a7b60cfd9bb066 Mon Sep 17 00:00:00 2001
+From: amesgen <amesgen@amesgen.de>
+Date: Tue, 8 Aug 2023 23:36:45 +0200
+Subject: [PATCH] Fix `RealFrac Seconds` instance
+
+---
+ System/Clock/Seconds.hs | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/System/Clock/Seconds.hs b/System/Clock/Seconds.hs
+index a9a1c78..f7457cb 100644
+--- a/System/Clock/Seconds.hs
++++ b/System/Clock/Seconds.hs
+@@ -50,7 +50,7 @@ instance Fractional Seconds where
+
+ instance RealFrac Seconds where
+ properFraction (Seconds (TimeSpec s ns))
+- | s >= 0 = (fromIntegral s, Seconds $ TimeSpec 0 ns)
++ | s >= 0 || ns == 0 = (fromIntegral s, Seconds $ TimeSpec 0 ns)
+ | otherwise = (fromIntegral (s+1), Seconds $ TimeSpec (-1) ns)
+
+ -- | The 'getTime' function shall return the current value for the
diff --git a/gnu/packages/patches/libvpx-CVE-2023-44488.patch b/gnu/packages/patches/libvpx-CVE-2023-44488.patch
new file mode 100644
index 0000000000..4ebb034eb4
--- /dev/null
+++ b/gnu/packages/patches/libvpx-CVE-2023-44488.patch
@@ -0,0 +1,107 @@
+From the upstream repo, can be removed after 1.14.1
+https://github.com/webmproject/libvpx/commit/df9fd9d5b7325060b2b921558a1eb20ca7880937.patch
+https://www.openwall.com/lists/oss-security/2023/09/30/4
+
+The test change didn't apply so it was removed from the patch
+
+From df9fd9d5b7325060b2b921558a1eb20ca7880937 Mon Sep 17 00:00:00 2001
+From: Jerome Jiang <jianj@google.com>
+Date: Thu, 30 Jun 2022 13:48:56 -0400
+Subject: [PATCH] Fix bug with smaller width bigger size
+
+Fixed previous patch that clusterfuzz failed on.
+
+Local fuzzing passing overnight.
+
+Bug: webm:1642
+Change-Id: If0e08e72abd2e042efe4dcfac21e4cc51afdfdb9
+(cherry picked from commit 263682c9a29395055f3b3afe2d97be1828a6223f)
+---
+ test/resize_test.cc | 11 +++--------
+ vp9/common/vp9_alloccommon.c | 13 ++++++-------
+ vp9/encoder/vp9_encoder.c | 27 +++++++++++++++++++++++++--
+ 3 files changed, 34 insertions(+), 17 deletions(-)
+
+diff --git a/vp9/common/vp9_alloccommon.c b/vp9/common/vp9_alloccommon.c
+index e53883f621d..9e73e40ea09 100644
+--- a/vp9/common/vp9_alloccommon.c
++++ b/vp9/common/vp9_alloccommon.c
+@@ -135,13 +135,6 @@ int vp9_alloc_context_buffers(VP9_COMMON *cm, int width, int height) {
+ cm->free_mi(cm);
+ if (cm->alloc_mi(cm, new_mi_size)) goto fail;
+ }
+-
+- if (cm->seg_map_alloc_size < cm->mi_rows * cm->mi_cols) {
+- // Create the segmentation map structure and set to 0.
+- free_seg_map(cm);
+- if (alloc_seg_map(cm, cm->mi_rows * cm->mi_cols)) goto fail;
+- }
+-
+ if (cm->above_context_alloc_cols < cm->mi_cols) {
+ vpx_free(cm->above_context);
+ cm->above_context = (ENTROPY_CONTEXT *)vpx_calloc(
+@@ -156,6 +149,12 @@ int vp9_alloc_context_buffers(VP9_COMMON *cm, int width, int height) {
+ cm->above_context_alloc_cols = cm->mi_cols;
+ }
+
++ if (cm->seg_map_alloc_size < cm->mi_rows * cm->mi_cols) {
++ // Create the segmentation map structure and set to 0.
++ free_seg_map(cm);
++ if (alloc_seg_map(cm, cm->mi_rows * cm->mi_cols)) goto fail;
++ }
++
+ if (vp9_alloc_loop_filter(cm)) goto fail;
+
+ return 0;
+diff --git a/vp9/encoder/vp9_encoder.c b/vp9/encoder/vp9_encoder.c
+index b66fdc0bca3..e3850775455 100644
+--- a/vp9/encoder/vp9_encoder.c
++++ b/vp9/encoder/vp9_encoder.c
+@@ -1973,6 +1973,17 @@ static void alloc_copy_partition_data(VP9_COMP *cpi) {
+ }
+ }
+
++static void free_copy_partition_data(VP9_COMP *cpi) {
++ vpx_free(cpi->prev_partition);
++ cpi->prev_partition = NULL;
++ vpx_free(cpi->prev_segment_id);
++ cpi->prev_segment_id = NULL;
++ vpx_free(cpi->prev_variance_low);
++ cpi->prev_variance_low = NULL;
++ vpx_free(cpi->copied_frame_cnt);
++ cpi->copied_frame_cnt = NULL;
++}
++
+ void vp9_change_config(struct VP9_COMP *cpi, const VP9EncoderConfig *oxcf) {
+ VP9_COMMON *const cm = &cpi->common;
+ RATE_CONTROL *const rc = &cpi->rc;
+@@ -2052,6 +2063,8 @@ void vp9_change_config(struct VP9_COMP *cpi, const VP9EncoderConfig *oxcf) {
+ new_mi_size = cm->mi_stride * calc_mi_size(cm->mi_rows);
+ if (cm->mi_alloc_size < new_mi_size) {
+ vp9_free_context_buffers(cm);
++ vp9_free_pc_tree(&cpi->td);
++ vpx_free(cpi->mbmi_ext_base);
+ alloc_compressor_data(cpi);
+ realloc_segmentation_maps(cpi);
+ cpi->initial_width = cpi->initial_height = 0;
+@@ -2070,8 +2083,18 @@ void vp9_change_config(struct VP9_COMP *cpi, const VP9EncoderConfig *oxcf) {
+ update_frame_size(cpi);
+
+ if (last_w != cpi->oxcf.width || last_h != cpi->oxcf.height) {
+- memset(cpi->consec_zero_mv, 0,
+- cm->mi_rows * cm->mi_cols * sizeof(*cpi->consec_zero_mv));
++ vpx_free(cpi->consec_zero_mv);
++ CHECK_MEM_ERROR(
++ cm, cpi->consec_zero_mv,
++ vpx_calloc(cm->mi_rows * cm->mi_cols, sizeof(*cpi->consec_zero_mv)));
++
++ vpx_free(cpi->skin_map);
++ CHECK_MEM_ERROR(
++ cm, cpi->skin_map,
++ vpx_calloc(cm->mi_rows * cm->mi_cols, sizeof(cpi->skin_map[0])));
++
++ free_copy_partition_data(cpi);
++ alloc_copy_partition_data(cpi);
+ if (cpi->oxcf.aq_mode == CYCLIC_REFRESH_AQ)
+ vp9_cyclic_refresh_reset_resize(cpi);
+ rc->rc_1_frame = 0;
diff --git a/gnu/packages/patches/mes-0.26.1-fixups.patch b/gnu/packages/patches/mes-0.26.1-fixups.patch
deleted file mode 100644
index 511b85cfc5..0000000000
--- a/gnu/packages/patches/mes-0.26.1-fixups.patch
+++ /dev/null
@@ -1,126 +0,0 @@
-Taken from upstream.
-
-From 7f549d02ac997505a7ed8a05339e73b851a875b8 Mon Sep 17 00:00:00 2001
-From: Janneke Nieuwenhuizen <janneke@gnu.org>
-Date: Sun, 9 Jun 2024 08:18:35 +0200
-Subject: [PATCH 1/4] build: Remove a0-call-trunc-int from xfail for
- mescc-x86_64.
-
-Reported by Vagrant Cascadian <vagrant@debian.org> via IRC.
-
-* build-aux/check-mescc.sh (xfail_tests)[mescc x86_64]: Remove
-a0-call-trunc-int.c.
----
- build-aux/check-mescc.sh | 1 -
- 1 file changed, 1 deletion(-)
-
-diff --git a/build-aux/check-mescc.sh b/build-aux/check-mescc.sh
-index fb5e1ef46..b2d771c89 100755
---- a/build-aux/check-mescc.sh
-+++ b/build-aux/check-mescc.sh
-@@ -273,7 +273,6 @@ lib/tests/scaffold/91-goto-array.c
- lib/tests/scaffold/16-cast.c
- lib/tests/scaffold/17-compare-unsigned-le.c
- lib/tests/scaffold/17-compare-rotated.c
--lib/tests/scaffold/a0-call-trunc-int.c
- "
- fi
-
---
-2.41.0
-
-From 3389cf4aef17cec38a5fd693c4c5d62520b0eab3 Mon Sep 17 00:00:00 2001
-From: Janneke Nieuwenhuizen <janneke@gnu.org>
-Date: Sun, 9 Jun 2024 08:28:13 +0200
-Subject: [PATCH 2/4] lib: arm: Fix signal.h header.
-
-This is a follow-up to commit
- 83a08a0788a5417d0a0bae3a43dc9c4026e09d99
- lib: Add ucontext_t for all architectures.
-
-* include/linux/arm/signal.h: Add missing semicolon.
----
- include/linux/arm/signal.h | 3 ++-
- 1 file changed, 2 insertions(+), 1 deletion(-)
-
-diff --git a/include/linux/arm/signal.h b/include/linux/arm/signal.h
-index 06cb09176..381811714 100644
---- a/include/linux/arm/signal.h
-+++ b/include/linux/arm/signal.h
-@@ -1,6 +1,7 @@
- /* -*-comment-start: "//";comment-end:""-*-
- * GNU Mes --- Maxwell Equations of Software
- * Copyright © 2024 Ekaitz Zarraga <ekaitz@elenq.tech>
-+ * Copyright © 2024 Janneke Nieuwenhuizen <janneke@gnu.org>
- *
- * This file is part of GNU Mes.
- *
-@@ -20,7 +21,7 @@
-
- // Taken from musl libc (4a16ddf5)
-
--typedef int greg_t
-+typedef int greg_t;
- typedef int gregset_t[18];
- typedef struct sigcontext
- {
---
-2.41.0
-
-From 835d13ee2614a8b6ed54e5b7ead44b3d93cd63b4 Mon Sep 17 00:00:00 2001
-From: Janneke Nieuwenhuizen <janneke@gnu.org>
-Date: Sun, 9 Jun 2024 11:20:42 +0200
-Subject: [PATCH 3/4] build: Add 90-signal to xfail for mescc-arm.
-
-Bisected until 0.23; this test sadly never worked on arm.
-
-* build-aux/check-mescc.sh (xfail_tests)[mescc-arm]: Add 90-signal.c
----
- build-aux/check-mescc.sh | 1 +
- 1 file changed, 1 insertion(+)
-
-diff --git a/build-aux/check-mescc.sh b/build-aux/check-mescc.sh
-index b2d771c89..3900601e9 100755
---- a/build-aux/check-mescc.sh
-+++ b/build-aux/check-mescc.sh
-@@ -280,6 +280,7 @@ lib/tests/scaffold/17-compare-rotated.c
- xfail_tests="$xfail_tests
- lib/tests/scaffold/17-compare-rotated.c
- lib/tests/scaffold/67-m1-overflow-check.c
-+lib/tests/signal/90-signal.c
- "
- fi
-
---
-2.41.0
-
-From 1683f074a0462bc27023ce5a980ff3d35d4126cf Mon Sep 17 00:00:00 2001
-From: Janneke Nieuwenhuizen <janneke@gnu.org>
-Date: Sun, 9 Jun 2024 11:24:25 +0200
-Subject: [PATCH 4/4] build: Remove 17-compare-rotated, 67-m1-overflow-check
- xfail for mescc-arm.
-
-These were fixed by the riscv64 work.
-
-* build-aux/check-mescc.sh (xfail_tests)[mescc arm]: Remove
-17-compare-rotated, 67-m1-overflow-check.
----
- build-aux/check-mescc.sh | 2 --
- 1 file changed, 2 deletions(-)
-
-diff --git a/build-aux/check-mescc.sh b/build-aux/check-mescc.sh
-index 3900601e9..9abf43384 100755
---- a/build-aux/check-mescc.sh
-+++ b/build-aux/check-mescc.sh
-@@ -278,8 +278,6 @@ lib/tests/scaffold/17-compare-rotated.c
-
- if test $mes_cpu = arm; then
- xfail_tests="$xfail_tests
--lib/tests/scaffold/17-compare-rotated.c
--lib/tests/scaffold/67-m1-overflow-check.c
- lib/tests/signal/90-signal.c
- "
- fi
---
-2.41.0
-
diff --git a/gnu/packages/patches/mixxx-link-qtscriptbytearray-qtscript.patch b/gnu/packages/patches/mixxx-link-qtscriptbytearray-qtscript.patch
deleted file mode 100644
index d7cd1c0d28..0000000000
--- a/gnu/packages/patches/mixxx-link-qtscriptbytearray-qtscript.patch
+++ /dev/null
@@ -1,25 +0,0 @@
-From 7554aefc886d4ebc4b4c139a5cddcab6163cf72f Mon Sep 17 00:00:00 2001
-From: Vinicius Monego <monego@posteo.net>
-Date: Thu, 30 Sep 2021 23:37:29 -0300
-Subject: [PATCH] Link QtScriptByteArray with QtScript.
-
----
- CMakeLists.txt | 2 +-
- 1 file changed, 1 insertion(+), 1 deletion(-)
-
-diff --git a/CMakeLists.txt b/CMakeLists.txt
-index 492ccae..05fec08 100644
---- a/CMakeLists.txt
-+++ b/CMakeLists.txt
-@@ -2077,7 +2077,7 @@ add_library(QtScriptByteArray STATIC EXCLUDE_FROM_ALL
- lib/qtscript-bytearray/bytearrayprototype.cpp
- )
- set_target_properties(QtScriptByteArray PROPERTIES AUTOMOC ON)
--target_link_libraries(QtScriptByteArray Qt5::Core)
-+target_link_libraries(QtScriptByteArray Qt5::Core Qt5::Script)
- target_include_directories(mixxx-lib SYSTEM PUBLIC lib/qtscript-bytearray)
- target_link_libraries(mixxx-lib PRIVATE QtScriptByteArray)
-
---
-2.30.2
-
diff --git a/gnu/packages/patches/mixxx-system-googletest-benchmark.patch b/gnu/packages/patches/mixxx-system-googletest-benchmark.patch
deleted file mode 100644
index 7adbe66208..0000000000
--- a/gnu/packages/patches/mixxx-system-googletest-benchmark.patch
+++ /dev/null
@@ -1,43 +0,0 @@
-From eb2079d467f8658eea13e2ed86cc69d864632866 Mon Sep 17 00:00:00 2001
-From: Vinicius Monego <monego@posteo.net>
-Date: Wed, 29 Sep 2021 19:07:35 -0300
-Subject: [PATCH] Use system googletest and benchmark.
-
----
- CMakeLists.txt | 13 +++----------
- 1 file changed, 3 insertions(+), 10 deletions(-)
-
-diff --git a/CMakeLists.txt b/CMakeLists.txt
-index 10e9b0a..492ccae 100644
---- a/CMakeLists.txt
-+++ b/CMakeLists.txt
-@@ -1467,12 +1467,7 @@ set(gtest_force_shared_crt ON CACHE BOOL "Pass Mixxx compiler/linker options to
- # Prevent installation of GoogleTest libraries
- set(INSTALL_GTEST OFF CACHE BOOL "Disable installation of GoogleTest" FORCE)
-
--# Add googletest directly to our build. This adds the following targets:
--# gtest, gtest_main, gmock and gmock_main
--add_subdirectory(
-- "${CMAKE_CURRENT_SOURCE_DIR}/lib/googletest"
-- "${CMAKE_CURRENT_BINARY_DIR}/lib/googletest"
--)
-+find_package(GTest CONFIG REQUIRED)
-
- add_executable(mixxx-test
- src/test/analyserwaveformtest.cpp
-@@ -1582,10 +1577,8 @@ set(BENCHMARK_ENABLE_TESTING OFF CACHE BOOL "" FORCE)
- # Prevent installation of google/benchmark artifacts
- set(BENCHMARK_ENABLE_INSTALL OFF CACHE BOOL "Disable installation of google/benchmark" FORCE)
-
--add_subdirectory(
-- "${CMAKE_CURRENT_SOURCE_DIR}/lib/benchmark"
-- "${CMAKE_CURRENT_BINARY_DIR}/lib/benchmark"
--)
-+find_package(benchmark CONFIG REQUIRED)
-+
- target_link_libraries(mixxx-test PRIVATE benchmark)
-
- # Test Suite
---
-2.30.2
-
diff --git a/gnu/packages/patches/python-scikit-optimize-1148.patch b/gnu/packages/patches/python-scikit-optimize-1148.patch
deleted file mode 100644
index 6ad854ab1e..0000000000
--- a/gnu/packages/patches/python-scikit-optimize-1148.patch
+++ /dev/null
@@ -1,32 +0,0 @@
-From 3a5d5eb90ec9d8d4905c05387748486157cadbbb Mon Sep 17 00:00:00 2001
-From: valtron <valtron2000@gmail.com>
-Date: Tue, 14 Feb 2023 09:56:10 -0700
-Subject: [PATCH] `np.int` -> `int`
-
-`np.int is int` and it was deprecated in numpy 1.20: https://numpy.org/doc/1.20/release/1.20.0-notes.html#deprecations
----
- skopt/space/transformers.py | 4 ++--
- 1 file changed, 2 insertions(+), 2 deletions(-)
-
-diff --git a/skopt/space/transformers.py b/skopt/space/transformers.py
-index 68892952..f2dfb164 100644
---- a/skopt/space/transformers.py
-+++ b/skopt/space/transformers.py
-@@ -259,7 +259,7 @@ def transform(self, X):
- if (self.high - self.low) == 0.:
- return X * 0.
- if self.is_int:
-- return (np.round(X).astype(np.int) - self.low) /\
-+ return (np.round(X).astype(int) - self.low) /\
- (self.high - self.low)
- else:
- return (X - self.low) / (self.high - self.low)
-@@ -272,7 +272,7 @@ def inverse_transform(self, X):
- raise ValueError("All values should be greater than 0.0")
- X_orig = X * (self.high - self.low) + self.low
- if self.is_int:
-- return np.round(X_orig).astype(np.int)
-+ return np.round(X_orig).astype(int)
- return X_orig
-
-
diff --git a/gnu/packages/patches/python-scikit-optimize-1150.patch b/gnu/packages/patches/python-scikit-optimize-1150.patch
deleted file mode 100644
index 0cdf361a80..0000000000
--- a/gnu/packages/patches/python-scikit-optimize-1150.patch
+++ /dev/null
@@ -1,275 +0,0 @@
-From cd74e00d0e4f435d548444e1a5edc20155e371d7 Mon Sep 17 00:00:00 2001
-From: =?UTF-8?q?Jonas=20T=C3=B8rnes?= <jonas.tornes@gmail.com>
-Date: Wed, 15 Feb 2023 18:47:52 +0100
-Subject: [PATCH 1/5] Update RandomForesetRegressor criterion to be inline with
- scikit-learn change from mse to squared error this has the same funcitonality
-
----
- requirements.txt | 6 +++---
- setup.py | 6 +++---
- skopt/learning/forest.py | 30 +++++++++++++++---------------
- 3 files changed, 21 insertions(+), 21 deletions(-)
-
-diff --git a/requirements.txt b/requirements.txt
-index 1eaa3083a..23ab3d856 100644
---- a/requirements.txt
-+++ b/requirements.txt
-@@ -1,6 +1,6 @@
--numpy>=1.13.3
--scipy>=0.19.1
--scikit-learn>=0.20
-+numpy>=1.23.2
-+scipy>=1.10.0
-+scikit-learn>=1.2.1
- matplotlib>=2.0.0
- pytest
- pyaml>=16.9
-diff --git a/setup.py b/setup.py
-index 8879da880..e7f921765 100644
---- a/setup.py
-+++ b/setup.py
-@@ -42,9 +42,9 @@
- classifiers=CLASSIFIERS,
- packages=['skopt', 'skopt.learning', 'skopt.optimizer', 'skopt.space',
- 'skopt.learning.gaussian_process', 'skopt.sampler'],
-- install_requires=['joblib>=0.11', 'pyaml>=16.9', 'numpy>=1.13.3',
-- 'scipy>=0.19.1',
-- 'scikit-learn>=0.20.0'],
-+ install_requires=['joblib>=0.11', 'pyaml>=16.9', 'numpy>=1.23.2',
-+ 'scipy>=1.10.0',
-+ 'scikit-learn>=1.2.1'],
- extras_require={
- 'plots': ["matplotlib>=2.0.0"]
- }
-diff --git a/skopt/learning/forest.py b/skopt/learning/forest.py
-index 096770c1d..ebde568f5 100644
---- a/skopt/learning/forest.py
-+++ b/skopt/learning/forest.py
-@@ -27,7 +27,7 @@ def _return_std(X, trees, predictions, min_variance):
- -------
- std : array-like, shape=(n_samples,)
- Standard deviation of `y` at `X`. If criterion
-- is set to "mse", then `std[i] ~= std(y | X[i])`.
-+ is set to "squared_error", then `std[i] ~= std(y | X[i])`.
-
- """
- # This derives std(y | x) as described in 4.3.2 of arXiv:1211.0906
-@@ -61,9 +61,9 @@ class RandomForestRegressor(_sk_RandomForestRegressor):
- n_estimators : integer, optional (default=10)
- The number of trees in the forest.
-
-- criterion : string, optional (default="mse")
-+ criterion : string, optional (default="squared_error")
- The function to measure the quality of a split. Supported criteria
-- are "mse" for the mean squared error, which is equal to variance
-+ are "squared_error" for the mean squared error, which is equal to variance
- reduction as feature selection criterion, and "mae" for the mean
- absolute error.
-
-@@ -194,7 +194,7 @@ class RandomForestRegressor(_sk_RandomForestRegressor):
- .. [1] L. Breiman, "Random Forests", Machine Learning, 45(1), 5-32, 2001.
-
- """
-- def __init__(self, n_estimators=10, criterion='mse', max_depth=None,
-+ def __init__(self, n_estimators=10, criterion='squared_error', max_depth=None,
- min_samples_split=2, min_samples_leaf=1,
- min_weight_fraction_leaf=0.0, max_features='auto',
- max_leaf_nodes=None, min_impurity_decrease=0.,
-@@ -228,20 +228,20 @@ def predict(self, X, return_std=False):
- Returns
- -------
- predictions : array-like of shape = (n_samples,)
-- Predicted values for X. If criterion is set to "mse",
-+ Predicted values for X. If criterion is set to "squared_error",
- then `predictions[i] ~= mean(y | X[i])`.
-
- std : array-like of shape=(n_samples,)
- Standard deviation of `y` at `X`. If criterion
-- is set to "mse", then `std[i] ~= std(y | X[i])`.
-+ is set to "squared_error", then `std[i] ~= std(y | X[i])`.
-
- """
- mean = super(RandomForestRegressor, self).predict(X)
-
- if return_std:
-- if self.criterion != "mse":
-+ if self.criterion != "squared_error":
- raise ValueError(
-- "Expected impurity to be 'mse', got %s instead"
-+ "Expected impurity to be 'squared_error', got %s instead"
- % self.criterion)
- std = _return_std(X, self.estimators_, mean, self.min_variance)
- return mean, std
-@@ -257,9 +257,9 @@ class ExtraTreesRegressor(_sk_ExtraTreesRegressor):
- n_estimators : integer, optional (default=10)
- The number of trees in the forest.
-
-- criterion : string, optional (default="mse")
-+ criterion : string, optional (default="squared_error")
- The function to measure the quality of a split. Supported criteria
-- are "mse" for the mean squared error, which is equal to variance
-+ are "squared_error" for the mean squared error, which is equal to variance
- reduction as feature selection criterion, and "mae" for the mean
- absolute error.
-
-@@ -390,7 +390,7 @@ class ExtraTreesRegressor(_sk_ExtraTreesRegressor):
- .. [1] L. Breiman, "Random Forests", Machine Learning, 45(1), 5-32, 2001.
-
- """
-- def __init__(self, n_estimators=10, criterion='mse', max_depth=None,
-+ def __init__(self, n_estimators=10, criterion='squared_error', max_depth=None,
- min_samples_split=2, min_samples_leaf=1,
- min_weight_fraction_leaf=0.0, max_features='auto',
- max_leaf_nodes=None, min_impurity_decrease=0.,
-@@ -425,19 +425,19 @@ def predict(self, X, return_std=False):
- Returns
- -------
- predictions : array-like of shape=(n_samples,)
-- Predicted values for X. If criterion is set to "mse",
-+ Predicted values for X. If criterion is set to "squared_error",
- then `predictions[i] ~= mean(y | X[i])`.
-
- std : array-like of shape=(n_samples,)
- Standard deviation of `y` at `X`. If criterion
-- is set to "mse", then `std[i] ~= std(y | X[i])`.
-+ is set to "squared_error", then `std[i] ~= std(y | X[i])`.
- """
- mean = super(ExtraTreesRegressor, self).predict(X)
-
- if return_std:
-- if self.criterion != "mse":
-+ if self.criterion != "squared_error":
- raise ValueError(
-- "Expected impurity to be 'mse', got %s instead"
-+ "Expected impurity to be 'squared_error', got %s instead"
- % self.criterion)
- std = _return_std(X, self.estimators_, mean, self.min_variance)
- return mean, std
-
-From 6eb2d4ddaa299ae47d9a69ffb31ebc4ed366d1c1 Mon Sep 17 00:00:00 2001
-From: =?UTF-8?q?Jonas=20T=C3=B8rnes?= <jonas.tornes@gmail.com>
-Date: Thu, 16 Feb 2023 11:34:58 +0100
-Subject: [PATCH 2/5] Change test to be consistent with code changes.
-
----
- skopt/learning/tests/test_forest.py | 4 ++--
- 1 file changed, 2 insertions(+), 2 deletions(-)
-
-diff --git a/skopt/learning/tests/test_forest.py b/skopt/learning/tests/test_forest.py
-index 0711cde9d..c6ed610f3 100644
---- a/skopt/learning/tests/test_forest.py
-+++ b/skopt/learning/tests/test_forest.py
-@@ -35,7 +35,7 @@ def test_random_forest():
- assert_array_equal(clf.predict(T), true_result)
- assert 10 == len(clf)
-
-- clf = RandomForestRegressor(n_estimators=10, criterion="mse",
-+ clf = RandomForestRegressor(n_estimators=10, criterion="squared_error",
- max_depth=None, min_samples_split=2,
- min_samples_leaf=1,
- min_weight_fraction_leaf=0.,
-@@ -80,7 +80,7 @@ def test_extra_forest():
- assert_array_equal(clf.predict(T), true_result)
- assert 10 == len(clf)
-
-- clf = ExtraTreesRegressor(n_estimators=10, criterion="mse",
-+ clf = ExtraTreesRegressor(n_estimators=10, criterion="squared_error",
- max_depth=None, min_samples_split=2,
- min_samples_leaf=1, min_weight_fraction_leaf=0.,
- max_features="auto", max_leaf_nodes=None,
-
-From 52c620add07d845debbaff2ce2b1c5faf3eae79b Mon Sep 17 00:00:00 2001
-From: =?UTF-8?q?Jonas=20T=C3=B8rnes?= <jonas.tornes@gmail.com>
-Date: Wed, 22 Feb 2023 16:59:03 +0100
-Subject: [PATCH 3/5] Update skopt/learning/forest.py
-MIME-Version: 1.0
-Content-Type: text/plain; charset=UTF-8
-Content-Transfer-Encoding: 8bit
-
-Fix max line width
-
-Co-authored-by: Roland Laurès <roland@laures-valdivia.net>
----
- skopt/learning/forest.py | 4 ++--
- 1 file changed, 2 insertions(+), 2 deletions(-)
-
-diff --git a/skopt/learning/forest.py b/skopt/learning/forest.py
-index ebde568f5..07dc42664 100644
---- a/skopt/learning/forest.py
-+++ b/skopt/learning/forest.py
-@@ -194,8 +194,8 @@ class RandomForestRegressor(_sk_RandomForestRegressor):
- .. [1] L. Breiman, "Random Forests", Machine Learning, 45(1), 5-32, 2001.
-
- """
-- def __init__(self, n_estimators=10, criterion='squared_error', max_depth=None,
-- min_samples_split=2, min_samples_leaf=1,
-+ def __init__(self, n_estimators=10, criterion='squared_error',
-+ max_depth=None, min_samples_split=2, min_samples_leaf=1,
- min_weight_fraction_leaf=0.0, max_features='auto',
- max_leaf_nodes=None, min_impurity_decrease=0.,
- bootstrap=True, oob_score=False,
-
-From 52a7db95cb567186fb4e9003139fea4592bdbf05 Mon Sep 17 00:00:00 2001
-From: =?UTF-8?q?Jonas=20T=C3=B8rnes?= <jonas.tornes@gmail.com>
-Date: Wed, 22 Feb 2023 17:03:25 +0100
-Subject: [PATCH 4/5] Fix line widht issues
-
----
- skopt/learning/forest.py | 4 ++--
- 1 file changed, 2 insertions(+), 2 deletions(-)
-
-diff --git a/skopt/learning/forest.py b/skopt/learning/forest.py
-index 07dc42664..d4c24456b 100644
---- a/skopt/learning/forest.py
-+++ b/skopt/learning/forest.py
-@@ -390,8 +390,8 @@ class ExtraTreesRegressor(_sk_ExtraTreesRegressor):
- .. [1] L. Breiman, "Random Forests", Machine Learning, 45(1), 5-32, 2001.
-
- """
-- def __init__(self, n_estimators=10, criterion='squared_error', max_depth=None,
-- min_samples_split=2, min_samples_leaf=1,
-+ def __init__(self, n_estimators=10, criterion='squared_error',
-+ max_depth=None, min_samples_split=2, min_samples_leaf=1,
- min_weight_fraction_leaf=0.0, max_features='auto',
- max_leaf_nodes=None, min_impurity_decrease=0.,
- bootstrap=False, oob_score=False,
-
-From 6b185e489fb4a56625e8505292a20c80434f0633 Mon Sep 17 00:00:00 2001
-From: =?UTF-8?q?Jonas=20T=C3=B8rnes?= <jonas.tornes@gmail.com>
-Date: Wed, 22 Feb 2023 18:37:11 +0100
-Subject: [PATCH 5/5] Fix lin width issues for comments.
-
----
- skopt/learning/forest.py | 12 ++++++------
- 1 file changed, 6 insertions(+), 6 deletions(-)
-
-diff --git a/skopt/learning/forest.py b/skopt/learning/forest.py
-index d4c24456b..eb3bd6648 100644
---- a/skopt/learning/forest.py
-+++ b/skopt/learning/forest.py
-@@ -63,9 +63,9 @@ class RandomForestRegressor(_sk_RandomForestRegressor):
-
- criterion : string, optional (default="squared_error")
- The function to measure the quality of a split. Supported criteria
-- are "squared_error" for the mean squared error, which is equal to variance
-- reduction as feature selection criterion, and "mae" for the mean
-- absolute error.
-+ are "squared_error" for the mean squared error, which is equal to
-+ variance reduction as feature selection criterion, and "mae" for the
-+ mean absolute error.
-
- max_features : int, float, string or None, optional (default="auto")
- The number of features to consider when looking for the best split:
-@@ -259,9 +259,9 @@ class ExtraTreesRegressor(_sk_ExtraTreesRegressor):
-
- criterion : string, optional (default="squared_error")
- The function to measure the quality of a split. Supported criteria
-- are "squared_error" for the mean squared error, which is equal to variance
-- reduction as feature selection criterion, and "mae" for the mean
-- absolute error.
-+ are "squared_error" for the mean squared error, which is equal to
-+ variance reduction as feature selection criterion, and "mae" for the
-+ mean absolute error.
-
- max_features : int, float, string or None, optional (default="auto")
- The number of features to consider when looking for the best split: