summaryrefslogtreecommitdiff
path: root/gnu/packages/pdf.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/pdf.scm')
-rw-r--r--gnu/packages/pdf.scm30
1 files changed, 13 insertions, 17 deletions
diff --git a/gnu/packages/pdf.scm b/gnu/packages/pdf.scm
index 5cf93ad724..7649bff695 100644
--- a/gnu/packages/pdf.scm
+++ b/gnu/packages/pdf.scm
@@ -1311,38 +1311,34 @@ presentation. The input files processed by pdfpc are PDF documents.")
(synopsis "Pango to PostScript converter")
(description
"Paps reads a UTF-8 encoded file and generates a PostScript language
-rendering of the file. The rendering is done by creating outline curves
-through the Pango @code{ft2} backend.")
+rendering of the file through the Pango Cairo back end.")
(license license:lgpl2.0+)))
(define-public stapler
(package
(name "stapler")
- (version "0.3.2")
+ (version "1.0.0")
(source
(origin
- (method git-fetch)
- (uri (git-reference
- (url "https://github.com/hellerbarde/stapler")
- (commit version)))
- (file-name (git-file-name name version))
+ (method url-fetch)
+ (uri (pypi-uri "stapler" version))
(sha256
(base32
- "06w7xanzr7cicqik62g7zqs57j4y6fc7hflrc1rlmphxx40hkg6r"))))
+ "0b2lbm3f79cdxcsagwhzihbzwahjabxqmbws0c8ki25gpdnygdd7"))))
(build-system python-build-system)
- (inputs
- `(("python2-pypdf2" ,python2-pypdf2)))
(arguments
- `(#:python ,python-2
- #:phases
+ '(#:phases
(modify-phases %standard-phases
- (add-after 'unpack 'fix-pypdf-version-requirement
- ;; A PyPDF2 version requirement of 1.25.1 is hard-coded in
- ;; setup.py. Relax it to work with any version of PyPDF2.
+ (add-after 'unpack 'fix-more-itertools-version-requirement
(lambda _
+ ;; Tests require an version of the more-itertools module older
+ ;; than the one we have packaged.
(substitute* "setup.py"
- (("PyPDF2==1.25.1") "PyPDF2"))
+ (("more-itertools>=2\\.2,<6\\.0\\.0") "more-itertools>=2.2"))
#t)))))
+ (propagated-inputs
+ `(("python-more-itertools" ,python-more-itertools)
+ ("python-pypdf2" ,python-pypdf2)))
(home-page "https://github.com/hellerbarde/stapler")
(synopsis "PDF manipulation tool")
(description "Stapler is a pure Python alternative to PDFtk, a tool for