summaryrefslogtreecommitdiff
path: root/gnu/packages/pdf.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/pdf.scm')
-rw-r--r--gnu/packages/pdf.scm10
1 files changed, 5 insertions, 5 deletions
diff --git a/gnu/packages/pdf.scm b/gnu/packages/pdf.scm
index 8f163bdd37..9298332940 100644
--- a/gnu/packages/pdf.scm
+++ b/gnu/packages/pdf.scm
@@ -177,7 +177,7 @@ information.")
`(("python-pypdf2" ,python-pypdf2)
("python-pyqt" ,python-pyqt)
("python-poppler-qt5" ,python-poppler-qt5)
- ("qtbase" ,qtbase)))
+ ("qtbase" ,qtbase-5)))
(home-page "http://crazy-compilers.com/flyer-composer")
(synopsis "Rearrange PDF pages to print as flyers on one sheet")
(description "@command{flyer-composer} can be used to prepare one- or
@@ -302,7 +302,7 @@ When present, Poppler is able to correctly render CJK and Cyrillic text.")
(define-public poppler-qt5
(package/inherit poppler
(name "poppler-qt5")
- (inputs `(("qtbase" ,qtbase)
+ (inputs `(("qtbase" ,qtbase-5)
,@(package-inputs poppler)))
(synopsis "Qt5 frontend for the Poppler PDF rendering library")))
@@ -342,7 +342,7 @@ When present, Poppler is able to correctly render CJK and Cyrillic text.")
`(("python-sip" ,python-sip-4)
("python-pyqt" ,python-pyqt)
("poppler-qt5" ,poppler-qt5)
- ("qtbase" ,qtbase)))
+ ("qtbase" ,qtbase-5)))
(home-page "https://pypi.org/project/python-poppler-qt5/")
(synopsis "Python bindings for Poppler-Qt5")
(description
@@ -400,7 +400,7 @@ reading and editing of existing PDF files.")
(inputs `(("cups" ,cups)
("freetype" ,freetype)
("libpng" ,libpng)
- ("qtbase" ,qtbase)
+ ("qtbase" ,qtbase-5)
("zlib" ,zlib)))
(arguments
`(#:tests? #f)) ; there is no check target
@@ -847,7 +847,7 @@ program capable of converting PDF into other formats.")
("djvulibre" ,djvulibre)
("libspectre" ,libspectre)
("poppler-qt5" ,poppler-qt5)
- ("qtbase" ,qtbase)
+ ("qtbase" ,qtbase-5)
("qtsvg" ,qtsvg)))
(arguments
`(#:imported-modules ((guix build qt-build-system)