summaryrefslogtreecommitdiff
path: root/gnu/packages/photo.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/photo.scm')
-rw-r--r--gnu/packages/photo.scm9
1 files changed, 5 insertions, 4 deletions
diff --git a/gnu/packages/photo.scm b/gnu/packages/photo.scm
index e69721ef10..47511fb0e4 100644
--- a/gnu/packages/photo.scm
+++ b/gnu/packages/photo.scm
@@ -12,6 +12,7 @@
;;; Copyright © 2022, 2023 John Kehayias <john.kehayias@protonmail.com>
;;; Copyright © 2022 Sharlatan Hellseher <sharlatanus@gmail.com>
;;; Copyright © 2023 Bruno Victal <mirai@makinata.eu>
+;;; Copyright © 2024 Zheng Junjie <873216071@qq.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -186,14 +187,14 @@ cards and generate meaningful file and folder names.")
(define-public libraw
(package
(name "libraw")
- (version "0.20.0")
+ (version "0.21.2")
(source (origin
(method url-fetch)
(uri (string-append "https://www.libraw.org/data/LibRaw-"
version ".tar.gz"))
(sha256
(base32
- "18wlsvj6c1rv036ph3695kknpgzc3lk2ikgshy8417yfl8ykh2hz"))))
+ "00sbscniqrwj341gyvzkgcidfkmscgxx05s4dsplp186680qhwpy"))))
(build-system gnu-build-system)
(native-inputs
(list pkg-config))
@@ -530,7 +531,7 @@ photographic equipment.")
(define-public darktable
(package
(name "darktable")
- (version "4.6.1")
+ (version "4.8.0")
(source
(origin
(method url-fetch)
@@ -538,7 +539,7 @@ photographic equipment.")
"https://github.com/darktable-org/darktable/releases/"
"download/release-" version "/darktable-" version ".tar.xz"))
(sha256
- (base32 "1zbsrx5cfyifzbi657izw8rfkgd9pm4hx8afv8y2sgi9f2hc1v8n"))))
+ (base32 "0mcjgz8kmsmj5icik3zsrk61qg9dafswch93bw3y8w2j07llk621"))))
(build-system cmake-build-system)
(arguments
(list