summaryrefslogtreecommitdiff
path: root/gnu/packages/pulseaudio.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/pulseaudio.scm')
-rw-r--r--gnu/packages/pulseaudio.scm55
1 files changed, 23 insertions, 32 deletions
diff --git a/gnu/packages/pulseaudio.scm b/gnu/packages/pulseaudio.scm
index 1fb64fd8a6..96ba13d484 100644
--- a/gnu/packages/pulseaudio.scm
+++ b/gnu/packages/pulseaudio.scm
@@ -450,9 +450,9 @@ only configure local servers, and requires that a special module
module-gsettings is loaded in the sound server.")
(license l:gpl2)))
-(define-public rnnoise
+(define-public noise-suppression-for-voice
(package
- (name "rnnoise")
+ (name "noise-suppression-for-voice")
(version "0.91")
(source
(origin
@@ -472,67 +472,58 @@ module-gsettings is loaded in the sound server.")
pulseaudio))
(home-page "https://github.com/werman/noise-suppression-for-voice")
(synopsis "Real-time Noise suppression plugin based on Xiph's RNNoise")
- (description "The plugin is meant to suppress a wide range of noise
-origins: computer fans, office, crowd, airplane, car, train, construction.
+ (description "This plug-in is meant to suppress a wide range of noise
+origins: computer fans, offices, crowds, airplanes, cars, trains,
+construction, and more.
Mild background noise is always suppressed, loud sounds, like
clicking of mechanical keyboard, are suppressed while there is no voice
however they are only reduced in volume when voice is present.
-The plugin is made to work with 1 or 2 channels (ladspa plugin),
+The plug-in is made to work with 1 or 2 channels (LADSPA plugin),
16 bit, 48000 Hz audio input.")
(license l:gpl3)))
(define-public noisetorch
(package
(name "noisetorch")
- (version "0.8.3")
+ (version "0.12.2")
(source
(origin
(method git-fetch)
(uri (git-reference
- (url "https://github.com/lawl/NoiseTorch")
- (commit version)))
+ (url "https://github.com/noisetorch/NoiseTorch")
+ (commit (string-append "v" version))))
(file-name (git-file-name name version))
(sha256
- (base32 "115sq4waq048bv82lnq5sblf62m50yvyakx7x06qq359v7qf5ji1"))))
+ (base32 "1qwzqv4rww9xywkfnjr79489d35cypa1zm9rgm966g51zzwhxrck"))))
(build-system go-build-system)
(arguments
- `(#:import-path "github.com/lawl/NoiseTorch"
+ `(#:import-path "github.com/noisetorch/NoiseTorch"
#:install-source? #f
#:phases
(modify-phases %standard-phases
- (add-after 'unpack 'symlink-rnnoise
+ (add-after 'unpack 'copy-rnnoise-library
(lambda* (#:key inputs #:allow-other-keys)
- (with-directory-excursion "src/github.com/lawl/NoiseTorch"
- (let ((dir "librnnoise_ladspa/bin/ladspa")
- (rnnoise (assoc-ref inputs "rnnoise")))
+ (with-directory-excursion "src/github.com/noisetorch/NoiseTorch"
+ (let ((lib (search-input-file inputs
+ "lib/ladspa/librnnoise_ladspa.so"))
+ (dir "c/ladspa"))
(mkdir-p dir)
- (symlink (string-append rnnoise "/lib/ladspa/librnnoise_ladspa.so")
- (string-append dir "/librnnoise_ladspa.so"))))
- #t))
- (add-after 'unpack 'gen-version.go
- (lambda _
- (with-directory-excursion "src/github.com/lawl/NoiseTorch"
- (substitute* "main.go"
- (("//go:generate go run scripts/embedversion\\.go") ""))
- (with-output-to-file "version.go"
- (lambda ()
- (format #t "package main~%~%var version=~s~&" ,version))))
- #t))
+ ;; Symlinking won't work: ‘cannot embed irregular file’!
+ (copy-file lib (string-append dir "/rnnoise_ladspa.so"))))))
(add-after 'unpack 'disable-update-check.go
(lambda _
- (with-directory-excursion "src/github.com/lawl/NoiseTorch"
+ (with-directory-excursion "src/github.com/noisetorch/NoiseTorch"
(substitute* "main.go"
- ((".*updateCheck.*") "")))
- #t))
+ ((".*updateCheck.*") "")))))
(add-before 'build 'go-generate
(lambda _
- (with-directory-excursion "src/github.com/lawl/NoiseTorch"
+ (with-directory-excursion "src/github.com/noisetorch/NoiseTorch"
(invoke "go" "generate")))))))
(inputs
- (list rnnoise))
- (home-page "https://github.com/lawl/NoiseTorch")
+ (list noise-suppression-for-voice))
+ (home-page "https://github.com/noisetorch/NoiseTorch")
(synopsis "Real-time microphone noise suppression")
(description "NoiseTorch creates a virtual PulseAudio microphone that
suppresses noise, in any application. Use whichever conferencing or VOIP