summaryrefslogtreecommitdiff
path: root/gnu/packages/python-science.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/python-science.scm')
-rw-r--r--gnu/packages/python-science.scm65
1 files changed, 43 insertions, 22 deletions
diff --git a/gnu/packages/python-science.scm b/gnu/packages/python-science.scm
index 57b852c2bd..4bb8ac342d 100644
--- a/gnu/packages/python-science.scm
+++ b/gnu/packages/python-science.scm
@@ -567,29 +567,16 @@ swarm algorithm.")
(define-public python-scikit-optimize
(package
(name "python-scikit-optimize")
- (version "0.9.0")
+ (version "0.10.2")
(source (origin
(method git-fetch)
(uri (git-reference
- (url "https://github.com/scikit-optimize/scikit-optimize")
+ (url "https://github.com/holgern/scikit-optimize")
(commit (string-append "v" version))))
(file-name (git-file-name name version))
(sha256
(base32
- "0hsq6pmryimxc275yrcy4bv217bx7ma6rz0q6m4138bv4zgq18d1"))
- (patches
- ;; These are for compatibility with more recent versions of
- ;; numpy and scikit-learn.
- (search-patches "python-scikit-optimize-1148.patch"
- "python-scikit-optimize-1150.patch"))
- (modules '((guix build utils)))
- (snippet
- ;; Since scikit-learn 1.3 max_features no longer supports
- ;; 'auto', which is identical to 'sqrt'
- '(substitute* '("skopt/learning/forest.py"
- "skopt/learning/tests/test_forest.py")
- (("max_features=['\"]auto['\"]")
- "max_features='sqrt'")))))
+ "0pc6avzxz8l32km5jvv3maih0a5x2akxybvxl2hdg04qz2l0kz8b"))))
(build-system pyproject-build-system)
(propagated-inputs
(list python-joblib
@@ -792,6 +779,37 @@ volume computations for simple domains like regular polygons, disks,
spheres, cubes, etc.")
(license license:gpl3+)))
+(define-public python-mpl-scatter-density
+ (package
+ (name "python-mpl-scatter-density")
+ (version "0.7")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "mpl-scatter-density" version))
+ (sha256
+ (base32 "083n4xkwjmxvij9i1xhfnxz8vk39ay0baam4nf0khvcihw47bkna"))))
+ (build-system pyproject-build-system)
+ (arguments
+ (list
+ ;; See <https://github.com/astrofrog/mpl-scatter-density/issues/42>.
+ #:test-flags #~(list "-k" "not test_default_dpi")))
+ (propagated-inputs
+ (list python-fast-histogram
+ python-matplotlib
+ python-numpy))
+ (native-inputs
+ (list python-pytest
+ python-pytest-cov
+ python-pytest-mpl
+ python-setuptools-scm))
+ (home-page "https://github.com/astrofrog/mpl-scatter-density")
+ (synopsis "Matplotlib helpers to make density scatter plots")
+ (description
+ "This package provides functionality to make it easy to make scatter
+density maps, both for interactive and non-interactive use.")
+ (license license:bsd-2)))
+
(define-public python-pyamg
(package
(name "python-pyamg")
@@ -1564,17 +1582,20 @@ higher scores.")
(lambda _
(invoke "python" "setup.py" "build_ext" "--inplace"))))))
(propagated-inputs (list python-numpy))
- (native-inputs (list python-hypothesis python-pytest))
+ (native-inputs
+ (list python-hypothesis
+ python-pytest
+ python-setuptools-scm))
(home-page "https://github.com/astrofrog/fast-histogram")
(synopsis "Fast simple 1D and 2D histograms")
(description
"The fast-histogram mini-package aims to provide simple and fast
-histogram functions for regular bins that don't compromise on performance. It
+histogram functions for regular bins that don't compromise on performance. It
doesn't do anything complicated - it just implements a simple histogram
-algorithm in C and keeps it simple. The aim is to have functions that are fast
-but also robust and reliable. The result is a 1D histogram function here that
-is 7-15x faster than @code{numpy.histogram}, and a 2D histogram function that
-is 20-25x faster than @code{numpy.histogram2d}.")
+algorithm in C and keeps it simple. The aim is to have functions that are
+fast but also robust and reliable. The result is a 1D histogram function here
+that is 7-15x faster than @code{numpy.histogram}, and a 2D histogram function
+that is 20-25x faster than @code{numpy.histogram2d}.")
(license license:bsd-3)))
(define-public python-fastcluster