summaryrefslogtreecommitdiff
path: root/gnu/packages/python-xyz.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/python-xyz.scm')
-rw-r--r--gnu/packages/python-xyz.scm15
1 files changed, 13 insertions, 2 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index fa16687e24..653d8aa9de 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -21475,9 +21475,20 @@ data.")
(define-public python2-cloudpickle
(let ((base (package-with-python2 (strip-python2-variant python-cloudpickle))))
(package/inherit base
+ (version "1.3.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "cloudpickle" version))
+ (sha256
+ (base32
+ "0lx7gy9clp427qwcm7b23zdsldpr03gy3vxxhyi8fpbhwz859brq"))))
(native-inputs
- `(("python-mock" ,python2-mock)
- ,@(package-native-inputs base)))
+ `(;; For tests.
+ ("python-mock" ,python2-mock)
+ ("python-psutil" ,python2-psutil)
+ ("python-pytest" ,python2-pytest)
+ ("python-tornado" ,python2-tornado)))
(propagated-inputs
`(("python-futures" ,python2-futures)
,@(package-propagated-inputs base))))))