summaryrefslogtreecommitdiff
path: root/gnu/packages/python-xyz.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/python-xyz.scm')
-rw-r--r--gnu/packages/python-xyz.scm9
1 files changed, 6 insertions, 3 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index b574ec2efe..5445318157 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -8551,9 +8551,10 @@ and therefore easier to read and write.")
#:phases
#~(modify-phases %standard-phases
(add-before 'build 'no-/bin/sh
- (lambda _
- (substitute* '("distlib/scripts.py" "tests/test_scripts.py")
- (("/bin/sh") (which "sh")))))
+ (lambda* (#:key inputs #:allow-other-keys)
+ (let ((/bin/sh (search-input-file inputs "bin/sh")))
+ (substitute* '("distlib/scripts.py" "tests/test_scripts.py")
+ (("/bin/sh") /bin/sh)))))
(add-before 'check 'prepare-test-environment
(lambda _
(setenv "HOME" "/tmp")
@@ -8561,6 +8562,8 @@ and therefore easier to read and write.")
(setenv "SKIP_ONLINE" "1"))))))
(native-inputs
(list python-pytest))
+ (inputs
+ (list bash-minimal))
(home-page "https://github.com/pypa/distlib")
(synopsis "Distribution utilities")
(description "Distlib is a library which implements low-level functions that