summaryrefslogtreecommitdiff
path: root/gnu/packages/python.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/python.scm')
-rw-r--r--gnu/packages/python.scm5
1 files changed, 3 insertions, 2 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index f0d2fd6eb8..3bc3346c21 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -431,7 +431,7 @@ data types.")
(package
(inherit python-2)
(name "python")
- (version "3.9.6")
+ (version "3.9.9")
(source (origin
(method url-fetch)
(uri (string-append "https://www.python.org/ftp/python/"
@@ -445,7 +445,7 @@ data types.")
"python-3-no-static-lib.patch"))
(sha256
(base32
- "12hhw2685i68pwfx5hdkqngzhbji4ccyjmqb5rzvkigg6fpj0y9r"))
+ "09vd7g71i11iz5ydqghwc8kaxr0vgji94hhwwnj77h3kll28r0h6"))
(modules '((guix build utils)))
(snippet
'(begin
@@ -780,6 +780,7 @@ ease from the desktop to a microcontroller or embedded system.")
`(#:tests? #f ;FIXME: 43 out of 364 tests are failing
#:modules ((ice-9 ftw) (ice-9 match)
(guix build utils) (guix build gnu-build-system))
+ #:disallowed-references (,nss-certs)
#:phases (modify-phases %standard-phases
(delete 'configure)
(add-after 'unpack 'patch-source