summaryrefslogtreecommitdiff
path: root/gnu/packages/qt.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/qt.scm')
-rw-r--r--gnu/packages/qt.scm14
1 files changed, 11 insertions, 3 deletions
diff --git a/gnu/packages/qt.scm b/gnu/packages/qt.scm
index db5badb938..74ea047271 100644
--- a/gnu/packages/qt.scm
+++ b/gnu/packages/qt.scm
@@ -1491,14 +1491,14 @@ with JavaScript and C++.")))
(define-public qtdeclarative
(package
(name "qtdeclarative")
- (version "6.5.2")
+ (version "6.6.2")
;; TODO: Package 'masm' and unbundle from sources.
(source (origin
(method url-fetch)
(uri (qt-url name version))
(sha256
(base32
- "06c7xfqn2a5s2m8j1bcvx3pyjqg1rgqkjvp49737gb4z9vjiz8gk"))
+ "0k6qndjvkkx3g8lr7f64xx86b3cwxzkgpl6fr6cp73s6qjkyk763"))
(patches (search-patches "qtdeclarative-disable-qmlcache.patch"))))
(outputs '("out" "debug"))
(build-system cmake-build-system)
@@ -1568,6 +1568,10 @@ with JavaScript and C++.")))
"("
(string-join
(list
+ ;; The 'tst_qmltyperegistrar' tests may fail
+ ;; non-deterministically (see:
+ ;; https://bugreports.qt.io/browse/QTBUG-123634).
+ "tst_qmltyperegistrar"
;; This test is marked as flaky upstream (see:
;; https://bugreports.qt.io/browse/QTBUG-101488).
"tst_qquickfiledialogimpl"
@@ -1610,7 +1614,11 @@ with JavaScript and C++.")))
"tst_dom_all"
"tst_qmlls"
"tst_qmllscompletions"
- ) "|")
+
+ ;; This test fails starting with 6.6.2 (see:
+ ;; https://bugreports.qt.io/browse/QTBUG-123748), for
+ ;; unknown reasons.
+ "tst_qquickiconimage") "|")
")")))))
(add-after 'install 'delete-installed-tests
(lambda _