summaryrefslogtreecommitdiff
path: root/gnu/packages/qt.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/qt.scm')
-rw-r--r--gnu/packages/qt.scm151
1 files changed, 73 insertions, 78 deletions
diff --git a/gnu/packages/qt.scm b/gnu/packages/qt.scm
index 0163d02bc0..9920af74fb 100644
--- a/gnu/packages/qt.scm
+++ b/gnu/packages/qt.scm
@@ -1771,69 +1771,68 @@ using the Enchant spell-checking library.")
;; Do not enable support for loading the Widevine DRM plugin.
(substitute* "src/buildtools/config/common.pri"
(("enable_widevine=true")
- "enable_widevine=false"))
- #t)))))
+ "enable_widevine=false")))))))
(build-system gnu-build-system)
(native-inputs
- `(("bison" ,bison)
- ("flex" ,flex)
- ("gperf" ,gperf)
- ("ninja" ,ninja)
- ("perl" ,perl)
- ("pkg-config" ,pkg-config)
- ("python-2" ,python-2)
- ("python-six" ,python2-six)
- ("ruby" ,ruby)))
+ (list bison
+ flex
+ gperf
+ ninja
+ perl
+ pkg-config
+ python2-six
+ python-2
+ ruby))
(inputs
- `(("alsa-lib" ,alsa-lib)
- ("atk" ,atk)
- ("cups-minimal" ,cups-minimal)
- ("curl" ,curl)
- ("dbus" ,dbus)
- ("ffmpeg" ,ffmpeg)
- ("fontconfig" ,fontconfig)
- ("harbuzz" ,harfbuzz)
- ("icu4c" ,icu4c)
- ("jsoncpp" ,jsoncpp)
- ("lcms" ,lcms)
- ("libcap" ,libcap)
- ("libevent" ,libevent)
- ("libgcrypt" ,libgcrypt)
- ("libjpeg" ,libjpeg-turbo)
- ("libvpx" ,libvpx)
- ("libwebp" ,libwebp)
- ("libx11" ,libx11)
- ("libxcb" ,libxcb)
- ("libxcomposite" ,libxcomposite)
- ("libxcursor" ,libxcursor)
- ("libxi" ,libxi)
- ("libxkbcommon" ,libxkbcommon)
- ;; FIXME: libxml2 needs to built with icu support though it links to
- ;; libxml2 configure summary still states "Checking for compatible
- ;; system libxml2... no"
- ("libxml2" ,libxml2)
- ("openh264" ,openh264)
- ("libxrandr" ,libxrandr)
- ("libxrender" ,libxrender)
- ("libxslt" ,libxslt)
- ("libxtst" ,libxtst)
- ("mesa" ,mesa)
- ("minizip" ,minizip)
- ("nss" ,nss)
- ("opus" ,opus)
- ("pciutils" ,pciutils)
- ("protobuf" ,protobuf)
- ("pulseaudio" ,pulseaudio)
- ("qtbase" ,qtbase-5)
- ("qtdeclarative" ,qtdeclarative)
- ("qtmultimedia" ,qtmultimedia)
- ("qtwebchannel" ,qtwebchannel)
- ("re2" ,re2)
- ("snappy" ,snappy)
- ("udev" ,eudev)
- ("valgrind" ,valgrind)
- ("vulkan-headers" ,vulkan-headers)
- ("xcb-util" ,xcb-util)))
+ (list alsa-lib
+ atk
+ cups-minimal
+ curl
+ dbus
+ ffmpeg
+ fontconfig
+ harfbuzz
+ icu4c
+ jsoncpp
+ lcms
+ libcap
+ libevent
+ libgcrypt
+ libjpeg-turbo
+ libvpx
+ libwebp
+ libx11
+ libxcb
+ libxcomposite
+ libxcursor
+ libxi
+ libxkbcommon
+ ;; FIXME: libxml2 needs to built with icu support though it links to
+ ;; libxml2 configure summary still states "Checking for compatible
+ ;; system libxml2... no"
+ libxml2
+ openh264
+ libxrandr
+ libxrender
+ libxslt
+ libxtst
+ mesa
+ minizip
+ nss
+ opus
+ pciutils
+ protobuf
+ pulseaudio
+ qtbase-5
+ qtdeclarative
+ qtmultimedia
+ qtwebchannel
+ re2
+ snappy
+ eudev
+ valgrind
+ vulkan-headers
+ xcb-util))
(arguments
(substitute-keyword-arguments (package-arguments qtsvg)
((#:modules modules '())
@@ -1844,13 +1843,12 @@ using the Enchant spell-checking library.")
`(modify-phases ,phases
(add-before 'configure 'substitute-source
(lambda* (#:key inputs outputs #:allow-other-keys)
- (let ((out (assoc-ref outputs "out"))
- (nss (assoc-ref inputs "nss"))
- (udev (assoc-ref inputs "udev")))
- (with-atomic-file-replacement "src/buildtools/config/linux.pri"
- (lambda (in out)
- (display (get-string-all in) out)
- (display "\ngn_args += use_system_openh264=true\n" out)))
+ (let ((out (assoc-ref outputs "out")))
+ (with-atomic-file-replacement
+ "src/buildtools/config/linux.pri"
+ (lambda (in out)
+ (display (get-string-all in) out)
+ (display "\ngn_args += use_system_openh264=true\n" out)))
;; Qtwebengine is not installed into the same prefix as
;; qtbase. Some qtbase QTLibraryInfo constants will not
;; work. Replace with the full path to the qtwebengine
@@ -1863,12 +1861,11 @@ using the Enchant spell-checking library.")
;; Substitute full dynamic library path for nss.
(substitute* "src/3rdparty/chromium/crypto/nss_util.cc"
(("libnssckbi.so")
- (string-append nss "/lib/nss/libnssckbi.so")))
+ (search-input-file inputs "lib/nss/libnssckbi.so")))
;; Substitute full dynamic library path for udev.
(substitute* "src/3rdparty/chromium/device/udev_linux/udev1_loader.cc"
(("libudev.so.1")
- (string-append udev "/lib/libudev.so.1")))
- #t)))
+ (search-input-file inputs "lib/libudev.so.1"))))))
(add-before 'configure 'set-env
(lambda _
;; Avoids potential race conditions.
@@ -1876,8 +1873,7 @@ using the Enchant spell-checking library.")
(setenv "NINJAFLAGS"
(string-append "-k1" ;less verbose build output
;; Respect the '--cores' option of 'guix build'.
- " -j" (number->string (parallel-job-count))))
- #t))
+ " -j" (number->string (parallel-job-count))))))
(replace 'configure
(lambda _
;; Valid QT_BUILD_PARTS variables are:
@@ -2000,7 +1996,7 @@ module provides support functions to the automatically generated code.")
(package
(inherit python-sip)
(name "python-sip")
- (version "4.19.24")
+ (version "4.19.25")
(source
(origin
(method url-fetch)
@@ -2010,7 +2006,7 @@ module provides support functions to the automatically generated code.")
"/sip-" version ".tar.gz")))
(sha256
(base32
- "1ra15vb5i9gkg2vdvh16cq9x2mmzw1yi3xphxs8q34q1pf83gkgd"))))
+ "04a23cgsnx150xq86w1z44b6vr2zyazysy9mqax0fy346zlr77dk"))))
(build-system gnu-build-system)
(native-inputs
`(("python" ,python-wrapper)))
@@ -2269,17 +2265,16 @@ top of the PyQt bindings for Qt. PyQt-builder is used to build PyQt itself.")
(define-public python-qtpy
(package
(name "python-qtpy")
- (version "1.9.0")
+ (version "2.0.1")
(source
(origin
(method url-fetch)
(uri (pypi-uri "QtPy" version))
(sha256
(base32
- "13cw8l7zrhbdi03k1wl1pg9xdl4ahdfa7yz8gd0f23sxnm22rdrd"))))
+ "13zbhnl2rm30xafwrzfwdb4mjp7gk4s9h2xagbf83pnjzczhgzdd"))))
(build-system python-build-system)
- (propagated-inputs
- `(("python-pyside2" ,python-pyside-2)))
+ (propagated-inputs (list python-packaging))
(arguments
`(;; Not all supported bindings are packaged. Especially PyQt4.
#:tests? #f))