summaryrefslogtreecommitdiff
path: root/gnu/packages/scheme.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/scheme.scm')
-rw-r--r--gnu/packages/scheme.scm16
1 files changed, 6 insertions, 10 deletions
diff --git a/gnu/packages/scheme.scm b/gnu/packages/scheme.scm
index 47754800f9..927e10bbfe 100644
--- a/gnu/packages/scheme.scm
+++ b/gnu/packages/scheme.scm
@@ -1085,7 +1085,7 @@ The core is 12 builtin special forms and 33 builtin functions.")
(define-public gauche
(package
(name "gauche")
- (version "0.9.12")
+ (version "0.9.15")
(home-page "https://practical-scheme.net/gauche/index.html")
(source
(origin
@@ -1095,7 +1095,7 @@ The core is 12 builtin special forms and 33 builtin functions.")
(string-replace-substring version "." "_")
"/Gauche-" version ".tgz"))
(sha256
- (base32 "05xnym1phg8i14bacip5d0d3v0gc1nn5mgayd5hnda873f969bml"))))
+ (base32 "10zpbbikkcpdzk6c52wkckiyhn7nhnqjv2djdzyjr0n8qxxy4hrn"))))
(build-system gnu-build-system)
(inputs
(list libatomic-ops slib zlib))
@@ -1116,24 +1116,20 @@ The core is 12 builtin special forms and 33 builtin functions.")
"ext/tls/test.scm"
"lib/gauche/package/util.scm"
"libsrc/gauche/process.scm")
- (("/bin/sh") (which "sh")))
- #t))
+ (("/bin/sh") (which "sh")))))
(add-after 'build 'build-doc
(lambda _
(with-directory-excursion "doc"
- (invoke "make" "info"))
- #t))
+ (invoke "make" "info"))))
(add-before 'check 'patch-network-tests
;; Remove net checks.
(lambda _
(delete-file "test/net.scm")
- (invoke "touch" "test/net.scm")
- #t))
+ (invoke "touch" "test/net.scm")))
(add-after 'install 'install-docs
(lambda _
(with-directory-excursion "doc"
- (invoke "make" "install"))
- #t)))))
+ (invoke "make" "install")))))))
(synopsis "Scheme scripting engine")
(description "Gauche is a R7RS Scheme scripting engine aiming at being a
handy tool that helps programmers and system administrators to write small to