summaryrefslogtreecommitdiff
path: root/gnu/packages/suckless.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/suckless.scm')
-rw-r--r--gnu/packages/suckless.scm66
1 files changed, 66 insertions, 0 deletions
diff --git a/gnu/packages/suckless.scm b/gnu/packages/suckless.scm
index 04803c8fd3..cfeb17e533 100644
--- a/gnu/packages/suckless.scm
+++ b/gnu/packages/suckless.scm
@@ -36,6 +36,7 @@
#:use-module (gnu packages fontutils)
#:use-module (gnu packages gawk)
#:use-module (gnu packages gnome)
+ #:use-module (gnu packages gtk)
#:use-module (gnu packages image)
#:use-module (gnu packages libbsd)
#:use-module (gnu packages linux)
@@ -393,6 +394,71 @@ antialiased fonts (using fontconfig), fallback fonts, resizing, and line
drawing.")
(license license:x11)))
+(define-public xst
+ (package
+ (inherit st)
+ (name "xst")
+ (version "0.8.4.1")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/gnotclub/xst")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "1q64x7czpbcg0v509qchn5v96zdnx7jmvy0zxhjmkk3d10x5rqlw"))))
+ (home-page "https://github.com/gnotclub/xst")
+ (synopsis "Fork of st that uses Xresources")
+ (description
+ "@command{xst} uses Xresources and applies the following patches to
+@command{st}:
+@itemize
+@item @uref{https://st.suckless.org/patches/alpha/, alpha}
+@item @uref{https://st.suckless.org/patches/boxdraw/, boxdraw}
+@item @uref{https://st.suckless.org/patches/clipboard/, clipboard}
+@item @uref{https://st.suckless.org/patches/disable_bold_italic_fonts/, disable_bold_italic_fonts}
+@item @uref{https://st.suckless.org/patches/externalpipe/, externalpipe}
+@item @uref{https://st.suckless.org/patches/scrollback/, scrollback}
+@item @uref{https://st.suckless.org/patches/spoiler/, spoiler}
+@item @uref{https://st.suckless.org/patches/vertcenter/, vertcenter}
+@end itemize")
+ (license license:expat)))
+
+(define-public lukesmithxyz-st
+ (let ((commit "e053bd6036331cc7d14f155614aebc20f5371d3a")
+ (revision "0"))
+ (package
+ (inherit st)
+ (name "lukesmithxyz-st")
+ (version "0.8.4")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/LukeSmithxyz/st")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "12avzzapkkj4mvd00zh8b6gynk6jysh84jcwlkliyyd82lvyw22v"))))
+ (arguments
+ (substitute-keyword-arguments (package-arguments st)
+ ((#:phases phases)
+ `(modify-phases ,phases
+ (add-after 'unpack 'remove-calls-to-git
+ (lambda _
+ (substitute* "Makefile"
+ (("git submodule init") "")
+ (("git submodule update") ""))))))))
+ (inputs (modify-inputs (package-inputs st)
+ (prepend libxext harfbuzz)))
+ (home-page "https://github.com/LukeSmithxyz/st")
+ (synopsis "Luke Smith's fork of st")
+ (description
+ "This package is Luke's fork of the suckless simple terminal (st) with
+Vim bindings and Xresource compatibility.")
+ (license license:expat))))
+
(define-public surf
(package
(name "surf")