summaryrefslogtreecommitdiff
path: root/gnu/packages/suckless.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/suckless.scm')
-rw-r--r--gnu/packages/suckless.scm53
1 files changed, 53 insertions, 0 deletions
diff --git a/gnu/packages/suckless.scm b/gnu/packages/suckless.scm
index a560f8bc62..8dd8f76143 100644
--- a/gnu/packages/suckless.scm
+++ b/gnu/packages/suckless.scm
@@ -12,6 +12,7 @@
;;; Copyright © 2021 Alexandru-Sergiu Marton <brown121407@posteo.ro>
;;; Copyright © 2021 Nikolay Korotkiy <sikmir@disroot.org>
;;; Copyright © 2022 Jai Vetrivelan <jaivetrivelan@gmail.com>
+;;; Copyright © 2022 jgart <jgart@dismail.de>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -461,6 +462,25 @@ drawing.")
Vim bindings and Xresource compatibility.")
(license license:expat))))
+(define-public sxmo-st
+ (package
+ (inherit st)
+ (name "sxmo-st")
+ (version "0.8.4.1")
+ (source
+ (origin
+ (method git-fetch)
+ (uri
+ (git-reference
+ (url "https://git.sr.ht/~mil/sxmo-st")
+ (commit version)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "1nl40q1pxf46hpbibz9m9d0giiy1p3lrhr9agw0fkyba2vzbbafa"))))
+ (home-page "https://git.sr.ht/~mil/sxmo-st")
+ (synopsis "St terminal emulator for the Simple X Mobile PinePhone environment")
+ (license license:expat)))
+
(define-public surf
(package
(name "surf")
@@ -992,6 +1012,39 @@ chat output in the background.")
running a command.")
(license license:cc0)))
+(define-public sbase
+ ;; There are no tagged releases.
+ (let ((commit "2c2a7f54ab55a022a617e510b6e00c3e2736fabd")
+ (revision "0"))
+ (package
+ (name "sbase")
+ (version (git-version "0" revision commit))
+ (source
+ (origin
+ (method git-fetch)
+ (uri
+ (git-reference
+ (url "https://git.suckless.org/sbase/")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "119v1lpgsx8bx9h57wg454ddhzz2awqavl3wrn35a704vifg28g0"))))
+ (build-system gnu-build-system)
+ (arguments
+ (list
+ #:tests? #f ;no test suite
+ #:make-flags #~(list (string-append "CC=" #$(cc-for-target))
+ (string-append "PREFIX=" #$output))
+ #:phases
+ #~(modify-phases %standard-phases
+ (delete 'configure))))
+ (home-page "https://core.suckless.org/sbase/")
+ (synopsis "Collection of UNIX tools")
+ (description "@command{sbase} is a collection of UNIX tools similar to those of GNU
+Coreutils, containing utilities commands such as @command{grep}, @command{cp},
+@command{rm}, etc.")
+ (license license:expat))))
+
(define-public scron
(package
(name "scron")