summaryrefslogtreecommitdiff
path: root/gnu/packages/syncthing.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/syncthing.scm')
-rw-r--r--gnu/packages/syncthing.scm246
1 files changed, 43 insertions, 203 deletions
diff --git a/gnu/packages/syncthing.scm b/gnu/packages/syncthing.scm
index 7e1d8df333..8b41a6317f 100644
--- a/gnu/packages/syncthing.scm
+++ b/gnu/packages/syncthing.scm
@@ -74,33 +74,18 @@
("go-github-com-syncthing-notify" ,go-github-com-syncthing-notify)
("go-github-com-syndtr-goleveldb" ,go-github-com-syndtr-goleveldb)
("go-github-com-thejerf-suture" ,go-github-com-thejerf-suture)
- ("go-golang-org-x-time-rate" ,go-golang-org-x-time-rate)
+ ("go-golang-org-x-time" ,go-golang-org-x-time)
("go-gopkg.in-ldap.v2" ,go-gopkg.in-ldap.v2)
("go-github-com-gogo-protobuf" ,go-github-com-gogo-protobuf)
- ("go-github-com-gogo-protobuf-gogoproto"
- ,go-github-com-gogo-protobuf-gogoproto)
- ("go-github-com-gogo-protobuf-protoc-gen-gogo"
- ,go-github-com-gogo-protobuf-protoc-gen-gogo)
- ("go-github-com-prometheus-client-golang-prometheus"
- ,go-github-com-prometheus-client-golang-prometheus)
("go-github-com-shirou-gopsutil" ,go-github-com-shirou-gopsutil)
- ("go-golang-org-x-net-bpf" ,go-golang-org-x-net-bpf)
- ("go-golang-org-x-net-internal-iana" ,go-golang-org-x-net-internal-iana)
- ("go-golang-org-x-net-internal-socket"
- ,go-golang-org-x-net-internal-socket)
- ("go-golang-org-x-net-internal-socks"
- ,go-golang-org-x-net-internal-socks)
- ("go-golang-org-x-net-ipv4" ,go-golang-org-x-net-ipv4)
- ("go-golang-org-x-net-ipv6" ,go-golang-org-x-net-ipv6)
- ("go-golang-org-x-net-proxy" ,go-golang-org-x-net-proxy)
- ("go-golang-org-x-text-unicode-norm" ,go-golang-org-x-text-unicode-norm)
- ("go-golang-org-x-text-transform" ,go-golang-org-x-text-transform)
+ ("go-github-com-prometheus-client-golang"
+ ,go-github-com-prometheus-client-golang)
+ ("go-golang-org-x-net" ,go-golang-org-x-net)
+ ("go-golang-org-x-text" ,go-golang-org-x-text)
("go-github-com-audriusbutkevicius-recli"
,go-github-com-audriusbutkevicius-recli)
("go-github-com-urfave-cli" ,go-github-com-urfave-cli)
- ("go-github-com-vitrun-qart-qr" ,go-github-com-vitrun-qart-qr)
- ("go-github-com-vitrun-qart-coding" ,go-github-com-vitrun-qart-coding)
- ("go-github-com-vitrun-qart-gf256" ,go-github-com-vitrun-qart-gf256)
+ ("go-github-com-vitrun-qart" ,go-github-com-vitrun-qart)
("go-github-com-mattn-go-isatty" ,go-github-com-mattn-go-isatty)
("go-golang-org-x-crypto" ,go-golang-org-x-crypto)
("go-github-com-flynn-archive-go-shlex"
@@ -461,7 +446,7 @@ database/sql package.")
(propagated-inputs
`(("go-github-com-oschwald-maxminddb-golang"
,go-github-com-oschwald-maxminddb-golang)
- ("go-golang-org-x-sys-unix" ,go-golang-org-x-sys-unix)))
+ ("go-golang-org-x-sys" ,go-golang-org-x-sys)))
(arguments
`(#:import-path "github.com/oschwald/geoip2-golang"
#:tests? #f)) ; Requires some unpackaged software and test data
@@ -488,7 +473,7 @@ GeoLite2 and GeoIP2 databases in Go.")
"1i6d935f3cv9djpjvc2ibh8aps8jqvg454b9pkwg2h98al759ggk"))))
(build-system go-build-system)
(propagated-inputs
- `(("go-golang-org-x-sys-unix" ,go-golang-org-x-sys-unix)))
+ `(("go-golang-org-x-sys" ,go-golang-org-x-sys)))
(arguments
`(#:import-path "github.com/oschwald/maxminddb-golang"
#:tests? #f)) ; Requires some unpackaged software and test data
@@ -629,11 +614,11 @@ environment")
(home-page "https://github.com/thejerf/suture")
(license expat)))
-(define-public go-github-com-vitrun-qart-coding
+(define-public go-github-com-vitrun-qart
(let ((commit "bf64b92db6b05651d6c25a3dabf2d543b360c0aa")
(revision "0"))
(package
- (name "go-github-com-vitrun-qart-coding")
+ (name "go-github-com-vitrun-qart")
(version (git-version "0.0.0" revision commit))
(source (origin
(method git-fetch)
@@ -647,77 +632,16 @@ environment")
"1xk7qki703xmay9ghi3kq2bjf1iw9dz8wik55739d6i7sn77vvkc"))))
(build-system go-build-system)
(arguments
- `(#:import-path "github.com/vitrun/qart/coding"
- #:unpack-path "github.com/vitrun/qart"))
- (synopsis "Low-level QR coding library")
+ `(#:import-path "github.com/vitrun/qart"))
+ (synopsis "Create QR codes with an embedded image")
(description "This package provides a library for embedding
human-meaningful graphics in QR codes. However, instead of scribbling on
redundant pieces and relying on error correction to preserve the meaning,
@code{qart} engineers the encoded values to create the picture in a code with no
-inherent errors. This @code{qart} component, @code{coding}, implements
-low-level QR coding details.")
- (home-page "https://github.com/vitrun/qart/")
- (license bsd-3))))
-
-(define-public go-github-com-vitrun-qart-gf256
- (let ((commit "bf64b92db6b05651d6c25a3dabf2d543b360c0aa")
- (revision "0"))
- (package
- (name "go-github-com-vitrun-qart-gf256")
- (version (git-version "0.0.0" revision commit))
- (source (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://github.com/vitrun/qart")
- (commit commit)))
- (file-name (string-append "go-github-com-vitrun-qart-"
- version "-checkout"))
- (sha256
- (base32
- "1xk7qki703xmay9ghi3kq2bjf1iw9dz8wik55739d6i7sn77vvkc"))))
- (build-system go-build-system)
- (arguments
- `(#:import-path "github.com/vitrun/qart/gf256"
- #:unpack-path "github.com/vitrun/qart"))
- (synopsis "Qart library for Galois Field GF(256) math")
- (description "This package, a component of @code{qart}, provides @code{gf256},
-implements arithmetic over the Galois Field GF(256).")
- (home-page "https://github.com/vitrun/qart")
- (license bsd-3))))
-
-(define-public go-github-com-vitrun-qart-qr
- (let ((commit "bf64b92db6b05651d6c25a3dabf2d543b360c0aa")
- (revision "0"))
- (package
- (name "go-github-com-vitrun-qart-qr")
- (version (git-version "0.0.0" revision commit))
- (source (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://github.com/vitrun/qart")
- (commit commit)))
- (file-name (string-append "go-github-com-vitrun-qart-"
- version "-checkout"))
- (sha256
- (base32
- "1xk7qki703xmay9ghi3kq2bjf1iw9dz8wik55739d6i7sn77vvkc"))))
- (build-system go-build-system)
- (arguments
- `(#:import-path "github.com/vitrun/qart/qr"
- #:unpack-path "github.com/vitrun/qart"))
- (synopsis "Qart component for generating QR codes")
- (description "This package provides a library for embedding
-human-meaningful graphics in QR codes. However, instead of scribbling on
-redundant pieces and relying on error correction to preserve the meaning,
-@code{qart} engineers the encoded values to create the picture in a code with no
-inherent errors. This @code{qart} component, @code{qr}, provides QR code
-generation.")
+inherent errors.")
(home-page "https://github.com/vitrun/qart")
(license bsd-3))))
-;; XXX Syncthing actually imports 'github.com/chmduquesne/rollinghash/adler32'.
-;; Normally we'd package this module indpendenctly but the adler32 module itself
-;; imports 'github.com/chmduquesne/rollinghash/', so this is the easy way out.
(define-public go-github-com-chmduquesne-rollinghash
(let ((commit "a60f8e7142b536ea61bb5d84014171189eeaaa81")
(revision "0"))
@@ -811,7 +735,7 @@ using sh's word-splitting rules.")
(arguments
'(#:import-path "github.com/syncthing/notify"))
(propagated-inputs
- `(("go-golang-org-x-sys-unix" ,go-golang-org-x-sys-unix)))
+ `(("go-golang-org-x-sys" ,go-golang-org-x-sys)))
(synopsis "File system event notification library")
(description "This package provides @code{notify}, a file system event
notification library in Go.")
@@ -869,11 +793,11 @@ data serialization format.")
(home-page "https://github.com/golang/protobuf")
(license bsd-3)))
-(define-public go-github-com-prometheus-client-model-go
+(define-public go-github-com-prometheus-client-model
(let ((commit "fd36f4220a901265f90734c3183c5f0c91daa0b8")
(revision "1"))
(package
- (name "go-github-com-prometheus-client-model-go")
+ (name "go-github-com-prometheus-client-model")
(version (git-version "0.0.2" revision commit))
(source (origin
(method git-fetch)
@@ -886,8 +810,12 @@ data serialization format.")
"1bs5d72k361llflgl94c22n0w53j30rsfh84smgk8mbjbcmjsaa5"))))
(build-system go-build-system)
(arguments
- '(#:import-path "github.com/prometheus/client_model/go"
- #:unpack-path "github.com/prometheus/client_model"))
+ '(#:import-path "github.com/prometheus/client_model"
+ #:tests? #f
+ #:phases
+ (modify-phases %standard-phases
+ ;; Source-only package
+ (delete 'build))))
(propagated-inputs
`(("go-github-com-golang-protobuf-proto"
,go-github-com-golang-protobuf-proto)))
@@ -927,9 +855,9 @@ message streaming.")
(home-page "https://github.com/matttproud/golang_protobuf_extensions")
(license asl2.0))))
-(define-public go-github-com-prometheus-common-expfmt
+(define-public go-github-com-prometheus-common
(package
- (name "go-github-com-prometheus-common-expfmt")
+ (name "go-github-com-prometheus-common")
(version "0.4.1")
(source (origin
(method git-fetch)
@@ -942,8 +870,8 @@ message streaming.")
"0sf4sjdckblz1hqdfvripk3zyp8xq89w7q75kbsyg4c078af896s"))))
(build-system go-build-system)
(arguments
- '(#:import-path "github.com/prometheus/common/expfmt"
- #:unpack-path "github.com/prometheus/common"
+ '(#:import-path "github.com/prometheus/common"
+ #:tests? #f
#:phases
(modify-phases %standard-phases
(add-before 'reset-gzip-timestamps 'make-gzip-archive-writable
@@ -955,49 +883,21 @@ message streaming.")
"/src/github.com/prometheus/common/expfmt/testdata/")
".*\\.gz$"))
#t))
- (replace 'check
- ;; Tests don't pass "vet" on go-1.11. See
- ;; https://github.com/syncthing/syncthing/issues/5311.
- (lambda* (#:key import-path #:allow-other-keys)
- (invoke "go" "test"
- "-vet=off"
- import-path))))))
+ ;; Source-only package
+ (delete 'build))))
(propagated-inputs
`(("go-github-com-golang-protobuf-proto"
,go-github-com-golang-protobuf-proto)
("go-github-com-matttproud-golang-protobuf-extensions-pbutil"
,go-github-com-matttproud-golang-protobuf-extensions-pbutil)
- ("go-github-com-prometheus-client-model-go"
- ,go-github-com-prometheus-client-model-go)))
+ ("go-github-com-prometheus-client-model"
+ ,go-github-com-prometheus-client-model)))
(synopsis "Prometheus metrics")
(description "This package provides tools for reading and writing
Prometheus metrics.")
(home-page "https://github.com/prometheus/common")
(license asl2.0)))
-(define-public go-github-com-prometheus-common-model
- (package
- (name "go-github-com-prometheus-common-model")
- (version "0.4.1")
- (source (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://github.com/prometheus/common.git")
- (commit (string-append "v" version))))
- (file-name (git-file-name name version))
- (sha256
- (base32
- "0sf4sjdckblz1hqdfvripk3zyp8xq89w7q75kbsyg4c078af896s"))))
- (build-system go-build-system)
- (arguments
- '(#:import-path "github.com/prometheus/common/model"
- #:unpack-path "github.com/prometheus/common"))
- (synopsis "Prometheus component")
- (description "This package provides a component of the Go Prometheus
-implementation.")
- (home-page "https://github.com/prometheus/common")
- (license asl2.0)))
-
(define-public go-github-com-prometheus-procfs
(package
(name "go-github-com-prometheus-procfs")
@@ -1023,9 +923,9 @@ system, kernel, and process metrics from the @file{/proc} pseudo file system.")
(home-page "https://github.com/prometheus/procfs")
(license asl2.0)))
-(define-public go-github-com-client-golang-prometheus-promhttp
+(define-public go-github-com-prometheus-client-golang
(package
- (name "go-github-com-client-golang-prometheus-promhttp")
+ (name "go-github-com-prometheus-client-golang")
(version "0.9.4")
(source (origin
(method git-fetch)
@@ -1038,22 +938,21 @@ system, kernel, and process metrics from the @file{/proc} pseudo file system.")
"0s134fj4i7k6pxdmxwkdi7amb1882yq33spv15hg3pkpbd3h311p"))))
(build-system go-build-system)
(arguments
- '(#:tests? #f ; The tests require internet access
- #:import-path "github.com/prometheus/client_golang/prometheus/promhttp"
- #:unpack-path "github.com/prometheus/client_golang"))
+ '(#:tests? #f
+ #:import-path "github.com/prometheus/client_golang"
+ #:phases
+ (modify-phases %standard-phases
+ ;; Source-only package
+ (delete 'build))))
(propagated-inputs
`(("go-github-com-beorn7-perks-quantile"
,go-github-com-beorn7-perks-quantile)
("go-github-com-golang-protobuf-proto"
,go-github-com-golang-protobuf-proto)
- ("go-github-com-prometheus-common-model"
- ,go-github-com-prometheus-common-model)
- ("go-github-com-prometheus-client-model-go"
- ,go-github-com-prometheus-client-model-go)
- ("go-github-com-prometheus-common-internal-bitbucket-org-ww-goautoneg"
- ,go-github-com-prometheus-common-internal-bitbucket-org-ww-goautoneg)
- ("go-github-com-prometheus-common-expfmt"
- ,go-github-com-prometheus-common-expfmt)
+ ("go-github-com-prometheus-client-model"
+ ,go-github-com-prometheus-client-model)
+ ("go-github-com-prometheus-common"
+ ,go-github-com-prometheus-common)
("go-github-com-prometheus-procfs" ,go-github-com-prometheus-procfs)))
(synopsis "HTTP server and client tools for Prometheus")
(description "This package @code{promhttp} provides HTTP client and
@@ -1061,43 +960,6 @@ server tools for Prometheus metrics.")
(home-page "https://github.com/prometheus/client_golang")
(license asl2.0)))
-(define-public go-github-com-prometheus-client-golang-prometheus
- (package
- (name "go-github-com-prometheus-client-golang-prometheus")
- (version "0.9.4")
- (source (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://github.com/prometheus/client_golang.git")
- (commit (string-append "v" version))))
- (file-name (git-file-name name version))
- (sha256
- (base32
- "0s134fj4i7k6pxdmxwkdi7amb1882yq33spv15hg3pkpbd3h311p"))))
- (build-system go-build-system)
- (arguments
- '(#:import-path "github.com/prometheus/client_golang/prometheus"
- #:unpack-path "github.com/prometheus/client_golang"
- #:tests? #f)) ; 'TestHandler' test fails in this non-critical dependency
- (propagated-inputs
- `(("go-github-com-beorn7-perks-quantile"
- ,go-github-com-beorn7-perks-quantile)
- ("go-github-com-prometheus-common-model" ,go-github-com-prometheus-common-model)
- ("go-github-com-prometheus-client-model-go"
- ,go-github-com-prometheus-client-model-go)
- ("go-github-com-prometheus-common-expfmt"
- ,go-github-com-prometheus-common-expfmt)
- ("go-github-com-prometheus-procfs" ,go-github-com-prometheus-procfs)
- ("go-github-com-prometheus-common-internal-bitbucket-org-ww-goautoneg"
- ,go-github-com-prometheus-common-internal-bitbucket-org-ww-goautoneg)))
- (synopsis "Prometheus instrumentation library for Go applications")
- (description "This package provides the Go client library for the
-Prometheus monitoring and alerting system. It has two separate parts, one for
-instrumenting application code, and one for creating clients that talk to the
-Prometheus HTTP API.")
- (home-page "https://github.com/prometheus/client_golang")
- (license asl2.0)))
-
(define-public go-gopkg.in-asn1-ber.v1
(package
(name "go-gopkg.in-asn1-ber.v1")
@@ -1114,7 +976,7 @@ Prometheus HTTP API.")
(build-system go-build-system)
(arguments
'(#:import-path "gopkg.in/asn1-ber.v1"
- ;; Tests don't pass "vet" on go-1.11. See
+ ;; Tests don't pass "vet" on Go since 1.11. See
;; https://github.com/go-asn1-ber/asn1-ber/issues/20.
#:phases
(modify-phases %standard-phases
@@ -1178,28 +1040,6 @@ quoting, commenting, and escaping.")
(home-page "https://github.com/flynn-archive/go-shlex")
(license asl2.0))))
-(define-public go-github-com-prometheus-common-internal-bitbucket-org-ww-goautoneg
- (package
- (name "go-github-com-prometheus-common-internal-bitbucket-org-ww-goautoneg")
- (version "0.4.1")
- (source (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://github.com/prometheus/common.git")
- (commit (string-append "v" version))))
- (file-name (git-file-name name version))
- (sha256
- (base32
- "0sf4sjdckblz1hqdfvripk3zyp8xq89w7q75kbsyg4c078af896s"))))
- (build-system go-build-system)
- (arguments
- '(#:import-path "github.com/prometheus/common/internal/bitbucket.org/ww/goautoneg"
- #:unpack-path "github.com/prometheus/common"))
- (synopsis "Internal Prometheus component")
- (description "This package is an internal component of Prometheus.")
- (home-page "https://github.com/prometheus/common")
- (license asl2.0)))
-
(define-public go-github-com-audriusbutkevicius-pfilter
(let ((commit "c55ef6137fc6f075801eac099cc2687ede0f101d")
(revision "3"))