summaryrefslogtreecommitdiff
path: root/gnu/packages/syndication.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/syndication.scm')
-rw-r--r--gnu/packages/syndication.scm51
1 files changed, 27 insertions, 24 deletions
diff --git a/gnu/packages/syndication.scm b/gnu/packages/syndication.scm
index 7f2153f784..dff317f595 100644
--- a/gnu/packages/syndication.scm
+++ b/gnu/packages/syndication.scm
@@ -232,42 +232,45 @@ cards.")
("openssl" ,openssl)
("pkg-config" ,pkg-config)
;; For building documentation.
- ("asciidoctor" ,ruby-asciidoctor)))
+ ("asciidoctor" ,ruby-asciidoctor)
+ ;; And the rust deps
+ ("rust-cxx-build" ,rust-cxx-build-1)
+ ("rust-tempfile" ,rust-tempfile-3)
+ ("rust-proptest" ,rust-proptest-1)
+ ("rust-section-testing" ,rust-section-testing-0.0)
+ ;; And the packages which can't be found for some reason...
+ ;("rust-num-integer" ,rust-num-integer-0.1)
+ ))
(inputs
`(("curl" ,curl)
("json-c" ,json-c)
("libxml2" ,libxml2)
("ncurses" ,ncurses)
("stfl" ,stfl)
- ("sqlite" ,sqlite)))
+ ("sqlite" ,sqlite)
+ ;; And the rust deps
+ ("rust-backtrace" ,rust-backtrace-0.3)
+ ("rust-bitflags" ,rust-bitflags-1.3)
+ ("rust-chrono" ,rust-chrono-0.4)
+ ("rust-clap" ,rust-clap-2)
+ ("rust-curl-sys" ,rust-curl-sys-0.4)
+ ("rust-cxx" ,rust-cxx-1)
+ ("rust-fastrand" ,rust-fastrand-1)
+ ("rust-gettext-rs" ,rust-gettext-rs-0.7)
+ ("rust-libc" ,rust-libc-0.2)
+ ("rust-natord" ,rust-natord-1)
+ ("rust-nom" ,rust-nom-7)
+ ("rust-once-cell" ,rust-once-cell-1)
+ ("rust-percent-encoding" ,rust-percent-encoding-2)
+ ("rust-url" ,rust-url-2)
+ ("rust-unicode-width" ,rust-unicode-width-0.1)
+ ("rust-xdg" ,rust-xdg-2)) )
(arguments
`(#:modules ((guix build cargo-build-system)
(guix build utils)
((guix build gnu-build-system) #:prefix gnu:))
#:vendor-dir "vendor"
#:install-source? #f
- #:cargo-inputs
- (("rust-backtrace" ,rust-backtrace-0.3)
- ("rust-bitflags" ,rust-bitflags-1.3)
- ("rust-chrono" ,rust-chrono-0.4)
- ("rust-clap" ,rust-clap-2)
- ("rust-curl-sys" ,rust-curl-sys-0.4)
- ("rust-cxx" ,rust-cxx-1)
- ("rust-fastrand" ,rust-fastrand-1)
- ("rust-gettext-rs" ,rust-gettext-rs-0.7)
- ("rust-libc" ,rust-libc-0.2)
- ("rust-natord" ,rust-natord-1)
- ("rust-nom" ,rust-nom-7)
- ("rust-once-cell" ,rust-once-cell-1)
- ("rust-percent-encoding" ,rust-percent-encoding-2)
- ("rust-url" ,rust-url-2)
- ("rust-unicode-width" ,rust-unicode-width-0.1)
- ("rust-xdg" ,rust-xdg-2))
- #:cargo-development-inputs
- (("rust-cxx-build" ,rust-cxx-build-1)
- ("rust-tempfile" ,rust-tempfile-3)
- ("rust-proptest" ,rust-proptest-1)
- ("rust-section-testing" ,rust-section-testing-0.0))
#:phases
(modify-phases %standard-phases
(add-after 'configure 'dont-vendor-self