summaryrefslogtreecommitdiff
path: root/gnu/packages/telephony.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/telephony.scm')
-rw-r--r--gnu/packages/telephony.scm18
1 files changed, 7 insertions, 11 deletions
diff --git a/gnu/packages/telephony.scm b/gnu/packages/telephony.scm
index 1cf2fa8edf..b4b2585935 100644
--- a/gnu/packages/telephony.scm
+++ b/gnu/packages/telephony.scm
@@ -107,6 +107,7 @@
(uri (git-reference
(url "https://git.kernel.org/pub/scm/network/ofono/phonesim")
(commit "a7c844d45b047b2dae5b0877816c346fce4c47b9")))
+ (file-name (git-file-name name version))
(sha256
(base32 "0rc1c2vr03dmi1dr3skj57v77ga9c22g29xs1qiphqms4isby9cq"))))
(build-system gnu-build-system)
@@ -658,7 +659,7 @@ address of one of the participants.")
(inputs
(list avahi
boost
- libsndfile/fixed
+ libsndfile
libxi
mesa ; avoid bundled
openssl
@@ -741,7 +742,7 @@ your calls and messages.")
(define-public pjproject
(package
(name "pjproject")
- (version "2.11")
+ (version "2.11.1")
(source
(origin
(method git-fetch)
@@ -751,7 +752,7 @@ your calls and messages.")
(file-name (git-file-name name version))
(sha256
(base32
- "1kn9g1x1vmh4130ghph8mldz5m89gsjs4vpdzlzm98m3808gk5an"))
+ "04s4bgr2d22ym2ajjk6q507hyqss1p59yp8avyyyf5f8032nbaws"))
(modules '((guix build utils)))
(snippet
'(begin
@@ -760,12 +761,12 @@ your calls and messages.")
(substitute* "aconfigure.ac"
(("third_party/build/os-auto.mak") ""))
(substitute* "Makefile"
- (("third_party/build") ""))))))
+ (("third_party/build") ""))))
+ (patches (search-patches "pjproject-install-libpjsua2.patch"))))
(build-system gnu-build-system)
(outputs '("out" "debug" "static"))
(arguments
- `(#:tests? #t
- #:test-target "selftest"
+ `(#:test-target "selftest"
#:configure-flags
(list "--enable-shared"
"--with-external-speex"
@@ -794,11 +795,6 @@ your calls and messages.")
"/lib"))
#:phases
(modify-phases %standard-phases
- (add-after 'unpack 'make-source-files-writable
- ;; Make all the files writable to prevent the following error:
- ;; "autom4te: cannot open aconfigure: Permission denied".
- (lambda _
- (for-each make-file-writable (find-files "."))))
(add-before 'build 'build-dep
(lambda _ (invoke "make" "dep")))
;; The check phases is moved after the install phase so to