summaryrefslogtreecommitdiff
path: root/gnu/packages/tex.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/tex.scm')
-rw-r--r--gnu/packages/tex.scm277
1 files changed, 277 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index 6a90ba0821..cdb0218acf 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -8188,3 +8188,280 @@ support packages. Others are cmbright, hvmath and kerkis.")
(license (list license:silofl1.1 ;for Arev Sans
license:lppl1.3a ;for TeX support files
license:gpl2)))) ;for ams-mdbch.sty
+
+(define-public texlive-mathdesign
+ (package
+ (inherit (simple-texlive-package
+ "texlive-mathdesign"
+ (list "/doc/fonts/mathdesign/"
+ "/dvips/mathdesign/"
+ "/fonts/enc/dvips/mathdesign/"
+ "/fonts/map/dvips/mathdesign/"
+ "/fonts/tfm/public/mathdesign/"
+ "/fonts/type1/public/mathdesign/"
+ "/fonts/vf/public/mathdesign/"
+ "/tex/latex/mathdesign/")
+ (base32
+ "0jcby2sd0l3ank2drxc0qcf5d1cwa8idzh4g91h4nxk8zrzxj8nr")
+ #:trivial? #t))
+ (home-page "https://www.ctan.org/pkg/mathdesign")
+ (synopsis "Mathematical fonts to fit with particular text fonts")
+ (description "The Math Design project offers free mathematical
+fonts that match with existing text fonts. To date, three free font
+families are available: Adobe Utopia, URW Garamond and Bitstream
+Charter. Mathdesign covers the whole LaTeX glyph set including AMS
+symbols. Both roman and bold versions of these symbols can be used.
+Moreover, there is a choice between three greek fonts (two of them
+created by the Greek Font Society).")
+ (license license:gpl2+)))
+
+(define-public texlive-bera
+ (package
+ (inherit (simple-texlive-package
+ "texlive-bera"
+ (list "/doc/fonts/bera/"
+ "/fonts/afm/public/bera/"
+ "/fonts/map/dvips/bera/"
+ "/fonts/tfm/public/bera/"
+ "/fonts/type1/public/bera/"
+ "/fonts/vf/public/bera/"
+ "/tex/latex/bera/")
+ (base32
+ "1pkmhhr6ah44xhipjr7nianv03hr4w4bn45xcvp264yw6ymqzqwr")
+ #:trivial? #t))
+ (home-page "https://www.ctan.org/pkg/bera")
+ (synopsis "Bera fonts")
+ (description "The @code{bera} package contains the Bera Type 1
+fonts and files to use the fonts with LaTeX. Bera is a set of three
+font families: Bera Serif (a slab-serif Roman), Bera Sans (a Frutiger
+descendant) and Bera Mono (monospaced/typewriter). The Bera family is
+a repackaging, for use with TeX, of the Bitstream Vera family.")
+ (license license:silofl1.1)))
+
+(define-public texlive-fourier
+ (package
+ (inherit (simple-texlive-package
+ "texlive-fourier"
+ (list "/doc/fonts/fourier/"
+ "/fonts/afm/public/fourier/"
+ "/fonts/map/dvips/fourier/"
+ "/fonts/tfm/public/fourier/"
+ "/fonts/type1/public/fourier/"
+ "/fonts/vf/public/fourier/"
+ "/tex/latex/fourier/")
+ (base32
+ "1vs2xdx6f6hd01zlslx3y93g3dsa7k3yhqpnhgkizgjmz0r9ipz1")
+ #:trivial? #t))
+ (home-page "https://www.ctan.org/pkg/fourier")
+ (synopsis "Utopia fonts for LaTeX documents")
+ (description "Fourier-GUTenberg is a LaTeX typesetting system
+which uses Adobe Utopia as its standard base font. Fourier-GUTenberg
+provides all complementary typefaces needed to allow Utopia based TeX
+typesetting including an extensive mathematics set and several other
+symbols. The system is absolutely stand-alone; apart from Utopia and
+Fourier no other typefaces are required. Utopia is a registered
+trademark of Adobe Systems Incorporated.")
+ (license license:lppl)))
+
+(define-public texlive-utopia
+ (package
+ (inherit (simple-texlive-package
+ "texlive-utopia"
+ (list "/doc/fonts/utopia/"
+ "/fonts/afm/adobe/utopia/"
+ "/fonts/tfm/adobe/utopia/"
+ "/fonts/type1/adobe/utopia/"
+ "/fonts/vf/adobe/utopia/")
+ (base32
+ "113wgkfz4z0ls2grxxfj17l42a1yv9r5ipcd0156xnfsrqvqzxfc")
+ #:trivial? #t))
+ (home-page "https://www.ctan.org/pkg/utopia")
+ (synopsis "Adobe Utopia fonts")
+ (description "The Adobe Standard Encoding set of the Utopia font
+family, as contributed to the X Consortium. The set comprises upright
+and italic shapes in medium and bold weights. Macro support and
+matching maths fonts are provided by the @code{fourier} and
+@code{mathdesign} font packages.")
+ (license (license:fsf-free
+ "http://mirrors.ctan.org/fonts/utopia/README"))))
+
+(define-public texlive-fontaxes
+ (package
+ (name "texlive-fontaxes")
+ (version "1.0e")
+ (source
+ (origin
+ (method svn-fetch)
+ (uri (texlive-ref "latex" "fontaxes"))
+ (file-name (string-append name "-" version "-checkout"))
+ (sha256
+ (base32
+ "19mhp9l7cjw0sbq55c9lz0l2pffkyhyir3i63jqynifjmglbgkl7"))))
+ (build-system texlive-build-system)
+ (arguments '(#:tex-directory "latex/fontaxes"))
+ (home-page "http://www.ctan.org/pkg/fontaxes")
+ (synopsis "Additional font axes for LaTeX")
+ (description "The @code{fontaxes} package adds several new font
+axes on top of LaTeX's New Font Selection Scheme (NFSS). In
+particular, it splits the shape axis into a primary and a secondary
+shape axis and it adds three new axes to deal with the different
+figure versions offered by many professional fonts.")
+ (license license:lppl1.3+)))
+
+(define-public texlive-mweights
+ (package
+ (inherit (simple-texlive-package
+ "texlive-mweights"
+ (list "/doc/latex/mweights/"
+ "/tex/latex/mweights/")
+ (base32
+ "1k2xclk54q3xgn48hji23q52nivkzgwf0s30bmm6k83f7v57qv8h")
+ #:trivial? #t))
+ (home-page "https://www.ctan.org/pkg/mweights")
+ (synopsis "Support for multiple-weight font packages")
+ (description "Many font families available for use with LaTeX are
+available at multiple weights. Many Type 1-oriented support packages
+for such fonts re-define the standard @code{\\mddefault} or
+@code{\\bfdefault} macros. This can create difficulties if the weight
+desired for one font family is not available for another font family,
+or if it differs from the weight desired for another font family. The
+@code{mweights} package provides a solution to these difficulties.")
+ (license license:lppl)))
+
+(define-public texlive-cabin
+ (package
+ (inherit (simple-texlive-package
+ "texlive-cabin"
+ (list "/doc/fonts/cabin/"
+ "/fonts/enc/dvips/cabin/"
+ "/fonts/map/dvips/cabin/"
+ "/fonts/opentype/impallari/cabin/"
+ "/fonts/tfm/impallari/cabin/"
+ "/fonts/type1/impallari/cabin/"
+ "/fonts/vf/impallari/cabin/"
+ "/tex/latex/cabin/")
+ (base32
+ "0dfq9gqch80iyvp58spmpmqfc9h61sjvnddm81ba0af1p8ag8sfg")
+ #:trivial? #t))
+ (home-page "https://www.ctan.org/pkg/cabin")
+ (synopsis "Humanist Sans Serif font with LaTeX support")
+ (description "Cabin is a humanist sans with four weights, true
+italics and small capitals. According to its designer, Pablo
+Impallari, Cabin was inspired by the typefaces of Edward Johnston and
+Eric Gill. Cabin incorporates modern proportions, optical adjustments
+and some elements of the geometric sans. @code{cabin.sty} supports
+use of the font under LaTeX, pdfLaTeX, XeLaTeX and LuaLaTeX. It uses
+the @code{mweights} package to manage the user's view of all those
+font weights. An @code{sfdefault} option is provided to enable Cabin
+as the default text font. The @code{fontaxes} package is required for
+use with [pdf]LaTeX.")
+ (license (list license:silofl1.1 ;for Cabin
+ license:lppl)))) ;for support files
+
+(define-public texlive-newtx
+ (package
+ (inherit (simple-texlive-package
+ "texlive-newtx"
+ (list "/doc/fonts/newtx/"
+ "/fonts/afm/public/newtx/"
+ "/fonts/enc/dvips/newtx/"
+ "/fonts/map/dvips/newtx/"
+ "/fonts/opentype/public/newtx/"
+ "/fonts/tfm/public/newtx/"
+ "/fonts/type1/public/newtx/"
+ "/fonts/vf/public/newtx/"
+ "/tex/latex/newtx/")
+ (base32
+ "0rqjj33m6xkhrjzjhf24kxdg61az5sqsbcl0m7xqkf4akqybn22d")
+ #:trivial? #t))
+ (home-page "https://www.ctan.org/pkg/newtx")
+ (synopsis "Repackaging of the TX fonts with improved metrics")
+ (description "The @code{newtx} bundle splits
+@code{txfonts.sty} (from the TX fonts distribution) into two
+independent packages, @code{newtxtext.sty} and @code{newtxmath.sty},
+each with fixes and enhancements. @code{newtxmath}'s metrics have
+been re-evaluated to provide a less tight appearance and to provide a
+@code{libertine} option that substitutes Libertine italic and Greek
+letters for the existing math italic and Greek glyphs, making a
+mathematics package that matches Libertine text quite well.")
+ (license license:lppl1.3)))
+
+(define-public texlive-xcharter
+ (package
+ (inherit (simple-texlive-package
+ "texlive-xcharter"
+ (list "/doc/fonts/xcharter/"
+ "/fonts/afm/public/xcharter/"
+ "/fonts/enc/dvips/xcharter/"
+ "/fonts/map/dvips/xcharter/"
+ "/fonts/opentype/public/xcharter/"
+ "/fonts/tfm/public/xcharter/"
+ "/fonts/type1/public/xcharter/"
+ "/fonts/vf/public/xcharter/"
+ "/tex/latex/xcharter/")
+ (base32
+ "0krm4h53lw7h9jbmv5nc89fm4x7i8l574aig1l4mw8w3ziknwmi7")
+ #:trivial? #t))
+ (home-page "https://www.ctan.org/pkg/xcharter")
+ (synopsis "Extension of the Bitstream Charter fonts")
+ (description "@code{xcharter} repackages Bitstream Charter with an
+extended set of features. The extension provides small caps, oldstyle
+figures and superior figures in all four styles, accompanied by LaTeX
+font support files. The fonts themselves are provided in both Adobe
+Type 1 and OTF formats, with supporting files as necessary.")
+ (license (list (license:fsf-free
+ "http://mirrors.ctan.org/fonts/xcharter/README")
+ license:lppl1.3))))
+
+(define-public texlive-ly1
+ (package
+ (inherit (simple-texlive-package
+ "texlive-ly1"
+ (list "/doc/fonts/ly1/"
+ "/fonts/enc/dvips/ly1/"
+ "/fonts/map/dvips/ly1/"
+ "/fonts/tfm/adobe/ly1/"
+ "/fonts/vf/adobe/ly1/"
+ "/tex/latex/ly1/")
+ (base32
+ "0wjyw0risgvrq97zfciglwy1f4msvfslln6pz0q8yzzx8wsv3zgq")
+ #:trivial? #t))
+ (home-page "https://www.ctan.org/pkg/ly1")
+ (synopsis "Support for LY1 LaTeX encoding")
+ (description "The legacy @emph{texnansi} (TeX and ANSI) encoding
+is known in the LaTeX scheme of things as @emph{LY1} encoding. The
+@code{ly1} bundle includes metrics and LaTeX macros to use the three
+basic Adobe Type 1 fonts (Times, Helvetica and Courier) in LaTeX using
+LY1 encoding.")
+ (license license:lppl1.0+)))
+
+(define-public texlive-kastrup
+ (package
+ (name "texlive-kastrup")
+ (version (number->string %texlive-revision))
+ (source
+ (origin
+ (method svn-fetch)
+ (uri (texlive-ref "generic" "kastrup"))
+ (file-name (string-append name "-" version "-checkout"))
+ (sha256
+ (base32
+ "1kkshc48brkq2nx3rlbv78a2130izykbf33ri1q2shqr8pjfmmq8"))))
+ (build-system texlive-build-system)
+ (arguments
+ '(#:tex-directory "generic/kastrup"
+ #:phases
+ (modify-phases %standard-phases
+ (add-after 'unpack 'remove-generated-file
+ (lambda _
+ (delete-file "binhex.drv")
+ #t)))))
+ (home-page "http://www.ctan.org/pkg/binhex")
+ (synopsis "Convert numbers into binary, octal and hexadecimal")
+ (description "The @code{kastrup} package provides the
+@emph{binhex.tex} file. This file provides expandable macros for both
+fixed-width and minimum-width numbers to bases 2, 4, 8 and 16. All
+constructs TeX accepts as arguments to its @code{\\number} primitive
+are valid as arguments for the macros. The package may be used under
+LaTeX and plain TeX.")
+ (license (license:fsf-free "file:/binhex.dtx"))))