summaryrefslogtreecommitdiff
path: root/gnu/packages/tls.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/tls.scm')
-rw-r--r--gnu/packages/tls.scm27
1 files changed, 6 insertions, 21 deletions
diff --git a/gnu/packages/tls.scm b/gnu/packages/tls.scm
index be3f8d109d..bb05adb8b7 100644
--- a/gnu/packages/tls.scm
+++ b/gnu/packages/tls.scm
@@ -137,14 +137,14 @@ in intelligent transportation networks.")
(define-public p11-kit
(package
(name "p11-kit")
- (version "0.23.22")
+ (version "0.24.1")
(source
(origin
(method url-fetch)
(uri (string-append "https://github.com/p11-glue/p11-kit/releases/"
"download/" version "/p11-kit-" version ".tar.xz"))
(sha256
- (base32 "1dn6br4v033d3gp2max9lsr3y4q0nj6iyr1yq3kzi8ym7lal13wa"))))
+ (base32 "1y5fm9gwhkh902r26p90qf1g2h1ziqrk4hgf9i9sxm2wzlz7ignq"))))
(build-system gnu-build-system)
(native-inputs
(append (list pkg-config)
@@ -157,7 +157,10 @@ in intelligent transportation networks.")
(list libbsd)
'())))
(arguments
- (list #:configure-flags #~'("--without-trust-paths")
+ (list #:configure-flags
+ ;; Use the default certificates so that users such as flatpak
+ ;; find them. See <https://issues.guix.gnu.org/49957>.
+ #~'("--with-trust-paths=/etc/ssl/certs/ca-certificates.crt")
#:phases #~(modify-phases %standard-phases
#$@(if (hurd-target?)
#~((add-after 'unpack 'apply-hurd-patch
@@ -189,24 +192,6 @@ coordinating the use of PKCS#11 by different components or libraries
living in the same process.")
(license license:bsd-3)))
-(define-public p11-kit-next
- (package
- (inherit p11-kit)
- (version "0.24.1")
- (source
- (origin
- (method url-fetch)
- (uri (string-append "https://github.com/p11-glue/p11-kit/releases/"
- "download/" version "/p11-kit-" version ".tar.xz"))
- (sha256
- (base32 "1y5fm9gwhkh902r26p90qf1g2h1ziqrk4hgf9i9sxm2wzlz7ignq"))))
- (arguments
- ;; Use the default certificates so that users such as flatpak find them.
- ;; See <https://issues.guix.gnu.org/49957>.
- (substitute-keyword-arguments (package-arguments p11-kit)
- ((#:configure-flags flags #~'())
- #~'("--with-trust-paths=/etc/ssl/certs/ca-certificates.crt"))))))
-
(define-public gnutls
(package
(name "gnutls")