summaryrefslogtreecommitdiff
path: root/gnu/packages/tls.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/tls.scm')
-rw-r--r--gnu/packages/tls.scm15
1 files changed, 7 insertions, 8 deletions
diff --git a/gnu/packages/tls.scm b/gnu/packages/tls.scm
index d162094ed4..140932a809 100644
--- a/gnu/packages/tls.scm
+++ b/gnu/packages/tls.scm
@@ -14,7 +14,7 @@
;;; Copyright © 2017 Rutger Helling <rhelling@mykolab.com>
;;; Copyright © 2018 Clément Lassieur <clement@lassieur.org>
;;; Copyright © 2019 Mathieu Othacehe <m.othacehe@gmail.com>
-;;; Copyright © 2020 Jan (janneke) Nieuwenhuizen <janneke@gnu.org>
+;;; Copyright © 2020, 2023 Janneke Nieuwenhuizen <janneke@gnu.org>
;;; Copyright © 2020, 2021, 2023 Maxim Cournoyer <maxim.cournoyer@gmail.com>
;;; Copyright © 2021 Solene Rapenne <solene@perso.pw>
;;; Copyright © 2021 Brice Waegeneire <brice@waegenei.re>
@@ -65,7 +65,6 @@
#:use-module (gnu packages gawk)
#:use-module (gnu packages gettext)
#:use-module (gnu packages guile)
- #:use-module (gnu packages hurd)
#:use-module (gnu packages libbsd)
#:use-module (gnu packages libffi)
#:use-module (gnu packages libidn)
@@ -153,12 +152,12 @@ in intelligent transportation networks.")
(build-system gnu-build-system)
(native-inputs
(append (list pkg-config)
- (if (hurd-target?)
+ (if (target-hurd?)
(list autoconf automake gettext-minimal libtool)
'())))
(inputs
(append (list libffi libtasn1)
- (if (hurd-target?)
+ (if (target-hurd?)
(list libbsd)
'())))
(arguments
@@ -167,7 +166,7 @@ in intelligent transportation networks.")
;; find them. See <https://issues.guix.gnu.org/49957>.
#~'("--with-trust-paths=/etc/ssl/certs/ca-certificates.crt")
#:phases #~(modify-phases %standard-phases
- #$@(if (hurd-target?)
+ #$@(if (target-hurd?)
#~((add-after 'unpack 'apply-hurd-patch
(lambda* (#:key inputs #:allow-other-keys)
(define patch
@@ -216,9 +215,9 @@ living in the same process.")
(build-system gnu-build-system)
(arguments
(list #:tests? (not (or (%current-target-system)
- (hurd-target?)))
+ (target-hurd?)))
;; Ensure we don't keep a reference to the tools used for testing.
- #:disallowed-references (if (hurd-target?)
+ #:disallowed-references (if (target-hurd?)
'()
(list net-tools iproute socat))
#:configure-flags
@@ -276,7 +275,7 @@ living in the same process.")
(native-inputs
(append (list pkg-config texinfo which
util-linux) ;one test needs 'setsid'
- (if (hurd-target?)
+ (if (target-hurd?)
'()
(list net-tools
iproute ;for 'ss'