summaryrefslogtreecommitdiff
path: root/gnu/packages/video.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/video.scm')
-rw-r--r--gnu/packages/video.scm36
1 files changed, 19 insertions, 17 deletions
diff --git a/gnu/packages/video.scm b/gnu/packages/video.scm
index ff52b9b38d..153fe354d5 100644
--- a/gnu/packages/video.scm
+++ b/gnu/packages/video.scm
@@ -319,6 +319,8 @@ video and audio streams from a DVD.")
"https://linuxfromscratch.org/blfs/view/svn/multimedia/transcode.html")
(license license:gpl2+)))
+;;; Warning: this package shouldn't be added as an input anywhere, as it can
+;;; only be used for recent x86_64 CPUs implementing the AVX2 instruction!
(define-public svt-hevc
(package
(name "svt-hevc")
@@ -341,11 +343,12 @@ video and audio streams from a DVD.")
(synopsis "SVT HEVC encoder")
(description "Scalable Video Technology (SVT) is a software-based video
coding technology that is highly optimized for Intel's Xeon processors. Using
-the SVT-HEVC encoder, it is possible to spread video encoding processing across
-multiple Intel's Xeon processors to achieve a real advantage of processing
-efficiency.")
- (home-page "https://01.org/svt")
- ;; Specifically targets x86_64 Intel hardware.
+the SVT-HEVC encoder, it is possible to spread video encoding processing
+across multiple Intel's Xeon processors to achieve a real advantage of
+processing efficiency. Note that this package @emph{requires} the AVX2
+instruction, which means it will @emph{not} work on older x86_64 CPUs such as
+the Core 2 Duo.")
+ (home-page "https://github.com/OpenVisualCloud/SVT-HEVC/")
(supported-systems '("x86_64-linux"))
(license (license:non-copyleft "file:///LICENSE.md"))))
@@ -1054,6 +1057,11 @@ H.264 (MPEG-4 AVC) video streams.")
"--enable-precompiled-headers=no")
#:phases
(modify-phases %standard-phases
+ (add-after 'unpack 'fix-utfcpp-include
+ (lambda _
+ (substitute* "src/common/strings/utf8.cpp"
+ (("<utf8.h>")
+ "<utf8cpp/utf8.h>"))))
(add-after 'unpack 'patch-relative-file-names
(lambda* (#:key outputs #:allow-other-keys)
(let ((out (assoc-ref outputs "out")))
@@ -5002,7 +5010,7 @@ transitions, and effects and then export your film to many common formats.")
(define-public shotcut
(package
(name "shotcut")
- (version "22.12.21")
+ (version "23.07.29")
(source
(origin
(method git-fetch)
@@ -5011,7 +5019,7 @@ transitions, and effects and then export your film to many common formats.")
(commit (string-append "v" version))))
(file-name (git-file-name name version))
(sha256
- (base32 "1hchnywsrkvnz07r2i1cffg1a8zi59pcpswz8x93a0rdc42hlk3d"))))
+ (base32 "1xdybjs39bg361jl7i3rlqdiwhi2xai7x45j7f6cgzygdd833pw5"))))
(build-system qt-build-system)
(arguments
`(#:tests? #f ;there are no tests
@@ -5046,7 +5054,7 @@ transitions, and effects and then export your film to many common formats.")
`("PATH" ":" prefix
,(list (string-append mlt "/bin"))))))))))
(native-inputs
- (list pkg-config python-wrapper qttools-5))
+ (list pkg-config python-wrapper qttools))
(inputs
(list bash-minimal
ffmpeg
@@ -5056,15 +5064,9 @@ transitions, and effects and then export your film to many common formats.")
ladspa
mlt
pulseaudio
- qtbase-5
- qtdeclarative-5
- qtgraphicaleffects
- qtmultimedia-5
- qtquickcontrols-5
- qtquickcontrols2-5
- qtsvg-5
- qtwebsockets-5
- qtx11extras
+ qtbase
+ qtdeclarative
+ qtmultimedia
sdl2))
(home-page "https://www.shotcut.org/")
(synopsis "Video editor built on the MLT framework")