summaryrefslogtreecommitdiff
path: root/gnu/packages/video.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/video.scm')
-rw-r--r--gnu/packages/video.scm19
1 files changed, 8 insertions, 11 deletions
diff --git a/gnu/packages/video.scm b/gnu/packages/video.scm
index 2830aaacd1..6cd2b156e1 100644
--- a/gnu/packages/video.scm
+++ b/gnu/packages/video.scm
@@ -827,7 +827,7 @@ television and DVD. It is also known as AC-3.")
(define-public libaom
(package
(name "libaom")
- (version "3.1.2")
+ (version "3.1.3")
(source (origin
(method git-fetch)
(uri (git-reference
@@ -836,7 +836,7 @@ television and DVD. It is also known as AC-3.")
(file-name (git-file-name name version))
(sha256
(base32
- "1c7yrhb56qj5c3lz54n1f9cbrvdr32g2yrrdiiy72sib8ycq9hz2"))))
+ "08rk31d2cp9k9nj37s6a4n7klpfqfbj62anwyiggzsz7b68psjq3"))))
(build-system cmake-build-system)
(native-inputs
`(("perl" ,perl)
@@ -3699,7 +3699,7 @@ supported players in addition to this package.")
(define-public handbrake
(package
(name "handbrake")
- (version "1.4.1")
+ (version "1.4.2")
(source (origin
(method url-fetch)
(uri (string-append "https://github.com/HandBrake/HandBrake/"
@@ -3707,7 +3707,7 @@ supported players in addition to this package.")
"HandBrake-" version "-source.tar.bz2"))
(sha256
(base32
- "1xhq9jjmf854jf7sg4m754hgajnavwwhmjnaikcf2vgjr35ax81r"))
+ "0qgvdpnjjvh9937cr0yry1lkz5fj6x9pz32fx7s80c9fvjvq33lb"))
(modules '((guix build utils)))
(snippet
;; Remove "contrib" and source not necessary for
@@ -3720,8 +3720,7 @@ supported players in addition to this package.")
;; (ffmpeg, libvpx, libdvdread, libdvdnav, and libbluray),
;; which would lead to fetching and building of these
;; libraries. Use our own instead.
- (("MODULES \\+= contrib") "# MODULES += contrib"))
- #t))))
+ (("MODULES \\+= contrib") "# MODULES += contrib"))))))
(build-system glib-or-gtk-build-system)
(native-inputs
`(("automake" ,automake) ; GUI subpackage must be bootstrapped
@@ -3787,8 +3786,7 @@ supported players in addition to this package.")
(add-before 'configure 'patch-SHELL
(lambda _
(substitute* "gtk/po/Makefile.in.in"
- (("SHELL = /bin/sh") "SHELL = @SHELL@"))
- #t))
+ (("SHELL = /bin/sh") "SHELL = @SHELL@"))))
(add-before 'configure 'relax-reqs
(lambda _
(substitute* "make/configure.py"
@@ -3798,8 +3796,7 @@ supported players in addition to this package.")
;; and ninja are only needed for contrib/libdav1d, and nasm
;; only for libvpx
(("((cmake|meson|ninja|nasm) *=.*abort=)True" _ &)
- (string-append & "False")))
- #t))
+ (string-append & "False")))))
(replace 'configure
(lambda* (#:key outputs configure-flags #:allow-other-keys)
;; 'configure' is not an autoconf-generated script, and
@@ -3810,7 +3807,7 @@ supported players in addition to this package.")
(string-append "--prefix=" out)
(or configure-flags '())))))
(add-after 'configure 'chdir-build
- (lambda _ (chdir "./build") #t)))))
+ (lambda _ (chdir "./build"))))))
(home-page "https://handbrake.fr")
(synopsis "Video transcoder")
(description