summaryrefslogtreecommitdiff
path: root/gnu/packages/web-browsers.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/web-browsers.scm')
-rw-r--r--gnu/packages/web-browsers.scm21
1 files changed, 12 insertions, 9 deletions
diff --git a/gnu/packages/web-browsers.scm b/gnu/packages/web-browsers.scm
index d1cf249231..b876f25882 100644
--- a/gnu/packages/web-browsers.scm
+++ b/gnu/packages/web-browsers.scm
@@ -72,6 +72,7 @@
#:use-module (gnu packages gnupg)
#:use-module (gnu packages gtk)
#:use-module (gnu packages image)
+ #:use-module (gnu packages imagemagick)
#:use-module (gnu packages libevent)
#:use-module (gnu packages libidn)
#:use-module (gnu packages libunistring)
@@ -159,14 +160,14 @@ management, extensions such as advertisement blocker and colorful tabs.")
(define-public links
(package
(name "links")
- (version "2.27")
+ (version "2.28")
(source (origin
(method url-fetch)
(uri (string-append "http://links.twibright.com/download/"
"links-" version ".tar.bz2"))
(sha256
(base32
- "1d7bz6bbis94jq82xydwnazaczzmb1ij62pbmf0dxkg7xpycppfq"))))
+ "1d2lyj9k2s6brk38k51qfpddwh2w96w6gh9jq5br9rfy2fdlkm9g"))))
(build-system gnu-build-system)
(arguments
(list
@@ -711,7 +712,7 @@ is fully configurable and extensible in Common Lisp.")
(define-public lagrange
(package
(name "lagrange")
- (version "1.13.7")
+ (version "1.14.2")
(source
(origin
(method url-fetch)
@@ -719,7 +720,7 @@ is fully configurable and extensible in Common Lisp.")
(string-append "https://git.skyjake.fi/skyjake/lagrange/releases/"
"download/v" version "/lagrange-" version ".tar.gz"))
(sha256
- (base32 "051f7ym1z1hjsxnlvk7gx7b4v12x42i3g9gi49qwy3x8rw30vrvz"))
+ (base32 "0r4cwpgnz761dvkfijq0p7pcyzq6f8bnmivijpnpf3bkzpvmxc2i"))
(modules '((guix build utils)))
(snippet
'(begin
@@ -835,7 +836,7 @@ http, and https via third-party applications.")
(define-public tinmop
(package
(name "tinmop")
- (version "0.9.6")
+ (version "0.9.9.14")
(source
(origin
(method git-fetch)
@@ -844,12 +845,13 @@ http, and https via third-party applications.")
(commit (string-append "v" version))))
(file-name (git-file-name name version))
(sha256
- (base32 "19rr1wcadm4698q5gyq0pxv81220l5g8zfnp61s43a4q7kn4mi1z"))))
+ (base32 "0xpqakqg4827wv92vvzwcvkqzr8d523fvnyjvnj4ac83d4w6nnls"))))
(build-system gnu-build-system)
(native-inputs
(list autoconf
automake
gnu-gettext
+ imagemagick
mandoc
nano
openssl
@@ -918,10 +920,11 @@ http, and https via third-party applications.")
'("LISP_COMPILER) --eval \"(require 'asdf)\" "
"--eval \"(push \\\"$$(pwd)/\\\" asdf:*central-registry*)\" "))))
#t)))))
- (synopsis "Gemini, kami and pleroma client with a terminal interface")
+ (synopsis
+ "Gemini, gopher, kami and pleroma client with a terminal interface")
(description
- "This package provides a Gemini, kami and pleroma client with a terminal
-interface.")
+ "This package provides a Gemini, gopher, kami and pleroma client with a
+terminal interface.")
(home-page "https://www.autistici.org/interzona/tinmop.html")
(license license:gpl3+)))