summaryrefslogtreecommitdiff
path: root/gnu/packages/web.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/web.scm')
-rw-r--r--gnu/packages/web.scm110
1 files changed, 61 insertions, 49 deletions
diff --git a/gnu/packages/web.scm b/gnu/packages/web.scm
index 90f7330f2b..8028f1e977 100644
--- a/gnu/packages/web.scm
+++ b/gnu/packages/web.scm
@@ -64,7 +64,7 @@
;;; Copyright © 2023 David Thompson <dthompson2@worcester.edu>
;;; Copyright © 2023 Christopher Howard <christopher@librehacker.com>
;;; Copyright © 2023 Felix Lechner <felix.lechner@lease-up.com>
-;;; Copyright © 2023 Evgeny Pisemsky <evgeny@pisemsky.com>
+;;; Copyright © 2023 Evgeny Pisemsky <mail@pisemsky.site>
;;; Copyright © 2024 Tomas Volf <~@wolfsden.cz>
;;;
;;; This file is part of GNU Guix.
@@ -148,6 +148,7 @@
#:use-module (gnu packages golang)
#:use-module (gnu packages golang-build)
#:use-module (gnu packages golang-check)
+ #:use-module (gnu packages golang-compression)
#:use-module (gnu packages golang-web)
#:use-module (gnu packages golang-xyz)
#:use-module (gnu packages gperf)
@@ -185,6 +186,7 @@
#:use-module (gnu packages perl)
#:use-module (gnu packages perl-check)
#:use-module (gnu packages perl-compression)
+ #:use-module (gnu packages prometheus)
#:use-module (gnu packages python)
#:use-module (gnu packages python-build)
#:use-module (gnu packages python-check)
@@ -338,51 +340,60 @@ and its related documentation.")
(define-public miniflux
(package
(name "miniflux")
- (version "2.0.46")
- (source (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://github.com/miniflux/v2")
- (commit version)))
- (file-name (git-file-name name version))
- (sha256
- (base32
- "1qv95kipjlg374kiq6gssh5jsb5arahq4jsb7vkg3njnx0ldwvkb"))))
+ (version "2.1.4")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/miniflux/v2")
+ (commit version)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "1m1rcxcjswni3adgjkn3hvb59cbfdh9cl22d5qqwn0lxs8mgqhfl"))))
(build-system go-build-system)
(arguments
- (list #:go go-1.19
- #:install-source? #f
- #:import-path "miniflux.app"
- #:build-flags
- #~(list (string-append
- "-ldflags= -X miniflux.app/version.Version=" #$version))
- #:phases
- #~(modify-phases %standard-phases
- (add-before 'build 'disable-cgo
- (lambda _
- (setenv "CGO_ENABLED" "0")))
- (add-after 'install 'install-manpage
- (lambda* (#:key import-path #:allow-other-keys)
- (let ((man1 (string-append #$output "/share/man/man1/"))
- (page (format #f "src/~a/miniflux.1" import-path)))
- (install-file page man1))))
- (add-after 'install-manpage 'rename-binary
- (lambda _
- (let ((bindir (string-append #$output "/bin/")))
- (rename-file (string-append bindir "miniflux.app")
- (string-append bindir "miniflux"))))))))
+ (list
+ #:go go-1.22
+ #:install-source? #f
+ #:import-path "miniflux.app/v2"
+ #:build-flags
+ #~(list (string-append
+ "-ldflags= -X miniflux.app/v2/internal/version.Version="
+ #$version))
+ #:phases
+ #~(modify-phases %standard-phases
+ ;; XXX: Replace when go-build-system supports nested path.
+ (replace 'check
+ (lambda* (#:key import-path tests? #:allow-other-keys)
+ (when tests?
+ (with-directory-excursion (string-append "src/" import-path)
+ (invoke "go" "test" "-v" "./...")))))
+ (add-after 'install 'install-manpage
+ (lambda* (#:key import-path #:allow-other-keys)
+ (let ((man1 (string-append #$output "/share/man/man1/"))
+ (page (format #f "src/~a/miniflux.1" import-path)))
+ (install-file page man1))))
+ (add-after 'install-manpage 'rename-binary
+ (lambda _
+ (let ((bindir (string-append #$output "/bin/")))
+ (rename-file (string-append bindir "v2")
+ (string-append bindir "miniflux"))))))))
(inputs
- (list go-github-com-coreos-go-oidc-v3
- go-github-com-go-telegram-bot-api-telegram-bot-api
+ (list go-github-com-abadojack-whatlanggo
+ go-github-com-andybalholm-brotli
+ go-github-com-coreos-go-oidc-v3
+ go-github-com-go-webauthn-webauthn
go-github-com-gorilla-mux
go-github-com-lib-pq
- go-github-com-matrix-org-gomatrix
go-github-com-prometheus-client-golang
go-github-com-puerkitobio-goquery
- go-github-com-rylans-getlang
go-github-com-tdewolff-minify-v2
go-github-com-yuin-goldmark
+ go-golang-org-x-crypto
+ go-golang-org-x-net
+ go-golang-org-x-oauth2
go-golang-org-x-term
+ go-golang-org-x-text
go-mvdan-cc-xurls))
(home-page "https://miniflux.app/")
(synopsis "Minimalist and opinionated feed reader")
@@ -397,7 +408,7 @@ and its related documentation.")
@item Use only modern vanilla Javascript (ES6 and Fetch API)
@item Single binary compiled statically without dependency
@item The number of features is voluntarily limited
-@end itemize\n")
+@end itemize")
(license license:asl2.0)))
(define-public mod-wsgi
@@ -458,24 +469,24 @@ replacing them with data URIs.")
(define-public monolith
(package
(name "monolith")
- (version "2.7.0")
+ (version "2.8.1")
(source
(origin
(method git-fetch)
(uri (git-reference
- (url "https://github.com/Y2Z/monolith.git")
+ (url "https://github.com/Y2Z/monolith")
(commit (string-append "v" version))))
(file-name (git-file-name name version))
(sha256
- (base32 "0ccwjsp8gdgp0wafc3zvlfmx3f58axc1k1ac80qha3g60xccqn56"))))
+ (base32 "0xr63302yb5k9c2sihd1iy97j5c44d4jrzfaiwm81d9li577ih58"))))
(build-system cargo-build-system)
(arguments
`(#:cargo-inputs
(("rust-atty" ,rust-atty-0.2)
- ("rust-base64" ,rust-base64-0.13)
+ ("rust-base64" ,rust-base64-0.21)
("rust-chrono" ,rust-chrono-0.4)
("rust-clap" ,rust-clap-3)
- ("rust-cssparser" ,rust-cssparser-0.29)
+ ("rust-cssparser" ,rust-cssparser-0.33)
("rust-encoding-rs" ,rust-encoding-rs-0.8)
("rust-html5ever" ,rust-html5ever-0.24)
("rust-percent-encoding" ,rust-percent-encoding-2)
@@ -533,6 +544,7 @@ the same, being completely separated from the Internet.")
"--with-http_sub_module"
"--with-pcre-jit"
"--with-debug"
+ "--with-compat"
"--with-stream"
"--with-stream_ssl_module"
"--with-http_stub_status_module"
@@ -5182,8 +5194,8 @@ Cloud.")
(license license:expat)))
(define-public guix-data-service
- (let ((commit "b5fbde5ac832e34987a05b1445c1c465c19d5340")
- (revision "52"))
+ (let ((commit "eeda1bf33b42a81a8a295c9e498f3bb44e95d6f1")
+ (revision "53"))
(package
(name "guix-data-service")
(version (string-append "0.0.1-" revision "." (string-take commit 7)))
@@ -5195,7 +5207,7 @@ Cloud.")
(file-name (git-file-name name version))
(sha256
(base32
- "1dp26bj14jaac9f5332pd6hasm3wr1hg9wrbjm9m8wb7cdll9h2p"))))
+ "1dvlzm359iq6dghr7q1prqlkngxcy1198nb0xbv5rpwjp69j2vg9"))))
(build-system gnu-build-system)
(arguments
(list
@@ -5448,7 +5460,7 @@ you'd expect.")
go-github-com-elliotchance-orderedmap
go-github-com-fatih-color
go-github-com-goccy-go-json
- go-github-com-goccy-yaml
+ go-github-com-goccy-go-yaml
go-github-com-jinzhu-copier
go-github-com-magiconair-properties
go-github-com-pelletier-go-toml-v2
@@ -5520,7 +5532,7 @@ time strings.")
(base32 "1dqmnxnipi497nx9x10ifack09w41579svryss5q2w5wxy0pg764"))))
(build-system go-build-system)
(inputs
- (list go-github-com-google-go-cmp-cmp
+ (list go-github-com-google-go-cmp
go-github-com-itchyny-timefmt-go
go-github-com-mattn-go-isatty
go-github-com-mattn-go-runewidth
@@ -5737,7 +5749,7 @@ NetSurf project.")
(define-public ikiwiki
(package
(name "ikiwiki")
- (version "3.20200202.3")
+ (version "3.20200202.4")
(source
(origin
(method git-fetch)
@@ -5747,7 +5759,7 @@ NetSurf project.")
(file-name (git-file-name name version))
(sha256
(base32
- "0fphyqzlk9y8v9s89ypsmrnbhyymzrpc2w0liy0n4knc7kk2pabq"))
+ "04ijislp7png18bg1carb71xk3sij9x5xpizfkxp6jbip6wdxsml"))
(snippet
'(begin
;; The POT file requires write permission during the build