summaryrefslogtreecommitdiff
path: root/gnu/packages/web.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/web.scm')
-rw-r--r--gnu/packages/web.scm8
1 files changed, 8 insertions, 0 deletions
diff --git a/gnu/packages/web.scm b/gnu/packages/web.scm
index 794e2c919d..5c52a32927 100644
--- a/gnu/packages/web.scm
+++ b/gnu/packages/web.scm
@@ -1071,6 +1071,14 @@ instances, while JSON's objects will be mapped to @code{QVariantMap}.")
(substitute* "src/src.pro"
(("/lib64") "/lib"))
#t))
+ (add-after 'unpack 'adjust-mkspecs-directory
+ (lambda* (#:key outputs #:allow-other-keys)
+ (substitute* "src/src.pro"
+ ;; Do not attempt to install the .prf file into qtbase
+ ;; "lib/mkspecs/features", ref <https://bugs.gnu.org/45301>.
+ (("\\$\\$\\[QMAKE_MKSPECS\\]")
+ (string-append (assoc-ref outputs "out") "/lib/qt5/mkspecs")))
+ #t))
(delete 'configure) ; no configure script
(delete 'check) ; no test target
(add-before 'build 'qmake