summaryrefslogtreecommitdiff
path: root/gnu/packages/wine.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/wine.scm')
-rw-r--r--gnu/packages/wine.scm7
1 files changed, 6 insertions, 1 deletions
diff --git a/gnu/packages/wine.scm b/gnu/packages/wine.scm
index 3b637f76e5..88f146b46b 100644
--- a/gnu/packages/wine.scm
+++ b/gnu/packages/wine.scm
@@ -134,7 +134,12 @@
(substitute* "tools/makedep.c"
(("output_filenames\\( unix_libs \\);" all)
(string-append all
- "output ( \" -Wl,-rpath=%s \", arch_install_dirs[arch] );"))))))
+ "output ( \" -Wl,-rpath=%s \", arch_install_dirs[arch] );")))))
+ (add-before 'build 'set-widl-time-override
+ ;; Set WIDL_TIME_OVERRIDE to avoid embedding the current date in
+ ;; files generated by WIDL.
+ (lambda _
+ (setenv "WIDL_TIME_OVERRIDE" "315532800"))))
#:configure-flags
#~(list "--without-freetype"
"--without-x")))