summaryrefslogtreecommitdiff
path: root/gnu/packages/wm.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/wm.scm')
-rw-r--r--gnu/packages/wm.scm64
1 files changed, 54 insertions, 10 deletions
diff --git a/gnu/packages/wm.scm b/gnu/packages/wm.scm
index 505ce09c1a..da1695ff62 100644
--- a/gnu/packages/wm.scm
+++ b/gnu/packages/wm.scm
@@ -73,6 +73,8 @@
;;; Copyright © 2024 James Smith <jsubuntuxp@disroot.org>
;;; Copyright © 2024 bigbug <bigbookofbug@proton.me>
;;; Copyright © 2024 dan <i@dan.games>
+;;; Copyright © 2024 Wamm K. D. <jaft.r@outlook.com>
+;;; Copyright © 2024 Ashish SHUKLA <ashish.is@lostca.se>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -145,6 +147,7 @@
#:use-module (gnu packages logging)
#:use-module (gnu packages lua)
#:use-module (gnu packages man)
+ #:use-module (gnu packages maths)
#:use-module (gnu packages mpd)
#:use-module (gnu packages pciutils)
#:use-module (gnu packages music)
@@ -801,7 +804,7 @@ desktop environment.")
(define-public icewm
(package
(name "icewm")
- (version "3.5.1")
+ (version "3.6.0")
(source (origin
(method url-fetch)
(uri (string-append
@@ -809,7 +812,7 @@ desktop environment.")
version "/icewm-" version ".tar.lz"))
(sha256
(base32
- "0fjxpc46nlv91ijbxkyk33rlwbg2gd9xkr2mikimrba07zahfns5"))))
+ "0xmw4ilzsc932fxqahxvqix66x940nzf54p5mz5p67rplg9sz7wp"))))
(build-system gnu-build-system)
(native-inputs (list pkg-config))
(inputs (list fontconfig
@@ -869,6 +872,24 @@ manager and a system tray.")
(base32 "19qz9a23377nzc0qq8nca45s745mfncd4i2vwba14gi7ipipfcil"))))
(build-system haskell-build-system)
(properties '((upstream-name . "xmonad")))
+ (arguments
+ (list
+ #:phases
+ #~(modify-phases %standard-phases
+ (add-after 'install 'install-xsession
+ (lambda _
+ (let* ((xsessions (string-append #$output "/share/xsessions"))
+ (entry (string-append xsessions "/xmonad.desktop")))
+ (mkdir-p xsessions)
+ (call-with-output-file
+ entry
+ (lambda (port)
+ (format port "~
+ [Desktop Entry]~@
+ Name=xmonad~@
+ Comment=xmonad window manager~@
+ Exec=~a/bin/xmonad~@
+ Type=Application~%" #$output)))))))))
(inputs (list ghc-x11 ghc-data-default-class ghc-setlocale))
(native-inputs (list ghc-quickcheck ghc-quickcheck-classes))
(home-page "http://xmonad.org")
@@ -1139,7 +1160,7 @@ the XDG Autostart specification.")
(define-public fnott
(package
(name "fnott")
- (version "1.6.0")
+ (version "1.7.0")
(source (origin
(method git-fetch)
(uri (git-reference
@@ -1148,7 +1169,7 @@ the XDG Autostart specification.")
(file-name (git-file-name name version))
(sha256
(base32
- "04g1d0app9lpvzq3gxs7qjkd9zgbrmlvfy2n3h464r46j0wpgsx2"))))
+ "0x3wfqkkz6lf9w00nl5mchcw04gx884jxxz6f7z3fxpsjx582nr9"))))
(build-system meson-build-system)
(arguments `(#:build-type "release"
#:phases
@@ -2204,7 +2225,7 @@ compository, supporting the following featuers:
(define-public waybar
(package
(name "waybar")
- (version "0.10.3")
+ (version "0.10.4")
(source
(origin
(method git-fetch)
@@ -2213,7 +2234,7 @@ compository, supporting the following featuers:
(commit version)))
(file-name (git-file-name name version))
(sha256
- (base32 "04xd61ycn1nisq1s5ch14zkbsjcfcy6n29nkjn68s2ribmws0iid"))))
+ (base32 "0liiyz6212pmyhpsrb6773qf5b9b4kb76nggizygr9abfidbg5gw"))))
(build-system meson-build-system)
(arguments
(list #:configure-flags #~(list "--wrap-mode=nodownload")))
@@ -2305,7 +2326,7 @@ core/thread.")
(define-public mako
(package
(name "mako")
- (version "1.8.0")
+ (version "1.9.0")
(source (origin
(method git-fetch)
(uri (git-reference
@@ -2314,7 +2335,7 @@ core/thread.")
(file-name (git-file-name name version))
(sha256
(base32
- "05g1gp61qd9n9w4lq925i4wgryagvah6x489g17j7rnw59q4qhdi"))))
+ "0wcyhnpah1g5qpixfwlpybsjcl22iv39jrxlbi84xv2gfyi2vmj2"))))
(build-system meson-build-system)
(arguments
(list #:phases
@@ -3287,7 +3308,7 @@ read and write, and compatible with JSON.")
(define-public labwc
(package
(name "labwc")
- (version "0.7.2")
+ (version "0.7.4")
(source (origin
(method git-fetch)
(uri (git-reference
@@ -3296,7 +3317,7 @@ read and write, and compatible with JSON.")
(file-name (git-file-name name version))
(sha256
(base32
- "1vlignyv9bczkc8xcmzaj4x88v072qhc79j2pjwnxy9xv0282d7i"))))
+ "0xwgbqv0ablcjaq77c98m4rpgfylr1mja081ay9lccpjqycgbhgc"))))
(build-system meson-build-system)
(native-inputs
(list pkg-config gettext-minimal scdoc))
@@ -3903,6 +3924,7 @@ configuration."))))
alsa-lib
json-c
libmpdclient
+ pulseaudio
eudev))
(synopsis "X11 and Wayland status panel")
(description
@@ -3910,3 +3932,25 @@ configuration."))))
for short) for X11 and Wayland, that goes to great lengths to be both CPU and
battery efficient---polling is only done when absolutely necessary.")
(license license:expat)))
+
+(define-public wf-config
+ (package
+ (name "wf-config")
+ (version "0.8.0")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url (string-append "https://github.com/WayfireWM/" name "/"))
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256 (base32
+ "07x6dapv2xyg0cn44dd2faw5gpk7mwfpbkpld9kyiaa9d44362z1"))))
+ (build-system meson-build-system)
+ (native-inputs (list pkg-config))
+ (inputs (list glm libxml2 wlroots libevdev))
+ (home-page "https://github.com/WayfireWM/wf-config")
+ (synopsis "Library for managing configuration files for Wayfire")
+ (description "The package provides a library for managing the
+configuration files of Wayifre. It can set key and mouse bindings,
+configure input, and customize Wayfire plugins.")
+ (license license:expat)))