summaryrefslogtreecommitdiff
path: root/gnu/packages/wm.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/wm.scm')
-rw-r--r--gnu/packages/wm.scm77
1 files changed, 68 insertions, 9 deletions
diff --git a/gnu/packages/wm.scm b/gnu/packages/wm.scm
index f3997ad171..959928d8e2 100644
--- a/gnu/packages/wm.scm
+++ b/gnu/packages/wm.scm
@@ -41,7 +41,7 @@
;;; Copyright © 2020 B. Wilson <elaexuotee@wilsonb.com>
;;; Copyright © 2020 Niklas Eklund <niklas.eklund@posteo.net>
;;; Copyright © 2020 Robert Smith <robertsmith@posteo.net>
-;;; Copyright © 2021 Zheng Junjie <873216071@qq.com>
+;;; Copyright © 2021, 2023 Zheng Junjie <873216071@qq.com>
;;; Copyright © 2021 Sharlatan Hellseher <sharlatanus@gmail.com>
;;; Copyright © 2021 qblade <qblade@protonmail.com>
;;; Copyright © 2021 lasnesne <lasnesne@lagunposprasihopre.org>
@@ -64,6 +64,8 @@
;;; Copyright © 2023 Jonathan Brielamier <jonathan.brielmaier@web.de>
;;; Copyright © 2023 Vessel Wave <vesselwave@disroot.org>
;;; Copyright © 2023 Nicolas Graves <ngraves@ngraves.fr>
+;;; Copyright © 2023 Jaeme Sifat <jaeme@runbox.com>
+;;; Copyright © 2023 Josselin Poiret <dev@jpoiret.xyz>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -786,7 +788,7 @@ desktop environment.")
(define-public icewm
(package
(name "icewm")
- (version "3.4.3")
+ (version "3.4.5")
(source (origin
(method url-fetch)
(uri (string-append
@@ -794,7 +796,7 @@ desktop environment.")
version "/icewm-" version ".tar.lz"))
(sha256
(base32
- "1r2x7acjahq4666mds1di46zc32sl80592wllghqcp5800jpjcjm"))))
+ "1wd5k0whh2b43a72223cy19pwc29fhrhd2dnc61fha2y5ndgw6ld"))))
(build-system gnu-build-system)
(native-inputs (list pkg-config))
(inputs (list fontconfig
@@ -1083,7 +1085,8 @@ drags, snap-to-border support, and virtual desktops.")
(add-after 'install 'install-vim-files
(lambda* (#:key outputs #:allow-other-keys)
(let* ((out (assoc-ref outputs "out"))
- (syntax (string-append out "/share/vim/vimfiles/syntax")))
+ (syntax (string-append
+ out "/share/vim/vimfiles/pack/guix/start/fluxbox/syntax")))
(copy-recursively "3rd/vim/vim/syntax" syntax)
#t)))
(add-after 'install 'install-xsession
@@ -1490,6 +1493,56 @@ It is inspired by Xmonad and dwm. Its major features include:
project derived from the original Calm Window Manager.")
(license license:isc)))
+(define-public dunst
+ (package
+ (name "dunst")
+ (version "1.9.2")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/dunst-project/dunst")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "17zrw7jrnlyln81pxw7p4jgvl7j1w1gf488nfskhns6j6dcz90gh"))))
+ (build-system gnu-build-system)
+ (arguments
+ (list
+ #:tests? #f ;no check target
+ #:make-flags #~(list (string-append "CC="
+ #$(cc-for-target))
+ (string-append "PREFIX=" %output)
+ (string-append "SYSCONFDIR=" %output "/etc")
+ ;; Otherwise it tries to install service file
+ ;; to "dbus" store directory.
+ (string-append "SERVICEDIR_DBUS=" %output
+ "/share/dbus-1/services")
+ "dunstify")
+ #:phases #~(modify-phases %standard-phases
+ (delete 'configure))))
+ (native-inputs (list pkg-config perl ;for pod2man
+ which))
+ (inputs (list dbus
+ (librsvg-for-system) ;for svg support
+ glib
+ cairo
+ pango
+ libnotify ;for dunstify
+ libx11
+ libxscrnsaver
+ libxinerama
+ libxrandr
+ libxdg-basedir
+ wayland)) ;for wayland support
+ (home-page "https://dunst-project.org/")
+ (synopsis "Customizable and lightweight notification daemon")
+ (description
+ "Dunst is a highly configurable and minimalistic notification daemon.
+It provides @code{org.freedesktop.Notifications} D-Bus service, so it is
+started automatically on the first call via D-Bus.")
+ (license license:bsd-3)))
+
(define-public dwl
(package
(name "dwl")
@@ -1793,9 +1846,15 @@ corners, shadows, inactive window dimming, etc.")
(sha256
(base32 "03jrjwlwxkcyd6m9a1bbwapasnz7b7aws7h0y6jigjm4m478phv6"))))
(build-system meson-build-system)
- (inputs (list cairo gdk-pixbuf libxkbcommon linux-pam wayland))
- (native-inputs (list pango pkg-config scdoc wayland-protocols))
- (home-page "https://github.com/swaywm/sway")
+ (inputs (append (if (%current-target-system)
+ (list wayland-protocols)
+ '())
+ (list cairo gdk-pixbuf libxkbcommon linux-pam wayland)))
+ (native-inputs (append (if (%current-target-system)
+ (list pkg-config-for-build wayland)
+ '())
+ (list pango pkg-config scdoc wayland-protocols)))
+ (home-page "https://github.com/swaywm/swaylock")
(synopsis "Screen locking utility for Wayland compositors")
(description "Swaylock is a screen locking utility for Wayland compositors.")
(license license:expat))) ; MIT license
@@ -1988,7 +2047,7 @@ core/thread.")
(define-public wlr-randr
(package
(name "wlr-randr")
- (version "0.3.0")
+ (version "0.3.1")
(source
(origin
(method git-fetch)
@@ -1997,7 +2056,7 @@ core/thread.")
(commit (string-append "v" version))))
(file-name (git-file-name name version))
(sha256
- (base32 "0cj24fb6s7n8nphvhrp8ldrivjdcrjw64i5v9rsfb6z80q4qg548"))))
+ (base32 "13mya6j5z7cwg2a973y28ya8w36kxhj0fgj8bk9z6yf2w0ryr5xv"))))
(build-system meson-build-system)
(inputs (list wayland))
(native-inputs (list pkg-config))