summaryrefslogtreecommitdiff
path: root/gnu/packages/xdisorg.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/xdisorg.scm')
-rw-r--r--gnu/packages/xdisorg.scm91
1 files changed, 66 insertions, 25 deletions
diff --git a/gnu/packages/xdisorg.scm b/gnu/packages/xdisorg.scm
index 7cf8cc9a67..20702c3a4f 100644
--- a/gnu/packages/xdisorg.scm
+++ b/gnu/packages/xdisorg.scm
@@ -37,6 +37,8 @@
;;; Copyright © 2020 John Soo <jsoo1@asu.edu>
;;; Copyright © 2020 Boris A. Dekshteyn <boris.dekshteyn@gmail.com>
;;; Copyright © 2020 Alex McGrath <amk@amk.ie>
+;;; Copyright © 2020 Ivan Kozlov <kanichos@yandex.ru>
+;;; Copyright © 2020 Brett Gilio <brettg@gnu.org>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -220,7 +222,7 @@ used to further tweak the behaviour of the different profiles.")
(origin
(method git-fetch)
(uri (git-reference
- (url "https://github.com/Cloudef/bemenu.git")
+ (url "https://github.com/Cloudef/bemenu")
(commit version)))
(file-name (git-file-name name version))
(sha256
@@ -264,7 +266,7 @@ with X11 or Wayland, or in a text terminal with ncurses.")
(source (origin
(method git-fetch)
(uri (git-reference
- (url "https://github.com/hluk/CopyQ.git")
+ (url "https://github.com/hluk/CopyQ")
(commit (string-append "v" version))))
(file-name (git-file-name name version))
(sha256
@@ -295,7 +297,7 @@ application.")
(origin
(method git-fetch)
(uri (git-reference
- (url "https://github.com/astrand/xclip.git")
+ (url "https://github.com/astrand/xclip")
(commit version)))
(file-name (git-file-name name version))
(sha256
@@ -626,17 +628,18 @@ move windows, switch between desktops, etc.).")
(define-public scrot
(package
(name "scrot")
- (version "1.3")
+ (version "1.4")
(source
(origin
(method git-fetch)
(uri
(git-reference
- (url "https://github.com/resurrecting-open-source-projects/scrot.git")
+ (url "https://github.com/resurrecting-open-source-projects/scrot")
(commit version)))
(file-name (git-file-name name version))
(sha256
- (base32 "0x70hd59ik37kqd8xqpwrz46np01jv324iz28x2s0kk36d7sblsj"))))
+ (base32
+ "12xq6glg70icwsvbnfw9gm4dahlbnrc7b6adpd0mpf89h4sj2gds"))))
(build-system gnu-build-system)
(native-inputs
`(("autoconf" ,autoconf)
@@ -646,6 +649,7 @@ move windows, switch between desktops, etc.).")
`(("giblib" ,giblib)
("libx11" ,libx11)
("libXcursor" ,libxcursor)
+ ("libxcomposite" ,libxcomposite)
("libXfixes" ,libxfixes)))
(home-page "https://github.com/resurrecting-open-source-projects/scrot")
(synopsis "Command-line screen capture utility for X Window System")
@@ -664,7 +668,7 @@ of the screen selected by mouse.")
(source (origin
(method git-fetch)
(uri (git-reference
- (url "https://github.com/naelstrof/slop.git")
+ (url "https://github.com/naelstrof/slop")
(commit (string-append "v" version))))
(file-name (git-file-name name version))
(sha256
@@ -697,7 +701,7 @@ selection's dimensions to stdout.")
(source (origin
(method git-fetch)
(uri (git-reference
- (url "https://github.com/naelstrof/maim.git")
+ (url "https://github.com/naelstrof/maim")
(commit (string-append "v" version))))
(file-name (git-file-name name version))
(sha256
@@ -1050,7 +1054,7 @@ within a single process.")
(source (origin
(method git-fetch)
(uri (git-reference
- (url "https://github.com/alols/xcape.git")
+ (url "https://github.com/alols/xcape")
(commit (string-append "v" version))))
(file-name (git-file-name name version))
(sha256
@@ -1080,7 +1084,7 @@ Escape key when Left Control is pressed and released on its own.")
(define-public libwacom
(package
(name "libwacom")
- (version "1.3")
+ (version "1.4")
(source (origin
(method url-fetch)
(uri (string-append
@@ -1088,7 +1092,7 @@ Escape key when Left Control is pressed and released on its own.")
"libwacom-" version "/libwacom-" version ".tar.bz2"))
(sha256
(base32
- "0g48cdg2qpvrr2nk8ccibjg3iv7iqskdv66izxacqx70w47y1771"))))
+ "1rk661cymmahak9rw0wcssnfszbngq74vp7zc2cwyg6yrjbif1lh"))))
(build-system glib-or-gtk-build-system)
(arguments
`(#:configure-flags '("--disable-static")))
@@ -1243,7 +1247,7 @@ color temperature should be set to match the lamps in your room.")
(source (origin
(method git-fetch)
(uri (git-reference
- (url "https://github.com/minus7/redshift.git")
+ (url "https://github.com/minus7/redshift")
(commit commit)))
(file-name (string-append name "-" version))
(sha256
@@ -1360,6 +1364,44 @@ demos. It also acts as a nice screen locker.")
"http://metadata.ftp-master.debian.org/changelogs/"
"/main/x/xscreensaver/xscreensaver_5.36-1_copyright")))))
+(define-public xssproxy
+ (package
+ (name "xssproxy")
+ (version "1.0.0")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/timakro/xssproxy")
+ (commit (string-append "v" version))))
+ (file-name (string-append name "-" version "-checkout"))
+ (sha256
+ (base32
+ "0c83wmipnsdnbihc5niyczs7jrkss2s8n6iwwjdia7hkjzbd0hl7"))))
+ (build-system gnu-build-system)
+ (arguments `(#:make-flags `("bindir=/bin"
+ "man1dir=/share/man/man1"
+ ,(string-append "DESTDIR=" (assoc-ref %outputs "out"))
+ "CC=gcc")
+ #:phases (modify-phases %standard-phases
+ (delete 'configure)
+ (delete 'check))))
+ (native-inputs
+ `(("pkg-config" ,pkg-config)))
+ (inputs
+ `(("glib" ,glib)
+ ("libx11" ,libx11)
+ ("libxext" ,libxext)
+ ("libxscrnsaver" ,libxscrnsaver)
+ ("dbus" ,dbus)))
+ (synopsis "Forward freedesktop.org Idle Inhibition Service calls to Xss")
+ (description "xssproxy implements the @code{org.freedesktop.ScreenSaver}
+D-Bus interface described in the Idle Inhibition Service Draft by the
+freedesktop.org developers. The inhibition of the screensaver is then
+controlled using the XScreenSaverSuspend function from the Xss (X11 Screen
+Saver extension) library.")
+ (home-page "https://github.com/timakro/xssproxy")
+ (license license:gpl3+)))
+
(define-public xsel
(package
(name "xsel")
@@ -1513,7 +1555,7 @@ actions, a built-in clock, a battery monitor and a system tray.")
(source (origin
(method git-fetch)
(uri (git-reference
- (url "https://github.com/robm/dzen.git")
+ (url "https://github.com/robm/dzen")
(commit commit)))
(file-name (string-append name "-" version))
(sha256
@@ -1683,7 +1725,7 @@ invert colors on a specific display/screen.")
(source (origin
(method git-fetch)
(uri (git-reference
- (url "https://github.com/dusxmt/nxbelld.git")
+ (url "https://github.com/dusxmt/nxbelld")
(commit version)))
(sha256
(base32
@@ -1879,7 +1921,7 @@ to automatically turn it on on login.")
(source (origin
(method git-fetch)
(uri (git-reference
- (url "https://github.com/zoltanp/xrandr-invert-colors.git")
+ (url "https://github.com/zoltanp/xrandr-invert-colors")
(commit (string-append "v" version))))
(file-name (git-file-name name version))
(sha256
@@ -2014,7 +2056,7 @@ binary to setuid-binaries:
(origin
(method git-fetch)
(uri (git-reference
- (url "https://github.com/bugaevc/wl-clipboard.git")
+ (url "https://github.com/bugaevc/wl-clipboard")
(commit (string-append "v" version))))
(file-name (git-file-name name version))
(sha256
@@ -2064,7 +2106,7 @@ The cutbuffer and clipboard selection are always synchronized.")
(origin
(method git-fetch)
(uri (git-reference
- (url "https://github.com/johanmalm/jgmenu.git")
+ (url "https://github.com/johanmalm/jgmenu")
(commit (string-append "v" version))))
(file-name (git-file-name name version))
(sha256
@@ -2108,7 +2150,7 @@ can optionally use some appearance settings from XSettings, tint2 and GTK.")
(define-public xwallpaper
(package
(name "xwallpaper")
- (version "0.6.4")
+ (version "0.6.5")
(source
(origin
(method git-fetch)
@@ -2117,8 +2159,7 @@ can optionally use some appearance settings from XSettings, tint2 and GTK.")
(commit (string-append "v" version))))
(file-name (git-file-name name version))
(sha256
- (base32
- "175fzifvia58vah2x7509drvfn3xfv5d9szgh9x1w1a1w8rcs2hx"))))
+ (base32 "121ai4dc0v65qk12gn9w62ixly8hc8a5qrygkbb82vy8ck4jqxj7"))))
(build-system gnu-build-system)
(native-inputs
`(("autoconf" ,autoconf)
@@ -2184,7 +2225,7 @@ Xwrits hides itself until you should take another break.")
(origin
(method git-fetch)
(uri (git-reference
- (url "https://github.com/derat/xsettingsd.git")
+ (url "https://github.com/derat/xsettingsd")
(commit (string-append "v" version))))
(file-name (git-file-name name version))
(sha256
@@ -2250,7 +2291,7 @@ configuring visual settings in different UI toolkits separately.")
(origin
(method git-fetch)
(uri (git-reference
- (url "https://github.com/cdown/clipnotify.git")
+ (url "https://github.com/cdown/clipnotify")
(commit version)))
(file-name (git-file-name name version))
(sha256
@@ -2301,7 +2342,7 @@ tools to complement clipnotify.")
(origin
(method git-fetch)
(uri (git-reference
- (url "https://github.com/cdown/clipmenu.git")
+ (url "https://github.com/cdown/clipmenu")
(commit commit)))
(file-name (git-file-name name version))
(sha256
@@ -2380,7 +2421,7 @@ After selection, the clip is put onto the PRIMARY and CLIPBOARD X selections.")
(origin
(method git-fetch)
(uri (git-reference
- (url "https://github.com/qnikst/kbdd.git")
+ (url "https://github.com/qnikst/kbdd")
(commit (string-append "v" version))))
(file-name (git-file-name name version))
(sha256
@@ -2416,7 +2457,7 @@ create layout indicator widgets.")
(source (origin
(method git-fetch)
(uri (git-reference
- (url "https://github.com/enkore/j4-dmenu-desktop.git")
+ (url "https://github.com/enkore/j4-dmenu-desktop")
(commit (string-append "r" version))))
(file-name (git-file-name name version))
(sha256