summaryrefslogtreecommitdiff
path: root/gnu/packages/xdisorg.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/xdisorg.scm')
-rw-r--r--gnu/packages/xdisorg.scm14
1 files changed, 8 insertions, 6 deletions
diff --git a/gnu/packages/xdisorg.scm b/gnu/packages/xdisorg.scm
index 9cc7cc652a..5c4fd79091 100644
--- a/gnu/packages/xdisorg.scm
+++ b/gnu/packages/xdisorg.scm
@@ -3169,14 +3169,16 @@ if there's more than one.")
(define-public xkbset
(package
(name "xkbset")
- (version "0.6")
+ (version "0.8")
(source
(origin
- (method url-fetch)
- (uri (string-append "https://faculty.missouri.edu/~stephen/software/"
- name "/" name "-" version ".tar.gz"))
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/stephenmontgomerysmith/xkbset")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
(sha256
- (base32 "199mlm127zk1lr8nrq22n68l2l8cjwc4cgwd67rg1i6497n2y0xc"))))
+ (base32 "1xa6sgvnwynl2qrjnsppvb2vg4p5v1pisrfhrmnlymw1fzhh6s9p"))))
(build-system gnu-build-system)
(inputs
(list libx11 perl perl-tk))
@@ -3209,7 +3211,7 @@ if there's more than one.")
(string-append (assoc-ref outputs "out")
"/share/doc/" ,name "-" ,version))
#t)))))
- (home-page "https://faculty.missouri.edu/~stephen/software/")
+ (home-page "https://stephenmontgomerysmith.github.io/software/#xkbset")
(synopsis "User-preference utility for XKB extensions for X")
(description
"This is a program to help manage many of the XKB features of the X Window