summaryrefslogtreecommitdiff
path: root/gnu/packages/xml.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/xml.scm')
-rw-r--r--gnu/packages/xml.scm13
1 files changed, 8 insertions, 5 deletions
diff --git a/gnu/packages/xml.scm b/gnu/packages/xml.scm
index fe475e38d1..065f523387 100644
--- a/gnu/packages/xml.scm
+++ b/gnu/packages/xml.scm
@@ -1128,12 +1128,15 @@ Libxml2).")
(inputs
`(("nss" ,nss)
("libltdl" ,libltdl)))
+ (arguments
+ ;; NSS no longer supports MD5 since 3.59, don't attempt to use it.
+ '(#:configure-flags '("--disable-md5")))
(synopsis "XML Security Library (using NSS instead of GnuTLS)")))
(define-public minixml
(package
(name "minixml")
- (version "2.12")
+ (version "3.2")
(source (origin
(method url-fetch)
(uri (string-append "https://github.com/michaelrsweet/mxml/"
@@ -1141,14 +1144,14 @@ Libxml2).")
"/mxml-" version ".tar.gz"))
(sha256
(base32
- "0kq3wiycb40dcyswvajrqb1n5ffm5xcnsfxxaml92vhpl6x57yvb"))))
+ "0x698ayv00vrjg0yfm20lakpgl7m02x1fk2n09wygwk4973gd55q"))))
(build-system gnu-build-system)
(arguments
`(#:configure-flags
(list (string-append "LDFLAGS=-Wl,-rpath="
(assoc-ref %outputs "out") "/lib"))
#:tests? #f)) ; tests are run during build
- (home-page "https://michaelrsweet.github.io/mxml")
+ (home-page "https://www.msweet.org/mxml/")
(synopsis "Small XML parsing library")
(description
"Mini-XML is a small C library to read and write XML files and strings in
@@ -2140,7 +2143,7 @@ outputting XML data from Java code.")
(define-public java-xstream
(package
(name "java-xstream")
- (version "1.4.10")
+ (version "1.4.15")
(source
(origin
(method git-fetch)
@@ -2152,7 +2155,7 @@ outputting XML data from Java code.")
version)))))
(file-name (git-file-name name version))
(sha256
- (base32 "12m2bw8bapdc1w0pni9wl5hh2y8jfdgcvxd464jl9917dsp3ai2n"))))
+ (base32 "1178qryrjwjp44439pi5dxzd32896r5zs429z1qhlc09951r7mi9"))))
(build-system ant-build-system)
(arguments
`(#:jar-name "xstream.jar"