summaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/gnome.scm8
1 files changed, 8 insertions, 0 deletions
diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index 2d694e0822..565d8ad4f8 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -13420,6 +13420,14 @@ libraries. Applications do not need to be recompiled--or even restarted.")
#:configure-flags #~(list "-Dnetwork_tests=false" "-Ddocs=true")
#:phases
#~(modify-phases %standard-phases
+ (add-after 'unpack 'patch-source
+ (lambda _
+ ;; With Gnome 4.14, GtkStackPage has an autoptr already, so it'd
+ ;; get redefined. Drop this phase when updating gnome-builder to
+ ;; 46.0 or newer. See also
+ ;; <https://gitlab.gnome.org/GNOME/gnome-builder/-/commit/7aaaecefc2ea8a37eaeae8b4d726d119d4eb8fa3>
+ (substitute* "src/libide/tweaks/ide-tweaks-window.c"
+ (("G_DEFINE_AUTOPTR_CLEANUP_FUNC \\(GtkStackPage, .*\\)") ""))))
(add-after 'unpack 'patch-meson
(lambda* (#:key inputs #:allow-other-keys)
(substitute* "meson.build"