summaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/patches/casync-renameat2-declaration.patch27
-rw-r--r--gnu/packages/sync.scm67
2 files changed, 37 insertions, 57 deletions
diff --git a/gnu/packages/patches/casync-renameat2-declaration.patch b/gnu/packages/patches/casync-renameat2-declaration.patch
deleted file mode 100644
index 74c2ca7b3c..0000000000
--- a/gnu/packages/patches/casync-renameat2-declaration.patch
+++ /dev/null
@@ -1,27 +0,0 @@
-Fix build failure on glibc 2.28 where 'renameat2' would end up being
-declared twice: <https://github.com/systemd/casync/issues/166>.
-
-From 625244ca47e8ee1375d2d0092271bfd13b0913ea Mon Sep 17 00:00:00 2001
-From: Daniel Mack <daniel@zonque.org>
-Date: Tue, 13 Nov 2018 17:52:48 +0100
-Subject: [PATCH] meson.build: pass -D_GNU_SOURCE when checking for functions
-
-As described in #166, -D_GNU_SOURCE needs to be passed to the meson function
-availability checker. h/t to @tomeon for providing a link to the solution as
-well.
----
- meson.build | 2 +-
- 1 file changed, 1 insertion(+), 1 deletion(-)
-
-diff --git a/meson.build b/meson.build
-index f42ed16..c0f741e 100644
---- a/meson.build
-+++ b/meson.build
-@@ -78,6 +78,6 @@ foreach ident : [
- ['copy_file_range', '''#include <sys/syscall.h>
- #include <unistd.h>'''],
- ]
-- have = cc.has_function(ident[0], prefix : ident[1])
-+ have = cc.has_function(ident[0], args : '-D_GNU_SOURCE', prefix : ident[1])
- conf.set10('HAVE_' + ident[0].to_upper(), have)
- endforeach
diff --git a/gnu/packages/sync.scm b/gnu/packages/sync.scm
index 801aef3f44..3dfaf40796 100644
--- a/gnu/packages/sync.scm
+++ b/gnu/packages/sync.scm
@@ -451,35 +451,42 @@ written in @command{scsh}. It makes use of @command{unison} and
(license license:expat))))
(define-public casync
- (package
- (name "casync")
- (version "2")
- (home-page "https://github.com/systemd/casync/")
- (source (origin
- (method git-fetch)
- (uri (git-reference
- (url home-page)
- (commit (string-append "v" version))))
- (sha256
- (base32
- "0znkp3fcksrykcsv06y2mjvf2lbwmin25snmvfa8i5qfm3f4rm88"))
- (file-name (string-append name "-" version "-checkout"))
- (patches (search-patches "casync-renameat2-declaration.patch"))))
- (build-system meson-build-system)
- (native-inputs
- (list pkg-config python-sphinx rsync)) ;for tests
- (inputs
- (list xz ;for liblzma
- `(,zstd "lib")
- curl
- acl
- libselinux
- fuse
- openssl
- zlib))
- (synopsis "File synchronization and backup system")
- (description
- "casync is a @dfn{content-addressable data synchronizer} that can be used
+ (let ((commit "99559cd1d8cea69b30022261b5ed0b8021415654")
+ (revision "0"))
+ (package
+ (name "casync")
+ (version (git-version "2" revision commit))
+ (home-page "https://github.com/systemd/casync/")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url home-page)
+ (commit commit)))
+ (sha256
+ (base32
+ "139g82rkwv1kzss6crfmw3p01xnyjzz66b1ckprpbfncxb24047w"))
+ (file-name (string-append name "-" version "-checkout"))))
+ (build-system meson-build-system)
+ (arguments
+ `(#:configure-flags
+ (let ((out (assoc-ref %outputs "out")))
+ (list (string-append "-Dudevrulesdir="
+ out "/lib/udev/rules.d")))))
+ (native-inputs
+ (list pkg-config python python-sphinx rsync)) ;for tests
+ (inputs
+ (list xz ;for liblzma
+ `(,zstd "lib")
+ curl
+ acl
+ libselinux
+ eudev
+ fuse
+ openssl
+ zlib))
+ (synopsis "File synchronization and backup system")
+ (description
+ "casync is a @dfn{content-addressable data synchronizer} that can be used
as the basis of a backup system. It is:
@itemize
@@ -490,7 +497,7 @@ large file systems or directory trees;
over the Internet in an HTTP and CDN friendly way;
@item An efficient backup system.
@end itemize\n")
- (license license:lgpl2.1+)))
+ (license license:lgpl2.1+))))
(define-public rclone
(package