summaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/documentation.scm6
-rw-r--r--gnu/packages/patches/doxygen-support-gcc-12.patch15
2 files changed, 2 insertions, 19 deletions
diff --git a/gnu/packages/documentation.scm b/gnu/packages/documentation.scm
index 180b556cbf..e002905fb7 100644
--- a/gnu/packages/documentation.scm
+++ b/gnu/packages/documentation.scm
@@ -187,7 +187,7 @@ markup) can be customized and extended by the user.")
(define-public doxygen
(package
(name "doxygen")
- (version "1.9.4")
+ (version "1.9.5")
(home-page "https://www.doxygen.nl/")
(source (origin
(method url-fetch)
@@ -198,9 +198,7 @@ markup) can be customized and extended by the user.")
".src.tar.gz")))
(sha256
(base32
- "0dqzgci82z950pzg6cpxvvqwybi2031flml3pj47hayhq3c9qpm1"))
- ;; Remove with next release.
- (patches (search-patches "doxygen-support-gcc-12.patch"))))
+ "1v1f9cp5lyymg7xmw0ldnzi7ql8agbaqam1xdyljk0lrbnrm9d2m"))))
(build-system cmake-build-system)
(native-inputs
(list bison
diff --git a/gnu/packages/patches/doxygen-support-gcc-12.patch b/gnu/packages/patches/doxygen-support-gcc-12.patch
deleted file mode 100644
index 01f5040dde..0000000000
--- a/gnu/packages/patches/doxygen-support-gcc-12.patch
+++ /dev/null
@@ -1,15 +0,0 @@
-Fix for https://github.com/doxygen/doxygen/issues/9312 made in unreleased upstream commit
-https://github.com/doxygen/doxygen/commit/5198966c8d5fec89116d025c74934ac03ea511fa
-
-diff --git a/src/cache.h b/src/cache.h
-index 0ff3092ed5..e218eb27d2 100644
---- a/src/cache.h
-+++ b/src/cache.h
-@@ -19,6 +19,7 @@
- #include <list>
- #include <unordered_map>
- #include <mutex>
-+#include <utility>
- #include <ctype.h>
-
- /*! Fixed size cache for value type V using keys of type K.