summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/disk.scm11
-rw-r--r--gnu/packages/golang.scm15
2 files changed, 6 insertions, 20 deletions
diff --git a/gnu/packages/disk.scm b/gnu/packages/disk.scm
index 82b311f459..6f602d645f 100644
--- a/gnu/packages/disk.scm
+++ b/gnu/packages/disk.scm
@@ -1295,8 +1295,7 @@ on your file system and offers to remove it. @command{rmlint} can find:
(define-public lf
(package
(name "lf")
- ;; When updating, remove go-github-com-gdamore-tcell-v2-2.3 from golang.scm.
- (version "27")
+ (version "31")
(source (origin
(method git-fetch)
(uri (git-reference
@@ -1305,13 +1304,15 @@ on your file system and offers to remove it. @command{rmlint} can find:
(file-name (git-file-name name version))
(sha256
(base32
- "1piym8za0iw2s8yryh39y072f90mzisv89ffvn1jzb71f71mbfqa"))))
+ "03icsf4c3j7295s1d8s6srz5gf09a3lghgw3zfcd86p03zhkzsaf"))))
(build-system go-build-system)
(native-inputs
(list go-github-com-mattn-go-runewidth go-golang-org-x-term
- go-gopkg-in-djherbis-times-v1 go-github-com-gdamore-tcell-v2-2.3))
+ go-gopkg-in-djherbis-times-v1 go-github-com-gdamore-tcell-v2
+ go-github-com-djherbis-times))
(arguments
- `(#:import-path "github.com/gokcehan/lf"))
+ `(#:go ,go-1.18
+ #:import-path "github.com/gokcehan/lf"))
(home-page "https://github.com/gokcehan/lf")
(synopsis "Console file browser similar to Ranger")
(description "lf (as in \"list files\") is a terminal file manager
diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index 4ffcfadd42..e2a514a1ac 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -5648,21 +5648,6 @@ systems.")
(modify-inputs (package-inputs go-github-com-gdamore-tcell)
(prepend go-golang-org-x-term go-golang-org-x-sys)))))
-(define-public go-github-com-gdamore-tcell-v2-2.3
- (package
- (inherit go-github-com-gdamore-tcell-v2)
- (name "go-github-com-gdamore-tcell")
- (version "2.3.1")
- (source
- (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://github.com/gdamore/tcell")
- (commit (string-append "v" version))))
- (file-name (git-file-name name version))
- (sha256
- (base32 "0ypbl5080q9sd3irad8mv7zlg4242i8pmg5xyhbyq95kymwibaid"))))))
-
(define-public go-git-sr-ht-rockorager-tcell-term
(package
(name "go-git-sr-ht-rockorager-tcell-term")