summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/golang-web.scm25
-rw-r--r--gnu/packages/golang.scm25
2 files changed, 25 insertions, 25 deletions
diff --git a/gnu/packages/golang-web.scm b/gnu/packages/golang-web.scm
index 3e60bfaf33..07b77ee673 100644
--- a/gnu/packages/golang-web.scm
+++ b/gnu/packages/golang-web.scm
@@ -1119,6 +1119,31 @@ which produce colorized output using github.com/fatih/color.")
(description "OpenTracing-Go is a Go implementation of the OpenTracing API.")
(license license:asl2.0)))
+(define-public go-github-com-pquerna-cachecontrol
+ (package
+ (name "go-github-com-pquerna-cachecontrol")
+ (version "0.2.0")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/pquerna/cachecontrol")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "0d5zgv2w0sinh9m41pw3n015zzyabk7awgwwga7nmhjz452c9r5n"))))
+ (build-system go-build-system)
+ (arguments
+ (list #:import-path "github.com/pquerna/cachecontrol"))
+ (native-inputs
+ (list go-github-com-stretchr-testify))
+ (home-page "https://github.com/pquerna/cachecontrol")
+ (synopsis "Golang HTTP Cache-Control Parser and Interpretation")
+ (description
+ "This package implements RFC 7234 Hypertext Transfer Protocol (HTTP/1.1):
+Caching.")
+ (license license:asl2.0)))
+
(define-public go-github-com-puerkitobio-goquery
(package
(name "go-github-com-puerkitobio-goquery")
diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index 8fea581248..31107b8c8d 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -3891,31 +3891,6 @@ developed by the Go team. It provides IDE features to any LSP-compatible
editor.")
(license license:bsd-3)))
-(define-public go-github-com-pquerna-cachecontrol
- (package
- (name "go-github-com-pquerna-cachecontrol")
- (version "0.2.0")
- (source (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://github.com/pquerna/cachecontrol")
- (commit (string-append "v" version))))
- (file-name (git-file-name name version))
- (sha256
- (base32
- "0d5zgv2w0sinh9m41pw3n015zzyabk7awgwwga7nmhjz452c9r5n"))))
- (build-system go-build-system)
- (arguments
- (list #:import-path "github.com/pquerna/cachecontrol"))
- (native-inputs
- (list go-github-com-stretchr-testify))
- (home-page "https://github.com/pquerna/cachecontrol")
- (synopsis "Golang HTTP Cache-Control Parser and Interpretation")
- (description
- "This package implements RFC 7234 Hypertext Transfer Protocol (HTTP/1.1):
-Caching.")
- (license license:asl2.0)))
-
(define-public go-github-com-protonmail-go-crypto
(package
(name "go-github-com-protonmail-go-crypto")