summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/python-xyz.scm7
1 files changed, 7 insertions, 0 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 32fa9500e9..408c370adf 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -25143,6 +25143,13 @@ tool).")
(modules '((guix build utils)))
(snippet
'(begin
+ ;; Only add CFLAGS on architectures where they are supported
+ (substitute* "setup.py"
+ (("import sys")
+ "import sys\nimport platform")
+ (("os\\.name == 'posix'")
+ (string-append "os.name + platform.machine() == 'posixx86_64' or"
+ " os.name + platform.machine() == 'posixx86'")))
(delete-file-recursively "c-blosc")
(for-each delete-file '("numcodecs/_shuffle.c"
"numcodecs/blosc.c"