summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/freedesktop.scm12
1 files changed, 2 insertions, 10 deletions
diff --git a/gnu/packages/freedesktop.scm b/gnu/packages/freedesktop.scm
index fa0d2e3f48..5519f04b11 100644
--- a/gnu/packages/freedesktop.scm
+++ b/gnu/packages/freedesktop.scm
@@ -372,7 +372,7 @@ the freedesktop.org XDG Base Directory specification.")
(define-public elogind
(package
(name "elogind")
- (version "243.4")
+ (version "243.7")
(source (origin
(method git-fetch)
(uri (git-reference
@@ -381,7 +381,7 @@ the freedesktop.org XDG Base Directory specification.")
(file-name (git-file-name name version))
(sha256
(base32
- "141frvgyk4fafcxsix94qc0d9ffrwksld8lqq4hq6xsgjlvv0mrs"))))
+ "1ccj3cbs9nsfg497wg195in1a7b9csm1jdm7z6q7vvx1ynpjxlxz"))))
(build-system meson-build-system)
(arguments
`(#:configure-flags
@@ -420,14 +420,6 @@ the freedesktop.org XDG Base Directory specification.")
(("join_paths\\(bindir, 'pkttyagent'\\)")
"'\"/run/current-system/profile/bin/pkttyagent\"'"))
#t))
- (add-after 'unpack 'adjust-dbus-socket-address
- (lambda _
- ;; Look for the D-Bus socket in /var/run instead of /run. Remove
- ;; this for versions > 243.4.
- (substitute* "src/libelogind/sd-bus/bus-internal.h"
- (("=/run/dbus/system_bus_socket")
- "=/var/run/dbus/system_bus_socket"))
- #t))
(add-after 'unpack 'adjust-tests
(lambda _
;; This test tries to copy some bytes from /usr/lib/os-release,