summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/aux-files/renpy/renpy.in22
-rw-r--r--gnu/packages/game-development.scm4
2 files changed, 23 insertions, 3 deletions
diff --git a/gnu/packages/aux-files/renpy/renpy.in b/gnu/packages/aux-files/renpy/renpy.in
index 9115d9aee3..deef297aa2 100644
--- a/gnu/packages/aux-files/renpy/renpy.in
+++ b/gnu/packages/aux-files/renpy/renpy.in
@@ -37,7 +37,27 @@ def path_to_saves(gamedir, save_directory=None):
if not save_directory:
return gamedir + "/saves"
- return os.path.join(os.path.expanduser("~/.renpy"), save_directory)
+ prefix = os.environ.get("RENPY_PATH_TO_SAVES",
+ os.path.expanduser("~/.renpy"))
+
+ return os.path.join(prefix, save_directory)
+
+def path_to_logdir(basedir):
+ return basedir
+
+def predefined_searchpath(commondir):
+ import renpy
+
+ # The default gamedir, in private.
+ searchpath = [ renpy.config.gamedir ]
+
+ if env_searchpath := os.environ.get("RENPY_SEARCHPATH"):
+ searchpath.extend(env_searchpath.split("::"))
+
+ if commondir and os.path.isdir(commondir):
+ searchpath.append(commondir)
+
+ return searchpath
def main():
try:
diff --git a/gnu/packages/game-development.scm b/gnu/packages/game-development.scm
index a9284fbea0..ae313a8edf 100644
--- a/gnu/packages/game-development.scm
+++ b/gnu/packages/game-development.scm
@@ -1431,7 +1431,7 @@ developed mainly for Ren'py.")
(define-public python-renpy
(package
(name "python-renpy")
- (version "8.1.3")
+ (version "8.2.0")
(source
(origin
(method url-fetch)
@@ -1439,7 +1439,7 @@ developed mainly for Ren'py.")
"/renpy-" version "-source.tar.bz2"))
(sha256
(base32
- "1g6fz5dxp7yxhgv6q4brzf5hpfqq3l1g3dfv3fsiwwn6mj0b01z2"))
+ "02v54qqjjigfqhdr50kzhkdvplk56bvprq65jl57kcs1qhvlf5s9"))
(modules '((guix build utils)))
(snippet
#~(begin